summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2019-12-03 20:26:28 +0100
committerAndreas K. Huettel <dilfridge@gentoo.org>2020-03-09 11:42:06 +0100
commitd3e4dc37c99518ca1cc88598b00d0ad613a52669 (patch)
treeeec6c0a94355f731fd313e8d42ebe474e325dfa7
parentlibio: Disable vtable validation for pre-2.1 interposed handles [BZ #25203] (diff)
downloadglibc-d3e4dc37c99518ca1cc88598b00d0ad613a52669.tar.gz
glibc-d3e4dc37c99518ca1cc88598b00d0ad613a52669.tar.bz2
glibc-d3e4dc37c99518ca1cc88598b00d0ad613a52669.zip
x86: Assume --enable-cet if GCC defaults to CET [BZ #25225]
This links in CET support if GCC defaults to CET. Otherwise, __CET__ is defined, yet CET functionality is not compiled and linked into the dynamic loader, resulting in a linker failure due to undefined references to _dl_cet_check and _dl_open_check. (cherry picked from commit 761452f12781f2d15a50f2dcd9f40c53bc0ff040)
-rw-r--r--NEWS1
-rwxr-xr-xconfigure23
-rw-r--r--configure.ac9
3 files changed, 31 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 1f60f3eb19..a02fa10df9 100644
--- a/NEWS
+++ b/NEWS
@@ -25,6 +25,7 @@ The following bugs are resolved with this release:
[25189] Don't use a custom wrapper macro around __has_include
[25203] libio: Disable vtable validation for pre-2.1 interposed handles
[25204] Ignore LD_PREFER_MAP_32BIT_EXEC for SUID programs
+ [25225] ld.so fails to link on x86 if GCC defaults to -fcf-protection
Version 2.30
diff --git a/configure b/configure
index c773c487b5..6d26b8246f 100755
--- a/configure
+++ b/configure
@@ -3777,11 +3777,32 @@ else
fi
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+int
+main ()
+{
+
+#ifndef __CET__
+#error no CET compiler support
+#endif
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_compile "$LINENO"; then :
+ libc_cv_compiler_default_cet=yes
+else
+ libc_cv_compiler_default_cet=no
+fi
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+
# Check whether --enable-cet was given.
if test "${enable_cet+set}" = set; then :
enableval=$enable_cet; enable_cet=$enableval
else
- enable_cet=no
+ enable_cet=$libc_cv_compiler_default_cet
fi
diff --git a/configure.ac b/configure.ac
index 598ba6c4ae..7436485419 100644
--- a/configure.ac
+++ b/configure.ac
@@ -472,11 +472,18 @@ AC_ARG_ENABLE([mathvec],
[build_mathvec=$enableval],
[build_mathvec=notset])
+AC_TRY_COMPILE([], [
+#ifndef __CET__
+# error no CET compiler support
+#endif],
+ [libc_cv_compiler_default_cet=yes],
+ [libc_cv_compiler_default_cet=no])
+
AC_ARG_ENABLE([cet],
AC_HELP_STRING([--enable-cet],
[enable Intel Control-flow Enforcement Technology (CET), x86 only]),
[enable_cet=$enableval],
- [enable_cet=no])
+ [enable_cet=$libc_cv_compiler_default_cet])
# We keep the original values in `$config_*' and never modify them, so we
# can write them unchanged into config.make. Everything else uses