summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '2.2/patches')
-rw-r--r--2.2/patches/00_all_gentoo_base.patch24
-rw-r--r--2.2/patches/01_all_mod_rewrite_ampescape.patch11
-rw-r--r--2.2/patches/02_all_gentoo_mod_dir_incremental.patch19
-rw-r--r--2.2/patches/03_all_gentoo-apache-tools.patch12
-rw-r--r--2.2/patches/05_all_CVE-2006-6203.patch12
-rw-r--r--2.2/patches/06_all_CVE-2007-5000.patch8
-rw-r--r--2.2/patches/20_all_peruser_0.3.0.patch51
-rw-r--r--2.2/patches/21_all_itk_20070425-00.patch34
8 files changed, 98 insertions, 73 deletions
diff --git a/2.2/patches/00_all_gentoo_base.patch b/2.2/patches/00_all_gentoo_base.patch
index 3d739f5..8e9cece 100644
--- a/2.2/patches/00_all_gentoo_base.patch
+++ b/2.2/patches/00_all_gentoo_base.patch
@@ -6,8 +6,10 @@ Customizations for Gentoo
support/apxs.in | 11 -----------
4 files changed, 3 insertions(+), 14 deletions(-)
---- a/Makefile.in
-+++ b/Makefile.in
+Index: httpd-2.2.6/Makefile.in
+===================================================================
+--- httpd-2.2.6.orig/Makefile.in
++++ httpd-2.2.6/Makefile.in
@@ -14,7 +14,7 @@ PROGRAM_DEPENDENCIES = \
PROGRAMS = $(PROGRAM_NAME)
@@ -17,8 +19,10 @@ Customizations for Gentoo
install-other install-cgi install-include install-suexec install-build \
install-man
---- a/include/httpd.h
-+++ b/include/httpd.h
+Index: httpd-2.2.6/include/httpd.h
+===================================================================
+--- httpd-2.2.6.orig/include/httpd.h
++++ httpd-2.2.6/include/httpd.h
@@ -155,7 +155,7 @@ extern "C" {
/** The path to the suExec wrapper, can be overridden in Configuration */
@@ -28,8 +32,10 @@ Customizations for Gentoo
#endif
/** The timeout for waiting for messages */
---- a/server/core.c
-+++ b/server/core.c
+Index: httpd-2.2.6/server/core.c
+===================================================================
+--- httpd-2.2.6.orig/server/core.c
++++ httpd-2.2.6/server/core.c
@@ -2794,7 +2794,7 @@ static void set_banner(apr_pool_t *pconf
ap_add_version_component(pconf, AP_SERVER_BASEPRODUCT "/" AP_SERVER_MAJORVERSION);
}
@@ -39,8 +45,10 @@ Customizations for Gentoo
}
/*
---- a/support/apxs.in
-+++ b/support/apxs.in
+Index: httpd-2.2.6/support/apxs.in
+===================================================================
+--- httpd-2.2.6.orig/support/apxs.in
++++ httpd-2.2.6/support/apxs.in
@@ -190,9 +190,6 @@ if (@opt_S) {
my $httpd = get_vars("sbindir") . "/" . get_vars("progname");
$httpd = eval qq("$httpd");
diff --git a/2.2/patches/01_all_mod_rewrite_ampescape.patch b/2.2/patches/01_all_mod_rewrite_ampescape.patch
index 8aaca32..940e1e2 100644
--- a/2.2/patches/01_all_mod_rewrite_ampescape.patch
+++ b/2.2/patches/01_all_mod_rewrite_ampescape.patch
@@ -1,8 +1,9 @@
Provide escaping for the ampersand in mod_rewrite
-diff -ur httpd-2.2.0/modules/mappers/mod_rewrite.c httpd-2.2.0.patched/modules/mappers/mod_rewrite.c
---- httpd-2.2.0/modules/mappers/mod_rewrite.c 2005-11-10 07:20:05.000000000 -0800
-+++ httpd-2.2.0.patched/modules/mappers/mod_rewrite.c 2006-02-04 13:52:34.000000000 -0800
-@@ -1075,6 +1075,30 @@
+Index: httpd-2.2.6/modules/mappers/mod_rewrite.c
+===================================================================
+--- httpd-2.2.6.orig/modules/mappers/mod_rewrite.c
++++ httpd-2.2.6/modules/mappers/mod_rewrite.c
+@@ -1071,6 +1071,30 @@ static char *rewrite_mapfunc_escape(requ
return ap_escape_uri(r->pool, key);
}
@@ -33,7 +34,7 @@ diff -ur httpd-2.2.0/modules/mappers/mod_rewrite.c httpd-2.2.0.patched/modules/m
static char *rewrite_mapfunc_unescape(request_rec *r, char *key)
{
ap_unescape_url(key);
-@@ -4011,6 +4035,7 @@
+@@ -4007,6 +4031,7 @@ static int pre_config(apr_pool_t *pconf,
map_pfn_register("tolower", rewrite_mapfunc_tolower);
map_pfn_register("toupper", rewrite_mapfunc_toupper);
map_pfn_register("escape", rewrite_mapfunc_escape);
diff --git a/2.2/patches/02_all_gentoo_mod_dir_incremental.patch b/2.2/patches/02_all_gentoo_mod_dir_incremental.patch
index 1364386..8253fc0 100644
--- a/2.2/patches/02_all_gentoo_mod_dir_incremental.patch
+++ b/2.2/patches/02_all_gentoo_mod_dir_incremental.patch
@@ -1,7 +1,8 @@
-diff -ur httpd-2.0.58.orig/modules/mappers/mod_dir.c httpd-2.0.58/modules/mappers/mod_dir.c
---- httpd-2.0.58.orig/modules/mappers/mod_dir.c 2007-03-31 19:36:23.000000000 -0400
-+++ httpd-2.0.58/modules/mappers/mod_dir.c 2007-03-31 19:39:22.000000000 -0400
-@@ -39,6 +39,7 @@
+Index: httpd-2.2.6/modules/mappers/mod_dir.c
+===================================================================
+--- httpd-2.2.6.orig/modules/mappers/mod_dir.c
++++ httpd-2.2.6/modules/mappers/mod_dir.c
+@@ -39,6 +39,7 @@ typedef enum {
typedef struct dir_config_struct {
apr_array_header_t *index_names;
@@ -9,7 +10,7 @@ diff -ur httpd-2.0.58.orig/modules/mappers/mod_dir.c httpd-2.0.58/modules/mapper
slash_cfg do_slash;
} dir_config_rec;
-@@ -55,6 +56,23 @@
+@@ -55,6 +56,23 @@ static const char *add_index(cmd_parms *
return NULL;
}
@@ -33,7 +34,7 @@ diff -ur httpd-2.0.58.orig/modules/mappers/mod_dir.c httpd-2.0.58/modules/mapper
static const char *configure_slash(cmd_parms *cmd, void *d_, int arg)
{
dir_config_rec *d = d_;
-@@ -67,6 +85,8 @@
+@@ -67,6 +85,8 @@ static const command_rec dir_cmds[] =
{
AP_INIT_ITERATE("DirectoryIndex", add_index, NULL, DIR_CMD_PERMS,
"a list of file names"),
@@ -42,7 +43,7 @@ diff -ur httpd-2.0.58.orig/modules/mappers/mod_dir.c httpd-2.0.58/modules/mapper
AP_INIT_FLAG("DirectorySlash", configure_slash, NULL, DIR_CMD_PERMS,
"On or Off"),
{NULL}
-@@ -77,6 +97,7 @@
+@@ -77,6 +97,7 @@ static void *create_dir_config(apr_pool_
dir_config_rec *new = apr_pcalloc(p, sizeof(dir_config_rec));
new->index_names = NULL;
@@ -50,7 +51,7 @@ diff -ur httpd-2.0.58.orig/modules/mappers/mod_dir.c httpd-2.0.58/modules/mapper
new->do_slash = SLASH_UNSET;
return (void *) new;
}
-@@ -87,7 +108,26 @@
+@@ -87,7 +108,26 @@ static void *merge_dir_configs(apr_pool_
dir_config_rec *base = (dir_config_rec *)basev;
dir_config_rec *add = (dir_config_rec *)addv;
@@ -78,7 +79,7 @@ diff -ur httpd-2.0.58.orig/modules/mappers/mod_dir.c httpd-2.0.58/modules/mapper
new->do_slash =
(add->do_slash == SLASH_UNSET) ? base->do_slash : add->do_slash;
return new;
-@@ -155,6 +195,14 @@
+@@ -155,6 +195,14 @@ static int fixup_dir(request_rec *r)
return DECLINED;
}
diff --git a/2.2/patches/03_all_gentoo-apache-tools.patch b/2.2/patches/03_all_gentoo-apache-tools.patch
index 9958d07..f4b6612 100644
--- a/2.2/patches/03_all_gentoo-apache-tools.patch
+++ b/2.2/patches/03_all_gentoo-apache-tools.patch
@@ -3,8 +3,10 @@
support/Makefile.in | 18 ++++--------------
2 files changed, 12 insertions(+), 16 deletions(-)
---- a/Makefile.in
-+++ b/Makefile.in
+Index: httpd-2.2.6/Makefile.in
+===================================================================
+--- httpd-2.2.6.orig/Makefile.in
++++ httpd-2.2.6/Makefile.in
@@ -198,14 +198,20 @@ install-include:
$(INSTALL_DATA) $$hdr $(DESTDIR)$(includedir); \
done
@@ -28,8 +30,10 @@
@if test "x$(RSYNC)" != "x" && test -x $(RSYNC) ; then \
$(RSYNC) --exclude .svn -rlpt --numeric-ids $(top_srcdir)/docs/manual/ $(DESTDIR)$(manualdir)/; \
else \
---- a/support/Makefile.in
-+++ b/support/Makefile.in
+Index: httpd-2.2.6/support/Makefile.in
+===================================================================
+--- httpd-2.2.6.orig/support/Makefile.in
++++ httpd-2.2.6/support/Makefile.in
@@ -1,9 +1,8 @@
-DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
diff --git a/2.2/patches/05_all_CVE-2006-6203.patch b/2.2/patches/05_all_CVE-2006-6203.patch
index 4f59287..ab440f3 100644
--- a/2.2/patches/05_all_CVE-2006-6203.patch
+++ b/2.2/patches/05_all_CVE-2006-6203.patch
@@ -1,8 +1,8 @@
-Index: httpd-2.2.x/modules/http/http_protocol.c
+Index: httpd-2.2.6/modules/http/http_protocol.c
===================================================================
---- httpd-2.2.x/modules/http/http_protocol.c (revision 596677)
-+++ httpd-2.2.x/modules/http/http_protocol.c (revision 604192)
-@@ -913,7 +913,8 @@
+--- httpd-2.2.6.orig/modules/http/http_protocol.c
++++ httpd-2.2.6/modules/http/http_protocol.c
+@@ -910,7 +910,8 @@ static const char *get_canned_error_stri
NULL));
case HTTP_METHOD_NOT_ALLOWED:
return(apr_pstrcat(p,
@@ -12,7 +12,7 @@ Index: httpd-2.2.x/modules/http/http_protocol.c
" is not allowed for the URL ",
ap_escape_html(r->pool, r->uri),
".</p>\n",
-@@ -931,7 +932,7 @@
+@@ -928,7 +929,7 @@ static const char *get_canned_error_stri
case HTTP_LENGTH_REQUIRED:
s1 = apr_pstrcat(p,
"<p>A request of the requested method ",
@@ -21,7 +21,7 @@ Index: httpd-2.2.x/modules/http/http_protocol.c
" requires a valid Content-length.<br />\n",
NULL);
return(add_optional_notes(r, s1, "error-notes", "</p>\n"));
-@@ -978,7 +979,7 @@
+@@ -975,7 +976,7 @@ static const char *get_canned_error_stri
"The requested resource<br />",
ap_escape_html(r->pool, r->uri), "<br />\n",
"does not allow request data with ",
diff --git a/2.2/patches/06_all_CVE-2007-5000.patch b/2.2/patches/06_all_CVE-2007-5000.patch
index b329bb5..ab08e1f 100644
--- a/2.2/patches/06_all_CVE-2007-5000.patch
+++ b/2.2/patches/06_all_CVE-2007-5000.patch
@@ -1,8 +1,8 @@
-Index: httpd-2.2.x/modules/mappers/mod_imagemap.c
+Index: httpd-2.2.6/modules/mappers/mod_imagemap.c
===================================================================
---- httpd-2.2.x/modules/mappers/mod_imagemap.c (revision 603710)
-+++ httpd-2.2.x/modules/mappers/mod_imagemap.c (revision 604312)
-@@ -479,13 +479,16 @@
+--- httpd-2.2.6.orig/modules/mappers/mod_imagemap.c
++++ httpd-2.2.6/modules/mappers/mod_imagemap.c
+@@ -479,13 +479,16 @@ static int imap_reply(request_rec *r, ch
static void menu_header(request_rec *r, char *menu)
{
diff --git a/2.2/patches/20_all_peruser_0.3.0.patch b/2.2/patches/20_all_peruser_0.3.0.patch
index 54a0afc..c5cdc58 100644
--- a/2.2/patches/20_all_peruser_0.3.0.patch
+++ b/2.2/patches/20_all_peruser_0.3.0.patch
@@ -1,6 +1,7 @@
-diff -Nur httpd-2.2.3/server/mpm/config.m4 httpd-2.2.3-peruser/server/mpm/config.m4
---- httpd-2.2.3/server/mpm/config.m4 2005-10-30 10:05:26.000000000 -0700
-+++ httpd-2.2.3-peruser/server/mpm/config.m4 2007-09-24 22:52:22.000000000 -0600
+Index: httpd-2.2.6/server/mpm/config.m4
+===================================================================
+--- httpd-2.2.6.orig/server/mpm/config.m4
++++ httpd-2.2.6/server/mpm/config.m4
@@ -1,7 +1,7 @@
AC_MSG_CHECKING(which MPM to use)
AC_ARG_WITH(mpm,
@@ -10,7 +11,7 @@ diff -Nur httpd-2.2.3/server/mpm/config.m4 httpd-2.2.3-peruser/server/mpm/config
APACHE_MPM=$withval
],[
if test "x$APACHE_MPM" = "x"; then
-@@ -23,7 +23,7 @@
+@@ -23,7 +23,7 @@ ap_mpm_is_threaded ()
ap_mpm_is_experimental ()
{
@@ -19,9 +20,10 @@ diff -Nur httpd-2.2.3/server/mpm/config.m4 httpd-2.2.3-peruser/server/mpm/config
return 0
else
return 1
-diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/AUTHORS httpd-2.2.3-peruser/server/mpm/experimental/peruser/AUTHORS
---- httpd-2.2.3/server/mpm/experimental/peruser/AUTHORS 1969-12-31 17:00:00.000000000 -0700
-+++ httpd-2.2.3-peruser/server/mpm/experimental/peruser/AUTHORS 2007-09-28 17:29:01.000000000 -0600
+Index: httpd-2.2.6/server/mpm/experimental/peruser/AUTHORS
+===================================================================
+--- /dev/null
++++ httpd-2.2.6/server/mpm/experimental/peruser/AUTHORS
@@ -0,0 +1,9 @@
+Enrico Weigelt <weigelt [at] metux.de> (MetuxMPM maintainer)
+Sean Gabriel Heacock <gabriel [at] telana.com> (Peruser maintainer)
@@ -32,25 +34,28 @@ diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/AUTHORS httpd-2.2.3-peruse
+Bert <bert [at] ev6.net>
+Leen Besselink <leen [at] consolejunkie.net>
+Steve Amerige <mpm [at] fatbear.com>
-diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/Makefile.in httpd-2.2.3-peruser/server/mpm/experimental/peruser/Makefile.in
---- httpd-2.2.3/server/mpm/experimental/peruser/Makefile.in 1969-12-31 17:00:00.000000000 -0700
-+++ httpd-2.2.3-peruser/server/mpm/experimental/peruser/Makefile.in 2007-09-28 17:29:01.000000000 -0600
+Index: httpd-2.2.6/server/mpm/experimental/peruser/Makefile.in
+===================================================================
+--- /dev/null
++++ httpd-2.2.6/server/mpm/experimental/peruser/Makefile.in
@@ -0,0 +1,5 @@
+
+LTLIBRARY_NAME = libperuser.la
+LTLIBRARY_SOURCES = peruser.c
+
+include $(top_srcdir)/build/ltlib.mk
-diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/config.m4 httpd-2.2.3-peruser/server/mpm/experimental/peruser/config.m4
---- httpd-2.2.3/server/mpm/experimental/peruser/config.m4 1969-12-31 17:00:00.000000000 -0700
-+++ httpd-2.2.3-peruser/server/mpm/experimental/peruser/config.m4 2007-09-28 17:29:01.000000000 -0600
+Index: httpd-2.2.6/server/mpm/experimental/peruser/config.m4
+===================================================================
+--- /dev/null
++++ httpd-2.2.6/server/mpm/experimental/peruser/config.m4
@@ -0,0 +1,3 @@
+if test "$MPM_NAME" = "peruser" ; then
+ APACHE_FAST_OUTPUT(server/mpm/experimental/$MPM_NAME/Makefile)
+fi
-diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/mpm.h httpd-2.2.3-peruser/server/mpm/experimental/peruser/mpm.h
---- httpd-2.2.3/server/mpm/experimental/peruser/mpm.h 1969-12-31 17:00:00.000000000 -0700
-+++ httpd-2.2.3-peruser/server/mpm/experimental/peruser/mpm.h 2007-09-28 17:29:01.000000000 -0600
+Index: httpd-2.2.6/server/mpm/experimental/peruser/mpm.h
+===================================================================
+--- /dev/null
++++ httpd-2.2.6/server/mpm/experimental/peruser/mpm.h
@@ -0,0 +1,103 @@
+/* ====================================================================
+ * The Apache Software License, Version 1.1
@@ -155,9 +160,10 @@ diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/mpm.h httpd-2.2.3-peruser/
+} ap_ctable;
+
+#endif /* APACHE_MPM_PERUSER_H */
-diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/mpm_default.h httpd-2.2.3-peruser/server/mpm/experimental/peruser/mpm_default.h
---- httpd-2.2.3/server/mpm/experimental/peruser/mpm_default.h 1969-12-31 17:00:00.000000000 -0700
-+++ httpd-2.2.3-peruser/server/mpm/experimental/peruser/mpm_default.h 2007-09-28 17:29:01.000000000 -0600
+Index: httpd-2.2.6/server/mpm/experimental/peruser/mpm_default.h
+===================================================================
+--- /dev/null
++++ httpd-2.2.6/server/mpm/experimental/peruser/mpm_default.h
@@ -0,0 +1,110 @@
+/* ====================================================================
+ * The Apache Software License, Version 1.1
@@ -269,9 +275,10 @@ diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/mpm_default.h httpd-2.2.3-
+#endif
+
+#endif /* AP_MPM_DEFAULT_H */
-diff -Nur httpd-2.2.3/server/mpm/experimental/peruser/peruser.c httpd-2.2.3-peruser/server/mpm/experimental/peruser/peruser.c
---- httpd-2.2.3/server/mpm/experimental/peruser/peruser.c 1969-12-31 17:00:00.000000000 -0700
-+++ httpd-2.2.3-peruser/server/mpm/experimental/peruser/peruser.c 2007-10-03 11:28:06.000000000 -0600
+Index: httpd-2.2.6/server/mpm/experimental/peruser/peruser.c
+===================================================================
+--- /dev/null
++++ httpd-2.2.6/server/mpm/experimental/peruser/peruser.c
@@ -0,0 +1,3223 @@
+/* ====================================================================
+ * The Apache Software License, Version 1.1
diff --git a/2.2/patches/21_all_itk_20070425-00.patch b/2.2/patches/21_all_itk_20070425-00.patch
index 58c9706..08200bd 100644
--- a/2.2/patches/21_all_itk_20070425-00.patch
+++ b/2.2/patches/21_all_itk_20070425-00.patch
@@ -1,7 +1,7 @@
-Index: httpd-2.2.4/server/mpm/config.m4
+Index: httpd-2.2.6/server/mpm/config.m4
===================================================================
---- httpd-2.2.4.orig/server/mpm/config.m4
-+++ httpd-2.2.4/server/mpm/config.m4
+--- httpd-2.2.6.orig/server/mpm/config.m4
++++ httpd-2.2.6/server/mpm/config.m4
@@ -1,7 +1,7 @@
AC_MSG_CHECKING(which MPM to use)
AC_ARG_WITH(mpm,
@@ -11,7 +11,7 @@ Index: httpd-2.2.4/server/mpm/config.m4
APACHE_MPM=$withval
],[
if test "x$APACHE_MPM" = "x"; then
-@@ -23,7 +23,7 @@
+@@ -23,7 +23,7 @@ ap_mpm_is_threaded ()
ap_mpm_is_experimental ()
{
@@ -20,7 +20,7 @@ Index: httpd-2.2.4/server/mpm/config.m4
return 0
else
return 1
-@@ -66,6 +66,11 @@
+@@ -66,6 +66,11 @@ if ap_mpm_is_experimental; then
else
MPM_SUBDIR_NAME=$MPM_NAME
fi
@@ -32,16 +32,18 @@ Index: httpd-2.2.4/server/mpm/config.m4
MPM_DIR=server/mpm/$MPM_SUBDIR_NAME
MPM_LIB=$MPM_DIR/lib${MPM_NAME}.la
-Index: httpd-2.2.4/server/mpm/experimental/itk/config.m4
+Index: httpd-2.2.6/server/mpm/experimental/itk/config.m4
+===================================================================
--- /dev/null
-+++ httpd-2.2.4/server/mpm/experimental/itk/config.m4
++++ httpd-2.2.6/server/mpm/experimental/itk/config.m4
@@ -0,0 +1,3 @@
+if test "$MPM_NAME" = "itk" ; then
+ APACHE_FAST_OUTPUT(server/mpm/$MPM_SUBDIR_NAME/Makefile)
+fi
-Index: httpd-2.2.4/server/mpm/experimental/itk/itk.c
+Index: httpd-2.2.6/server/mpm/experimental/itk/itk.c
+===================================================================
--- /dev/null
-+++ httpd-2.2.4/server/mpm/experimental/itk/itk.c
++++ httpd-2.2.6/server/mpm/experimental/itk/itk.c
@@ -0,0 +1,1682 @@
+/* Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed with
@@ -1725,19 +1727,20 @@ Index: httpd-2.2.4/server/mpm/experimental/itk/itk.c
+ itk_cmds, /* command apr_table_t */
+ itk_hooks, /* register hooks */
+};
-Index: httpd-2.2.4/server/mpm/experimental/itk/Makefile.in
+Index: httpd-2.2.6/server/mpm/experimental/itk/Makefile.in
===================================================================
--- /dev/null
-+++ httpd-2.2.4/server/mpm/experimental/itk/Makefile.in
++++ httpd-2.2.6/server/mpm/experimental/itk/Makefile.in
@@ -0,0 +1,5 @@
+
+LTLIBRARY_NAME = libitk.la
+LTLIBRARY_SOURCES = itk.c
+
+include $(top_srcdir)/build/ltlib.mk
-Index: httpd-2.2.4/server/mpm/experimental/itk/mpm_default.h
+Index: httpd-2.2.6/server/mpm/experimental/itk/mpm_default.h
+===================================================================
--- /dev/null
-+++ httpd-2.2.4/server/mpm/experimental/itk/mpm_default.h
++++ httpd-2.2.6/server/mpm/experimental/itk/mpm_default.h
@@ -0,0 +1,77 @@
+/* Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed with
@@ -1816,9 +1819,10 @@ Index: httpd-2.2.4/server/mpm/experimental/itk/mpm_default.h
+
+#endif /* AP_MPM_DEFAULT_H */
+/** @} */
-Index: httpd-2.2.4/server/mpm/experimental/itk/mpm.h
+Index: httpd-2.2.6/server/mpm/experimental/itk/mpm.h
+===================================================================
--- /dev/null
-+++ httpd-2.2.4/server/mpm/experimental/itk/mpm.h
++++ httpd-2.2.6/server/mpm/experimental/itk/mpm.h
@@ -0,0 +1,65 @@
+/* Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed with