summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-02-06 16:53:15 -0600
committerWilliam Hubbs <williamh@gentoo.org>2018-02-06 16:53:15 -0600
commitc4887e88316e2176dc99c173ccc6af825c10f745 (patch)
treeff8643414d409a269f3f0bb1ff2ab837475fd349 /Makefile
parentadd layout-usrmerge to optionally support the /usr merge (diff)
downloadbaselayout-c4887e88316e2176dc99c173ccc6af825c10f745.tar.gz
baselayout-c4887e88316e2176dc99c173ccc6af825c10f745.tar.bz2
baselayout-c4887e88316e2176dc99c173ccc6af825c10f745.zip
Do not install .keep files
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 0 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 966e71ac..35bdb627 100644
--- a/Makefile
+++ b/Makefile
@@ -65,9 +65,7 @@ install:
layout-dirs:
# Create base filesytem layout
for x in $(KEEP_DIRS) ; do \
- test -e $(DESTDIR)$$x/.keep && continue ; \
$(INSTALL_DIR) $(DESTDIR)$$x || exit $$? ; \
- touch $(DESTDIR)$$x/.keep || echo "ignoring touch failure; mounted fs?" ; \
done
layout-BSD: layout-dirs
@@ -82,11 +80,8 @@ layout-Linux: layout-dirs
layout: layout-dirs layout-$(OS)
# Special dirs
install -m 0700 -d $(DESTDIR)/root
- touch $(DESTDIR)/root/.keep
install -m 1777 -d $(DESTDIR)/var/tmp
- touch $(DESTDIR)/var/tmp/.keep
install -m 1777 -d $(DESTDIR)/tmp
- touch $(DESTDIR)/tmp/.keep
# FHS compatibility symlinks stuff
ln -snf /var/tmp $(DESTDIR)/usr/tmp