summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/wile/wile-1.0.5.ebuild')
-rw-r--r--app-crypt/wile/wile-1.0.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/wile/wile-1.0.5.ebuild b/app-crypt/wile/wile-1.0.5.ebuild
new file mode 100644
index 0000000..8d8b140
--- /dev/null
+++ b/app-crypt/wile/wile-1.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="Stripped down letsencrypt (ACME) client"
+HOMEPAGE="https://github.com/costela/wile"
+SRC_URI="https://github.com/costela/wile/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/setuptools-38.5.1[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ >app-crypt/acme-0.22[${PYTHON_USEDEP}]
+ dev-python/josepy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/click-7[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ "
+
+DOCS=( README.md )