aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheofilos Intzoglou <int.teo@gmail.com>2011-10-11 16:29:01 +0300
committerTheofilos Intzoglou <int.teo@gmail.com>2011-10-11 16:29:01 +0300
commit1440dc8c183ec704ba24f659c640e430ee6da58a (patch)
tree2131fcacec689b1180128dca100a457edff6454c
parentMove option in toplevel CMakeLists.txt and changed its name to Qt4 so now we ... (diff)
downloadc-portage-1440dc8c183ec704ba24f659c640e430ee6da58a.tar.gz
c-portage-1440dc8c183ec704ba24f659c640e430ee6da58a.tar.bz2
c-portage-1440dc8c183ec704ba24f659c640e430ee6da58a.zip
Fix includes for C files to get everything building ok
-rw-r--r--src/Qt/helper.cpp1
-rw-r--r--src/Qt/helper.h3
-rw-r--r--src/Qt/qlistconverter.h2
-rw-r--r--src/Qt/qpackageproperties.h3
-rw-r--r--src/Qt/qportage.cpp3
-rw-r--r--src/Qt/qportagesettings.h5
-rw-r--r--src/Qt/tests/test.cpp4
7 files changed, 17 insertions, 4 deletions
diff --git a/src/Qt/helper.cpp b/src/Qt/helper.cpp
index 93a00fe..c745eae 100644
--- a/src/Qt/helper.cpp
+++ b/src/Qt/helper.cpp
@@ -1,5 +1,4 @@
#include "helper.h"
-#include <stringlist.h>
QStringList CListToQStringList(StringList *clist)
{
diff --git a/src/Qt/helper.h b/src/Qt/helper.h
index b45c14a..4979ffb 100644
--- a/src/Qt/helper.h
+++ b/src/Qt/helper.h
@@ -1,5 +1,8 @@
#include <QStringList>
+
+extern "C" {
#include <stringlist.h>
+}
QStringList CListToQStringList(StringList *);
StringList* QStringListToCList(const QStringList&); \ No newline at end of file
diff --git a/src/Qt/qlistconverter.h b/src/Qt/qlistconverter.h
index 83f73fc..ffd52ba 100644
--- a/src/Qt/qlistconverter.h
+++ b/src/Qt/qlistconverter.h
@@ -1,7 +1,9 @@
#ifndef QLISTCONVERTER_H
#define QLISTCONVERTER_H
+extern "C" {
#include "../stringlist.h"
+}
#include <QObject>
diff --git a/src/Qt/qpackageproperties.h b/src/Qt/qpackageproperties.h
index fcda875..bf20cfb 100644
--- a/src/Qt/qpackageproperties.h
+++ b/src/Qt/qpackageproperties.h
@@ -2,7 +2,10 @@
#define QPACKAGEPROPERTIES_H
#include <QObject>
+
+extern "C" {
#include "../packageproperties.h"
+}
class QString;
diff --git a/src/Qt/qportage.cpp b/src/Qt/qportage.cpp
index bf313ea..97359eb 100644
--- a/src/Qt/qportage.cpp
+++ b/src/Qt/qportage.cpp
@@ -20,8 +20,11 @@
#include "helper.h"
#include "qportage.h"
+
+extern "C" {
#include <stringlist.h>
#include <dataconnect.h>
+}
namespace CppPortage {
diff --git a/src/Qt/qportagesettings.h b/src/Qt/qportagesettings.h
index 652020c..f10c565 100644
--- a/src/Qt/qportagesettings.h
+++ b/src/Qt/qportagesettings.h
@@ -3,9 +3,12 @@
#include <QObject>
-#include "../portagesettings.h"
#include "qlistconverter.h"
+extern "C" {
+#include "../portagesettings.h"
+}
+
class QString;
class QStringList;
diff --git a/src/Qt/tests/test.cpp b/src/Qt/tests/test.cpp
index c8329b1..a418551 100644
--- a/src/Qt/tests/test.cpp
+++ b/src/Qt/tests/test.cpp
@@ -1,9 +1,9 @@
-#include <QApplication>
+#include <QCoreApplication>
#include <QDebug>
int main(int argc, char *argv[])
{
- QApplication app(argc,argv);
+ QCoreApplication app(argc,argv);
return app.exec();