aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDetlev Casanova <detlev.casanova@gmail.com>2010-07-30 18:26:36 +0200
committerDetlev Casanova <detlev.casanova@gmail.com>2010-07-30 18:26:36 +0200
commit7d8f4711186f65e26372c867a1729bc1dcd02f73 (patch)
treece9fcc95b38b6b5277a88eb944d3e838785f0b12
parentAdd the use flags functions (diff)
downloadc-portage-7d8f4711186f65e26372c867a1729bc1dcd02f73.tar.gz
c-portage-7d8f4711186f65e26372c867a1729bc1dcd02f73.tar.bz2
c-portage-7d8f4711186f65e26372c867a1729bc1dcd02f73.zip
Fix strdup inclusion
-rw-r--r--Makefile.am1
-rw-r--r--Makefile.in2
-rw-r--r--src/flag.c2
-rw-r--r--src/internal.h1
4 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d2880b9..d4d6895 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
lib_LTLIBRARIES = libportage.la
+#AM_CFLAGS = $(PYTHON_CFLAGS) --std=c99 -W -Wall -O0 -g -D_XOPEN_SOURCE=600
AM_CFLAGS = $(PYTHON_CFLAGS) --std=c99 -W -Wall -O0 -g
libportage_la_SOURCES = src/flag.c src/dataconnect.c src/portagesettings.c src/dict.c src/interpreter.c src/stringlist.c
diff --git a/Makefile.in b/Makefile.in
index c831ec4..55ab34b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -226,6 +226,8 @@ top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = subdir-objects
ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
lib_LTLIBRARIES = libportage.la
+
+#AM_CFLAGS = $(PYTHON_CFLAGS) --std=c99 -W -Wall -O0 -g -D_XOPEN_SOURCE=600
AM_CFLAGS = $(PYTHON_CFLAGS) --std=c99 -W -Wall -O0 -g
libportage_la_SOURCES = src/flag.c src/dataconnect.c src/portagesettings.c src/dict.c src/interpreter.c src/stringlist.c
libportage_la_LIBADD = $(PYTHON_LIBS)
diff --git a/src/flag.c b/src/flag.c
index 64e9c86..dc50afb 100644
--- a/src/flag.c
+++ b/src/flag.c
@@ -1,5 +1,5 @@
-#include "flag.h"
#include "internal.h"
+#include "flag.h"
#include <string.h>
diff --git a/src/internal.h b/src/internal.h
index 8f44213..eb612a5 100644
--- a/src/internal.h
+++ b/src/internal.h
@@ -2,6 +2,7 @@
#define INTERNAL_H
#include <Python.h>
+
#include "stringlist.h"
#include "dict.h"