aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-08-19 21:25:24 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-08-19 21:25:24 -0400
commitb6f3f45d7005db6798f7a608c472b7da8180e7eb (patch)
treed7352f9b9d39166591f4d1702715cee30605e4dc
parentCorrected /etc/conf.d/net configuration to send processor count as DNSMASQ_US... (diff)
downloadclustering-livecd-b6f3f45d7005db6798f7a608c472b7da8180e7eb.tar.gz
clustering-livecd-b6f3f45d7005db6798f7a608c472b7da8180e7eb.tar.bz2
clustering-livecd-b6f3f45d7005db6798f7a608c472b7da8180e7eb.zip
Torque integration tweaks
- server USE flag was mnissing in the livecd specs - added pbs_mom to nfsroot spec NOTE: code is not "functionnal", node-manager is in constant flux as I am figuring out dhcpcd and dnsmasq exhanges of userclass information, which we will use as a means to send the cpu count to the server for the config gilse
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec1
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec1
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec2
-rwxr-xr-xoverlay/sys-cluster/beowulf-head/files/node-manager6
4 files changed, 7 insertions, 3 deletions
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec
index 8b97eeb..b76af0a 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec
@@ -57,6 +57,7 @@ livecd/use:
beep
resolvconf
pbs
+ server
livecd/packages:
app-accessibility/brltty
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec
index 0f811a1..cae5bd5 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec
@@ -77,6 +77,7 @@ boot/kernel/gentoo/packages:
sys-fs/ntfs3g
## kyron: let the fun begin, we need a unionfs-ish FS to be able to configure the clustering stuff on the liveCD
sys-fs/aufs
+## Torque is rebuilt due to kernel dependencies (if cpusets is enabled)
sys-cluster/torque
livecd/rcadd:
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec b/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
index 7567b8d..f1b565f 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
@@ -178,6 +178,8 @@ stage4/rcadd:
portmap|default
sshd|default
vixie-cron|default
+# if we want Torque
+ pbs_mom|default
# This is for removing init script from runlevels. It is executed after the
# defaults shipped with catalyst, so it is possible to remove the defaults using
diff --git a/overlay/sys-cluster/beowulf-head/files/node-manager b/overlay/sys-cluster/beowulf-head/files/node-manager
index 509a9df..e843f24 100755
--- a/overlay/sys-cluster/beowulf-head/files/node-manager
+++ b/overlay/sys-cluster/beowulf-head/files/node-manager
@@ -62,10 +62,10 @@ HNAME=$4
if [[ $COMMAND == "old" ]]
then
- # we background this since it performs a ping with a 1second timeout
+ # we background this since it performs a ping with a 1 second timeout
# on a 256 node system, those seconds add up...
- if [[ $# -lt 5 ]]; then
- # We ignore calls made with odl and only 4 args as we're missing the
+ if [[ $# -lt 4 ]]; then
+ # We ignore calls made with old and only 4 args as we're missing the
# processor count. This can be caused by dnsmasq reloading
# or dnsmasq not setting DNSMASQ_USER_CLASS0 as it seems to happen often
# on subsequent dhcp requests made by the client.