summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-14 16:16:13 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-16 21:18:50 +0200
commit8371d1bbf8c39601fc9d4504aeb32bb4f3197790 (patch)
tree6e1401158392d31c75be5ff7b89f24c717d440d3
parentImport Ghostscript 9.53 (diff)
downloadghostscript-gpl-patches-8371d1bbf8c39601fc9d4504aeb32bb4f3197790.tar.gz
ghostscript-gpl-patches-8371d1bbf8c39601fc9d4504aeb32bb4f3197790.tar.bz2
ghostscript-gpl-patches-8371d1bbf8c39601fc9d4504aeb32bb4f3197790.zip
Import Ghostscript 9.53.1ghostscript-9.53.1
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--Resource/Init/gs_init.ps2
-rw-r--r--base/gsccode.h5
-rw-r--r--base/version.mak4
-rwxr-xr-xconfigure7
-rw-r--r--configure.ac7
-rw-r--r--doc/DLL.htm2
-rw-r--r--doc/Deprecated.htm2
-rw-r--r--doc/Develop.htm2
-rw-r--r--doc/Devices.htm2
-rw-r--r--doc/Drivers.htm2
-rw-r--r--doc/Fonts.htm2
-rw-r--r--doc/History9.htm50
-rw-r--r--doc/Install.htm2
-rw-r--r--doc/Internal.htm2
-rw-r--r--doc/Language.htm2
-rw-r--r--doc/Lib.htm2
-rw-r--r--doc/Make.htm2
-rw-r--r--doc/News.htm8
-rw-r--r--doc/Ps-style.htm2
-rw-r--r--doc/Ps2epsi.htm2
-rw-r--r--doc/Psfiles.htm2
-rw-r--r--doc/Readme.htm2
-rw-r--r--doc/Release.htm2
-rw-r--r--doc/SavedPages.htm2
-rw-r--r--doc/Source.htm2
-rw-r--r--doc/Unix-lpr.htm2
-rw-r--r--doc/Use.htm2
-rw-r--r--doc/VectorDevices.htm2
-rw-r--r--doc/WhatIsGS.htm2
-rw-r--r--doc/gs-vms.hlp2
-rw-r--r--doc/sample_downscale_device.htm2
-rw-r--r--doc/subclass.htm2
-rw-r--r--doc/thirdparty.htm2
-rw-r--r--man/dvipdf.14
-rw-r--r--man/gs.14
-rw-r--r--man/gslp.14
-rw-r--r--man/gsnd.14
-rw-r--r--man/pdf2dsc.14
-rw-r--r--man/pdf2ps.14
-rw-r--r--man/pf2afm.14
-rw-r--r--man/pfbtopfa.14
-rw-r--r--man/printafm.14
-rw-r--r--man/ps2ascii.14
-rw-r--r--man/ps2epsi.14
-rw-r--r--man/ps2pdf.14
-rw-r--r--man/ps2pdfwr.14
-rw-r--r--man/ps2ps.14
47 files changed, 116 insertions, 75 deletions
diff --git a/Resource/Init/gs_init.ps b/Resource/Init/gs_init.ps
index 849e24ef..f843119a 100644
--- a/Resource/Init/gs_init.ps
+++ b/Resource/Init/gs_init.ps
@@ -34,7 +34,7 @@
% Interpreter library version number
% NOTE: the interpreter code requires that the first non-comment token
% in this file be an integer, and that it match the compiled-in version!
-9530
+9531
% Check the interpreter revision.
dup revision ne
diff --git a/base/gsccode.h b/base/gsccode.h
index 433818f0..9ed3aa78 100644
--- a/base/gsccode.h
+++ b/base/gsccode.h
@@ -79,12 +79,7 @@ typedef uint64_t gs_glyph;
#define GS_NO_GLYPH ((gs_glyph)0x7fffffff)
-#if ARCH_SIZEOF_LONG_LONG > 4
# define GS_MIN_CID_GLYPH ((gs_glyph)0x80000000L)
-#else
-/* Avoid compiler warnings about signed/unsigned constants. */
-# define GS_MIN_CID_GLYPH ((gs_glyph)~0x7fffffff)
-#endif
#define GS_MIN_GLYPH_INDEX (GS_MIN_CID_GLYPH | (GS_MIN_CID_GLYPH >> 1))
#define GS_GLYPH_TAG (gs_glyph)(GS_MIN_CID_GLYPH | GS_MIN_GLYPH_INDEX)
diff --git a/base/version.mak b/base/version.mak
index 23098685..f2198432 100644
--- a/base/version.mak
+++ b/base/version.mak
@@ -15,9 +15,9 @@
# Major, minor and patch version numbers.
GS_VERSION_MAJOR=9
GS_VERSION_MINOR=53
-GS_VERSION_PATCH=0
+GS_VERSION_PATCH=1
# Revision date: year x 10000 + month x 100 + day.
-GS_REVISIONDATE=20200910
+GS_REVISIONDATE=20200914
# Derived values
GS_VERSION=$(GS_VERSION_MAJOR)$(GS_VERSION_MINOR)$(GS_VERSION_PATCH)
GS_DOT_VERSION=$(GS_VERSION_MAJOR).$(GS_VERSION_MINOR).$(GS_VERSION_PATCH)
diff --git a/configure b/configure
index 3cc84d31..3ace0a21 100755
--- a/configure
+++ b/configure
@@ -8820,9 +8820,12 @@ $as_echo "$as_me: Could not find local copy of libtiff. Disabling tiff and xps o
;;
esac
-
-if test x"$SHARE_LIBTIFF" != x"$SHARE_LIBJPEG" ; then
+# Skip this check for the recursive configure call.
+# Not relevant for AUX tools.
+if test x"$enable_auxtools_only" != x"yes" ; then
+ if test x"$SHARE_LIBTIFF" != x"$SHARE_LIBJPEG" ; then
as_fn_error $? "Mixing local libtiff with shared libjpeg not supported" "$LINENO" 5
+ fi
fi
CGLAGS_STORE=$CFLAGS
diff --git a/configure.ac b/configure.ac
index d4f56fde..a5c55946 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1617,9 +1617,12 @@ case "x$with_system_libtiff" in
;;
esac
-
-if test x"$SHARE_LIBTIFF" != x"$SHARE_LIBJPEG" ; then
+# Skip this check for the recursive configure call.
+# Not relevant for AUX tools.
+if test x"$enable_auxtools_only" != x"yes" ; then
+ if test x"$SHARE_LIBTIFF" != x"$SHARE_LIBJPEG" ; then
AC_MSG_ERROR([Mixing local libtiff with shared libjpeg not supported])
+ fi
fi
CGLAGS_STORE=$CFLAGS
diff --git a/doc/DLL.htm b/doc/DLL.htm
index a9f25413..9bafe9d5 100644
--- a/doc/DLL.htm
+++ b/doc/DLL.htm
@@ -767,7 +767,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Deprecated.htm b/doc/Deprecated.htm
index e1e5bc91..6003e601 100644
--- a/doc/Deprecated.htm
+++ b/doc/Deprecated.htm
@@ -5764,7 +5764,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Develop.htm b/doc/Develop.htm
index dcc0aece..542fed74 100644
--- a/doc/Develop.htm
+++ b/doc/Develop.htm
@@ -4762,7 +4762,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Devices.htm b/doc/Devices.htm
index 921211a6..b8be9431 100644
--- a/doc/Devices.htm
+++ b/doc/Devices.htm
@@ -2094,7 +2094,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Drivers.htm b/doc/Drivers.htm
index dc1fac45..596fef6d 100644
--- a/doc/Drivers.htm
+++ b/doc/Drivers.htm
@@ -3669,7 +3669,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Fonts.htm b/doc/Fonts.htm
index 941be154..31900929 100644
--- a/doc/Fonts.htm
+++ b/doc/Fonts.htm
@@ -361,7 +361,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/History9.htm b/doc/History9.htm
index 20e67642..51e9db32 100644
--- a/doc/History9.htm
+++ b/doc/History9.htm
@@ -70,7 +70,7 @@ TOC to see how to edit it for visual conciseness.
<h2>Table of contents</h2>
<blockquote><ul>
-<li><a href="#Version9.53.0">Version 9.53.0 (2020-09-10)</a>
+<li><a href="#Version9.53.0">Version 9.53.1 (2020-09-14)</a>
<li><a href="#Version9.52">Version 9.52 (2020-03-19)</a>
<li><a href="#Version9.50">Version 9.50 (2019-10-15)</a>
<li><a href="#Version9.27">Version 9.27 (2019-04-03)</a>
@@ -126,11 +126,11 @@ overview</a>.
<!-- [1.0 end visible header] ============================================== -->
<!-- [2.0 begin contents] ================================================== -->
-<h2><a name="Version9.53.0"></a>Version 9.53.0 (2020-09-10)</h2>
+<h2><a name="Version9.53.1"></a>Version 9.53.1 (2020-09-14)</h2>
<p> Highlights in this release include:
<ul>
<li>
-<p>The 9.53.0 release is primarily maintenance.
+<p>The 9.53.1 release is primarily maintenance.
</li>
<li>
<p>The most obvious change is the (re-)introduction of the patch level to the version number,
@@ -240,7 +240,47 @@ still work as previously for PostScript files. For PDF files, users are encourag
at <a href="https://www.mupdf.com">MuPDF</a>.
</li>
</ul>
-<h3><a name="9.53.0_changelog"></a>Changelog</h3>
+<h3><a name="9.53.1_changelog"></a>Changelog</h3>
+<p><strong>2020-09-14 14:32:23 +0100
+</strong>
+<br>Ken Sharp &lt;ken.sharp@artifex.com&gt;<br>
+<a href="http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=6d1440b2dabde655a2fe48ddbf0c09a82de4d423">6d1440b2dabde655a2fe48ddbf0c09a82de4d423</a>
+<blockquote>
+<p>
+ Fix crashes with pdfwrite, TrueType input fonts and Windows 64-bit build<br>
+<br>
+ With the change to 64-bits unconditionally for gs_glyph we can now<br>
+ define GS_MIN_CID_GLYPH in 64-bit terms.<br>
+<br>
+ Previously we were using the architecture size of a long_long to<br>
+ determine which define to use, and we do not define long_long on Windows<br>
+ leading to us using an essentially 32-bit definition. This caused<br>
+ indexing off the end of an array in copied_glyph_slot()<br>
+<br>
+base/gsccode.h<br>
+<p>
+</blockquote>
+<hr>
+<p><strong>2020-09-14 09:40:30 +0100
+</strong>
+<br>Chris Liddell &lt;chris.liddell@artifex.com&gt;<br>
+<a href="http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=e54e9c5eaebc0bf06e57f754a3c16278de412459">e54e9c5eaebc0bf06e57f754a3c16278de412459</a>
+<blockquote>
+<p>
+ Bug 702897: Fix shared libtiff/libjpeg check<br>
+<br>
+ For various reasons we cannot combine shared and not shared libjpeg and<br>
+ libtiff - they either both need to be &quot;local&quot; or both shared.<br>
+<br>
+ But the check for that compatibility was triggered during the recursive<br>
+ configure call when setting up for cross compiling.<br>
+<br>
+ Skip the check for that recursive configure call.<br>
+<br>
+configure.ac<br>
+<p>
+</blockquote>
+<hr>
<p><strong>2020-09-10 22:47:09 +0800
</strong>
<br>Sebastian Rasmussen &lt;sebras@gmail.com&gt;<br>
@@ -241822,7 +241862,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Install.htm b/doc/Install.htm
index 31ae9352..15ed5c1a 100644
--- a/doc/Install.htm
+++ b/doc/Install.htm
@@ -431,7 +431,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Internal.htm b/doc/Internal.htm
index c7706bbc..0afa6494 100644
--- a/doc/Internal.htm
+++ b/doc/Internal.htm
@@ -109,7 +109,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Language.htm b/doc/Language.htm
index 4da4a0bb..3d27fdda 100644
--- a/doc/Language.htm
+++ b/doc/Language.htm
@@ -2079,7 +2079,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Lib.htm b/doc/Lib.htm
index aa240f69..30484f8c 100644
--- a/doc/Lib.htm
+++ b/doc/Lib.htm
@@ -1038,7 +1038,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Make.htm b/doc/Make.htm
index 9ca66b04..ffb859ae 100644
--- a/doc/Make.htm
+++ b/doc/Make.htm
@@ -1518,7 +1518,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/News.htm b/doc/News.htm
index 75c18da1..de256246 100644
--- a/doc/News.htm
+++ b/doc/News.htm
@@ -86,11 +86,11 @@ overview</a>.
<!-- [1.0 end visible header] ============================================== -->
<!-- [2.0 begin contents] ================================================== -->
-<h2><a name="Version9.53.0"></a>Version 9.53.0 (2020-09-10)</h2>
+<h2><a name="Version9.53.0"></a>Version 9.53.1 (2020-09-14)</h2>
<p> Highlights in this release include:
<ul>
<li>
-<p>The 9.53.0 release is primarily maintenance.
+<p>The 9.53.1 release is primarily maintenance.
</li>
<li>
<p>The most obvious change is the (re-)introduction of the patch level to the version number,
@@ -200,7 +200,7 @@ still work as previously for PostScript files. For PDF files, users are encourag
at <a href="https://www.mupdf.com">MuPDF</a>.
</li>
</ul>
-<h3><a name="9.53.0_changelog"></a>Changelog</h3>
+<h3><a name="9.53.1_changelog"></a>Changelog</h3>
<p>See the <a href="History9.htm">history file</a> for complete log
of changes.
@@ -225,7 +225,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Ps-style.htm b/doc/Ps-style.htm
index 862e6460..559c6758 100644
--- a/doc/Ps-style.htm
+++ b/doc/Ps-style.htm
@@ -540,7 +540,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Ps2epsi.htm b/doc/Ps2epsi.htm
index ed352607..9af6fd87 100644
--- a/doc/Ps2epsi.htm
+++ b/doc/Ps2epsi.htm
@@ -220,7 +220,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Psfiles.htm b/doc/Psfiles.htm
index 119054af..73aa9f14 100644
--- a/doc/Psfiles.htm
+++ b/doc/Psfiles.htm
@@ -885,7 +885,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Readme.htm b/doc/Readme.htm
index 9c27128e..2d5f5f0a 100644
--- a/doc/Readme.htm
+++ b/doc/Readme.htm
@@ -572,7 +572,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Release.htm b/doc/Release.htm
index 4795a73f..e164517f 100644
--- a/doc/Release.htm
+++ b/doc/Release.htm
@@ -836,7 +836,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/SavedPages.htm b/doc/SavedPages.htm
index e70d4546..cbce7ce1 100644
--- a/doc/SavedPages.htm
+++ b/doc/SavedPages.htm
@@ -308,7 +308,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Source.htm b/doc/Source.htm
index 77f7c8bb..9d82f391 100644
--- a/doc/Source.htm
+++ b/doc/Source.htm
@@ -456,7 +456,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Unix-lpr.htm b/doc/Unix-lpr.htm
index 320ade33..cf1e69a7 100644
--- a/doc/Unix-lpr.htm
+++ b/doc/Unix-lpr.htm
@@ -295,7 +295,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/Use.htm b/doc/Use.htm
index e8bc3796..b09927fd 100644
--- a/doc/Use.htm
+++ b/doc/Use.htm
@@ -5308,7 +5308,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/VectorDevices.htm b/doc/VectorDevices.htm
index fae407d7..23a1fdf0 100644
--- a/doc/VectorDevices.htm
+++ b/doc/VectorDevices.htm
@@ -1401,7 +1401,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/WhatIsGS.htm b/doc/WhatIsGS.htm
index 2f0ecc6c..967934d6 100644
--- a/doc/WhatIsGS.htm
+++ b/doc/WhatIsGS.htm
@@ -180,7 +180,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/gs-vms.hlp b/doc/gs-vms.hlp
index 125faa30..c04994bd 100644
--- a/doc/gs-vms.hlp
+++ b/doc/gs-vms.hlp
@@ -1,6 +1,6 @@
1 gs
gs - GPL Ghostscript interpreter/previewer
-! Ghostscript version 9.53.0, 10 September 2020
+! Ghostscript version 9.53.1, 14 September 2020
Usage:
$ gs [options] [file ...]
diff --git a/doc/sample_downscale_device.htm b/doc/sample_downscale_device.htm
index dbae06ad..ea4c6da9 100644
--- a/doc/sample_downscale_device.htm
+++ b/doc/sample_downscale_device.htm
@@ -254,7 +254,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
<!--FINISH EDITING HERE-->
diff --git a/doc/subclass.htm b/doc/subclass.htm
index e52a2ce7..74a98c86 100644
--- a/doc/subclass.htm
+++ b/doc/subclass.htm
@@ -803,7 +803,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/doc/thirdparty.htm b/doc/thirdparty.htm
index 10c57d05..593164a0 100644
--- a/doc/thirdparty.htm
+++ b/doc/thirdparty.htm
@@ -244,7 +244,7 @@ or contact Artifex Software, Inc., 1305 Grant Avenue - Suite 200,
Novato, CA 94945, U.S.A., +1(415)492-9861, for further information.
<p>
-<small>Ghostscript version 9.53.0, 10 September 2020
+<small>Ghostscript version 9.53.1, 14 September 2020
<!-- [3.0 end visible trailer] ============================================= -->
diff --git a/man/dvipdf.1 b/man/dvipdf.1
index 446b237d..114428fe 100644
--- a/man/dvipdf.1
+++ b/man/dvipdf.1
@@ -1,4 +1,4 @@
-.TH DVIPDF 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH DVIPDF 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
dvipdf \- Convert TeX DVI file to PDF using ghostscript and dvips
.SH SYNOPSIS
@@ -21,7 +21,7 @@ and any options from the command-line.
.SH SEE ALSO
gs(1), dvips(1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/gs.1 b/man/gs.1
index 2cd715fc..b094134b 100644
--- a/man/gs.1
+++ b/man/gs.1
@@ -1,4 +1,4 @@
-.TH GS 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH GS 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
gs \- Ghostscript (PostScript and PDF language interpreter and previewer)
.SH SYNOPSIS
@@ -442,7 +442,7 @@ The various Ghostscript document files (above), especially \fBUse.htm\fR.
See http://bugs.ghostscript.com/ and the Usenet news group
comp.lang.postscript.
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the primary maintainers
of Ghostscript.
diff --git a/man/gslp.1 b/man/gslp.1
index 149c52ae..322d65f5 100644
--- a/man/gslp.1
+++ b/man/gslp.1
@@ -1,4 +1,4 @@
-.TH GSLP 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH GSLP 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
gslp \- Format and print text using ghostscript
.br
@@ -92,7 +92,7 @@ Also, the string %# in a heading or footing is replaced with the page #.
.SH SEE ALSO
gs(1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/gsnd.1 b/man/gsnd.1
index 373ca32d..5bbcef01 100644
--- a/man/gsnd.1
+++ b/man/gsnd.1
@@ -1,4 +1,4 @@
-.TH GSND 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH GSND 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
gsnd \- Run ghostscript (PostScript and PDF engine) without display
.SH SYNOPSIS
@@ -12,7 +12,7 @@ flag, followed by any other arguments from the command-line.
.SH SEE ALSO
gs(1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/pdf2dsc.1 b/man/pdf2dsc.1
index 6fcce730..9cac8568 100644
--- a/man/pdf2dsc.1
+++ b/man/pdf2dsc.1
@@ -1,4 +1,4 @@
-.TH PDF2DSC 1 "10 September 2020" 9.53.0 "Ghostscript Tools" \" -*- nroff -*-
+.TH PDF2DSC 1 "14 September 2020" 9.53.1 "Ghostscript Tools" \" -*- nroff -*-
.SH NAME
pdf2dsc \- generate a PostScript page list of a PDF document
.SH SYNOPSIS
@@ -28,6 +28,6 @@ Ghostscript since release 3.53.
.SH SEE ALSO
gs(1), ghostview(1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Yves Arrouye <yves.arrouye@usa.net> and Russell Lang gsview at ghostgum.com.au
diff --git a/man/pdf2ps.1 b/man/pdf2ps.1
index fd76709c..bd424820 100644
--- a/man/pdf2ps.1
+++ b/man/pdf2ps.1
@@ -1,4 +1,4 @@
-.TH PDF2PS 1 "10 September 2020" 9.53.0 "Ghostscript Tools" \" -*- nroff -*-
+.TH PDF2PS 1 "14 September 2020" 9.53.1 "Ghostscript Tools" \" -*- nroff -*-
.SH NAME
pdf2ps \- Ghostscript PDF to PostScript translator
.SH SYNOPSIS
@@ -14,7 +14,7 @@ LanguageLevel 3 in the output.
Run "\fBgs -h\fR" to find the location of Ghostscript documentation on your
system, from which you can get more details.
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/pf2afm.1 b/man/pf2afm.1
index 87de712a..8120cb0b 100644
--- a/man/pf2afm.1
+++ b/man/pf2afm.1
@@ -1,4 +1,4 @@
-.TH PF2AFM 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH PF2AFM 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
pf2afm \- Make an AFM file from Postscript (PFB/PFA/PFM) font files using ghostscript
.SH SYNOPSIS
@@ -15,7 +15,7 @@ gs(1)
.br
pf2afm.ps in the Ghostscript lib directory.
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/pfbtopfa.1 b/man/pfbtopfa.1
index a245a851..0179db74 100644
--- a/man/pfbtopfa.1
+++ b/man/pfbtopfa.1
@@ -1,4 +1,4 @@
-.TH PFBTOPFA 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH PFBTOPFA 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
pfbtopfa \- Convert Postscript .pfb fonts to .pfa format using ghostscript
.SH SYNOPSIS
@@ -10,7 +10,7 @@ to convert a .pfb file into a .pfa file.
.SH SEE ALSO
gs(1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/printafm.1 b/man/printafm.1
index 75aca2b4..664a1c23 100644
--- a/man/printafm.1
+++ b/man/printafm.1
@@ -1,4 +1,4 @@
-.TH PRINTAFM 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH PRINTAFM 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
printafm \- Print the metrics from a Postscript font in AFM format using ghostscript
.SH SYNOPSIS
@@ -11,7 +11,7 @@ Output goes to stdout.
.SH SEE ALSO
gs(1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/ps2ascii.1 b/man/ps2ascii.1
index 8f1db5ea..a2dcd066 100644
--- a/man/ps2ascii.1
+++ b/man/ps2ascii.1
@@ -1,4 +1,4 @@
-.TH PS2ASCII 1 "10 September 2020" 9.53.0 "Ghostscript Tools" \" -*- nroff -*-
+.TH PS2ASCII 1 "14 September 2020" 9.53.1 "Ghostscript Tools" \" -*- nroff -*-
.SH NAME
ps2ascii \- Ghostscript translator from PostScript or PDF to ASCII
.SH SYNOPSIS
@@ -22,7 +22,7 @@ system, from which you can get more details.
.SH SEE ALSO
pstotext(1), http://www.research.digital.com/SRC/virtualpaper/pstotext.html
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/ps2epsi.1 b/man/ps2epsi.1
index 6e43d8b6..0c62d46e 100644
--- a/man/ps2epsi.1
+++ b/man/ps2epsi.1
@@ -1,4 +1,4 @@
-.TH PS2EPSI 1 "10 September 2020" 9.53.0 "Ghostscript Tools" \" -*- nroff -*-
+.TH PS2EPSI 1 "14 September 2020" 9.53.1 "Ghostscript Tools" \" -*- nroff -*-
.SH NAME
ps2epsi \- generate conforming Encapsulated PostScript
.SH SYNOPSIS
@@ -59,7 +59,7 @@ ps2epsi.ps>the Ghostscript program which does the work
.SH SEE ALSO
gs (1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
However, the content may be obsolete, or inconsistent with ps2epsi.txt.
.SH AUTHOR
George Cameron
diff --git a/man/ps2pdf.1 b/man/ps2pdf.1
index 9890235d..2dabf86d 100644
--- a/man/ps2pdf.1
+++ b/man/ps2pdf.1
@@ -1,4 +1,4 @@
-.TH PS2PDF 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH PS2PDF 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
ps2pdf \- Convert PostScript to PDF using ghostscript
.br
@@ -89,7 +89,7 @@ VectorDevices.htm in the Ghostscript documentation
See http://bugs.ghostscript.com/ and the Usenet news group
comp.lang.postscript.
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/ps2pdfwr.1 b/man/ps2pdfwr.1
index dd8dda7d..075d1454 100644
--- a/man/ps2pdfwr.1
+++ b/man/ps2pdfwr.1
@@ -1,4 +1,4 @@
-.TH PS2PDFWR 1 "10 September 2020" 9.53.0 Ghostscript \" -*- nroff -*-
+.TH PS2PDFWR 1 "14 September 2020" 9.53.1 Ghostscript \" -*- nroff -*-
.SH NAME
ps2pdfwr \- Convert PostScript to PDF without specifying CompatibilityLevel, using ghostscript
.SH SYNOPSIS
@@ -23,7 +23,7 @@ scripts all invoke this one with the addition of the respective compatibility le
.SH SEE ALSO
gs(1), ps2pdf(1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.
diff --git a/man/ps2ps.1 b/man/ps2ps.1
index 24c8459d..90c37923 100644
--- a/man/ps2ps.1
+++ b/man/ps2ps.1
@@ -1,4 +1,4 @@
-.TH PS2PS 1 "10 September 2020" 9.53.0 "Ghostscript Tools" \" -*- nroff -*-
+.TH PS2PS 1 "14 September 2020" 9.53.1 "Ghostscript Tools" \" -*- nroff -*-
.SH NAME
ps2ps, eps2eps \- Ghostscript PostScript "distiller"
.SH SYNOPSIS
@@ -22,7 +22,7 @@ system, from which you can get more details.
.SH SEE ALSO
ps2pdf(1), ps2ascii(1), ps2epsi(1)
.SH VERSION
-This document was last revised for Ghostscript version 9.53.0.
+This document was last revised for Ghostscript version 9.53.1.
.SH AUTHOR
Artifex Software, Inc. are the
primary maintainers of Ghostscript.