aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-01 20:49:34 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 20:49:34 +0100
commite17747e23e4b38b545658687b4ca2553717ac02a (patch)
tree6772eb0ab6deb04882933ca063e421d8a0348186
parentcrossdev: follow ARCH=sh removal from ::gentoo (diff)
downloadcrossdev-master.tar.gz
crossdev-master.tar.bz2
crossdev-master.zip
crossdev: default to latest mingw64-runtime even for stable toolchains.HEADmaster
::gentoo does not have stable keywords for mingw64-runtime for a while. Let's default to 'latest' to make standard use case to just work.. Reported-by: i.Dark_Templar Bug: https://bugs.gentoo.org/733346 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rwxr-xr-xcrossdev8
1 files changed, 8 insertions, 0 deletions
diff --git a/crossdev b/crossdev
index 8812021..fec7ed3 100755
--- a/crossdev
+++ b/crossdev
@@ -855,6 +855,14 @@ for with in HEADERS ; do
[[ ${!var} == "COW" ]] && eval ${var}=${!defvar}
done
+# ::gentoo has no stable 'mingw64-runtime'. Let's default to 'latest'
+# unles suser specified something else.
+echo "LPKG=${LPKG}"
+echo "LVER=${LVER}"
+if [[ ${LPKG} == "mingw64-runtime" && ${LVER} == "[stable]" ]]; then
+ LVER="[latest]"
+fi
+
show_target_cfg() {
local pkgs crosspkgs=()