aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-12-22 15:52:29 +0000
committerUlrich Müller <ulm@gentoo.org>2010-12-22 15:52:29 +0000
commitb6c0d69471ab09eda1416e3f12970bdf314f4532 (patch)
treed88eb1da15e36d99a18901974344ab0d65dbfab5
parentInitial patchset for Emacs 23.2. (diff)
downloademacs-patches-b6c0d69471ab09eda1416e3f12970bdf314f4532.tar.gz
emacs-patches-b6c0d69471ab09eda1416e3f12970bdf314f4532.tar.bz2
emacs-patches-b6c0d69471ab09eda1416e3f12970bdf314f4532.zip
Remove 23.1 patchset.
-rw-r--r--emacs/23.1/01_all_handle-xz-suffix.patch16
-rw-r--r--emacs/23.1/02_all_backspace.patch54
-rw-r--r--emacs/23.1/03_all_gtk-menu.patch168
-rw-r--r--emacs/23.1/04_all_arm-libgcc_s.patch17
-rw-r--r--emacs/23.1/05_all_libpng14.patch49
-rw-r--r--emacs/23.1/06_all_cpp-4.5.patch25
6 files changed, 0 insertions, 329 deletions
diff --git a/emacs/23.1/01_all_handle-xz-suffix.patch b/emacs/23.1/01_all_handle-xz-suffix.patch
deleted file mode 100644
index 9345cea..0000000
--- a/emacs/23.1/01_all_handle-xz-suffix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Automatically handle .xz suffix (XZ-compressed files)
-From Jim Meyering <meyering@redhat.com> on emacs-devel
-
---- a/lisp/jka-cmpr-hook.el
-+++ b/lisp/jka-cmpr-hook.el
-@@ -219,6 +219,10 @@ options through Custom does this automatically."
- "compressing" "gzip" ("-c" "-q")
- "uncompressing" "gzip" ("-c" "-q" "-d")
- t t "\037\213"]
-+ ["\\.xz\\(~\\|\\.~[0-9]+~\\)?\\'"
-+ "XZ compressing" "xz" ("-c" "-q")
-+ "XZ uncompressing" "xz" ("-c" "-q" "-d")
-+ t t "\3757zXZ\0"]
- ;; dzip is gzip with random access. Its compression program can't
- ;; read/write stdin/out, so .dz files can only be viewed without
- ;; saving, having their contents decompressed with gzip.
diff --git a/emacs/23.1/02_all_backspace.patch b/emacs/23.1/02_all_backspace.patch
deleted file mode 100644
index bc547af..0000000
--- a/emacs/23.1/02_all_backspace.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-2009-10-22 Stefan Monnier <monnier@iro.umontreal.ca>
-
- * simple.el (normal-erase-is-backspace-mode): Use input-decode-map
- rather than fiddling with global-map bindings, since it should only
- affect per-terminal settings.
- See http://bugs.gentoo.org/show_bug.cgi?id=289709.
-
---- emacs-23.1-orig/lisp/simple.el
-+++ emacs-23.1/lisp/simple.el
-@@ -6269,31 +6269,27 @@
- (let* ((bindings
- `(([M-delete] [M-backspace])
- ([C-M-delete] [C-M-backspace])
-- (,esc-map
-- [C-delete] [C-backspace])))
-+ ([?\e C-delete] [?\e C-backspace])))
- (old-state (lookup-key local-function-key-map [delete])))
-
- (if enabled
- (progn
- (define-key local-function-key-map [delete] [?\C-d])
- (define-key local-function-key-map [kp-delete] [?\C-d])
-- (define-key local-function-key-map [backspace] [?\C-?]))
-+ (define-key local-function-key-map [backspace] [?\C-?])
-+ (dolist (b bindings)
-+ ;; Not sure if input-decode-map is really right, but
-+ ;; keyboard-translate-table (used below) only works
-+ ;; for integer events, and key-translation-table is
-+ ;; global (like the global-map, used earlier).
-+ (define-key input-decode-map (car b) nil)
-+ (define-key input-decode-map (cadr b) nil)))
- (define-key local-function-key-map [delete] [?\C-?])
- (define-key local-function-key-map [kp-delete] [?\C-?])
-- (define-key local-function-key-map [backspace] [?\C-?]))
--
-- ;; Maybe swap bindings of C-delete and C-backspace, etc.
-- (unless (equal old-state (lookup-key local-function-key-map [delete]))
-- (dolist (binding bindings)
-- (let ((map global-map))
-- (when (keymapp (car binding))
-- (setq map (car binding) binding (cdr binding)))
-- (let* ((key1 (nth 0 binding))
-- (key2 (nth 1 binding))
-- (binding1 (lookup-key map key1))
-- (binding2 (lookup-key map key2)))
-- (define-key map key1 binding2)
-- (define-key map key2 binding1)))))))
-+ (define-key local-function-key-map [backspace] [?\C-?])
-+ (dolist (b bindings)
-+ (define-key input-decode-map (car b) (cadr b))
-+ (define-key input-decode-map (cadr b) (car b))))))
- (t
- (if enabled
- (progn
diff --git a/emacs/23.1/03_all_gtk-menu.patch b/emacs/23.1/03_all_gtk-menu.patch
deleted file mode 100644
index ccffd0c..0000000
--- a/emacs/23.1/03_all_gtk-menu.patch
+++ /dev/null
@@ -1,168 +0,0 @@
-http://bugs.gentoo.org/292007
-http://emacsbugs.donarmstrong.com/4122
-http://bugs.gentoo.org/292492
-http://emacsbugs.donarmstrong.com/4336
-Fix updating of menus with GTK+ 2.18
-Patch by Jan Djärv <jan.h.d@swipnet.se>, backported from upstream CVS
-
---- emacs-23.1-orig/src/xfns.c
-+++ emacs-23.1/src/xfns.c
-@@ -374,10 +374,7 @@
- #ifdef USE_GTK
- GtkWidget *gwdesc = xg_win_to_widget (dpyinfo->display, wdesc);
- if (gwdesc != 0
-- && (gwdesc == x->widget
-- || gwdesc == x->edit_widget
-- || gwdesc == x->vbox_widget
-- || gwdesc == x->menubar_widget))
-+ && gtk_widget_get_toplevel (gwdesc) == x->widget)
- found = f;
- #else
- if (wdesc == XtWindow (x->widget)
-@@ -398,54 +395,6 @@
- return found;
- }
-
--/* Likewise, but exclude the menu bar widget. */
--
--struct frame *
--x_non_menubar_window_to_frame (dpyinfo, wdesc)
-- struct x_display_info *dpyinfo;
-- int wdesc;
--{
-- Lisp_Object tail, frame;
-- struct frame *f;
-- struct x_output *x;
--
-- if (wdesc == None) return 0;
--
-- for (tail = Vframe_list; CONSP (tail); tail = XCDR (tail))
-- {
-- frame = XCAR (tail);
-- if (!FRAMEP (frame))
-- continue;
-- f = XFRAME (frame);
-- if (!FRAME_X_P (f) || FRAME_X_DISPLAY_INFO (f) != dpyinfo)
-- continue;
-- x = f->output_data.x;
-- /* This frame matches if the window is any of its widgets. */
-- if (x->hourglass_window == wdesc)
-- return f;
-- else if (x->widget)
-- {
--#ifdef USE_GTK
-- GtkWidget *gwdesc = xg_win_to_widget (dpyinfo->display, wdesc);
-- if (gwdesc != 0
-- && (gwdesc == x->widget
-- || gwdesc == x->edit_widget
-- || gwdesc == x->vbox_widget))
-- return f;
--#else
-- if (wdesc == XtWindow (x->widget)
-- || wdesc == XtWindow (x->column_widget)
-- || wdesc == XtWindow (x->edit_widget))
-- return f;
--#endif
-- }
-- else if (FRAME_X_WINDOW (f) == wdesc)
-- /* A tooltip frame. */
-- return f;
-- }
-- return 0;
--}
--
- /* Likewise, but consider only the menu bar widget. */
-
- struct frame *
-@@ -473,15 +422,14 @@
- if (x->menubar_widget)
- {
- GtkWidget *gwdesc = xg_win_to_widget (dpyinfo->display, wdesc);
-- int found = 0;
-
-- BLOCK_INPUT;
-+ /* This gives false positives, but the rectangle check in xterm.c
-+ where this is called takes care of that. */
- if (gwdesc != 0
- && (gwdesc == x->menubar_widget
-- || gtk_widget_get_parent (gwdesc) == x->menubar_widget))
-- found = 1;
-- UNBLOCK_INPUT;
-- if (found) return f;
-+ || gtk_widget_is_ancestor (x->menubar_widget, gwdesc)
-+ || gtk_widget_is_ancestor (gwdesc, x->menubar_widget)))
-+ return f;
- }
- #else
- if (x->menubar_widget
---- emacs-23.1-orig/src/xterm.c
-+++ emacs-23.1/src/xterm.c
-@@ -109,8 +109,6 @@
- #if defined (USE_X_TOOLKIT) || defined (USE_GTK)
-
- extern void free_frame_menubar P_ ((struct frame *));
--extern struct frame *x_menubar_window_to_frame P_ ((struct x_display_info *,
-- int));
- #endif
-
- #ifdef USE_X_TOOLKIT
-@@ -143,11 +141,6 @@
-
- #endif /* USE_X_TOOLKIT */
-
--#if ! defined (USE_X_TOOLKIT) && ! defined (USE_GTK)
--#define x_any_window_to_frame x_window_to_frame
--#define x_top_window_to_frame x_window_to_frame
--#endif
--
- #ifdef USE_X_TOOLKIT
- #include "widget.h"
- #ifndef XtNinitialState
-@@ -3916,6 +3909,14 @@
- if (child == None || child == win)
- break;
-
-+#ifdef USE_GTK
-+ /* We don't wan't to know the innermost window. We
-+ want the edit window. For non-Gtk+ the innermost
-+ window is the edit window. For Gtk+ it might not
-+ be. It might be the tool bar for example. */
-+ if (x_window_to_frame (FRAME_X_DISPLAY_INFO (*fp), win))
-+ break;
-+#endif
- win = child;
- parent_x = win_x;
- parent_y = win_y;
-@@ -3932,8 +3933,14 @@
- parent_{x,y} are invalid, but that's okay, because we'll
- never use them in that case.) */
-
-+#ifdef USE_GTK
-+ /* We don't wan't to know the innermost window. We
-+ want the edit window. */
-+ f1 = x_window_to_frame (FRAME_X_DISPLAY_INFO (*fp), win);
-+#else
- /* Is win one of our frames? */
- f1 = x_any_window_to_frame (FRAME_X_DISPLAY_INFO (*fp), win);
-+#endif
-
- #ifdef USE_X_TOOLKIT
- /* If we end up with the menu bar window, say it's not
---- emacs-23.1-orig/src/xterm.h
-+++ emacs-23.1/src/xterm.h
-@@ -372,10 +372,13 @@
-
- extern struct frame *x_window_to_frame P_ ((struct x_display_info *, int));
-
--#if defined (USE_X_TOOLKIT) || defined (USE_GTK)
- extern struct frame *x_any_window_to_frame P_ ((struct x_display_info *, int));
--extern struct frame *x_non_menubar_window_to_frame P_ ((struct x_display_info *, int));
-+extern struct frame *x_menubar_window_to_frame P_ ((struct x_display_info *, int));
- extern struct frame *x_top_window_to_frame P_ ((struct x_display_info *, int));
-+
-+#if ! defined (USE_X_TOOLKIT) && ! defined (USE_GTK)
-+#define x_any_window_to_frame x_window_to_frame
-+#define x_top_window_to_frame x_window_to_frame
- #endif
-
- /* This is a chain of structures for all the X displays currently in use. */
diff --git a/emacs/23.1/04_all_arm-libgcc_s.patch b/emacs/23.1/04_all_arm-libgcc_s.patch
deleted file mode 100644
index a46ad3e..0000000
--- a/emacs/23.1/04_all_arm-libgcc_s.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-http://bugs.gentoo.org/302357
-http://debbugs.gnu.org/cgi/bugreport.cgi?bug=5518
-
---- emacs-orig/src/m/arm.h 2010-01-13 08:35:10 +0000
-+++ emacs/src/m/arm.h 2010-02-21 13:44:07 +0000
-@@ -36,5 +36,11 @@
-
- #define NO_REMAP
-
-+/* armin76@gentoo.org reported that the lgcc_s flag is necessary to
-+ build on ARM EABI under GNU/Linux (Bug#5518). */
-+#ifdef GNU_LINUX
-+#define LIB_GCC -lgcc_s
-+#endif
-+
- /* arch-tag: 07856f0c-f0c8-4bd8-99af-0b7fa1e5ee42
- (do not change this comment) */
diff --git a/emacs/23.1/05_all_libpng14.patch b/emacs/23.1/05_all_libpng14.patch
deleted file mode 100644
index ea8721c..0000000
--- a/emacs/23.1/05_all_libpng14.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-http://repos.archlinux.org/wsvn/packages/emacs/trunk/libpng14.patch
-
---- emacs-23.1-orig/src/image.c
-+++ emacs-23.1/src/image.c
-@@ -5793,7 +5793,7 @@
- /* PNG library details. */
-
- DEF_IMGLIB_FN (png_get_io_ptr);
--DEF_IMGLIB_FN (png_check_sig);
-+DEF_IMGLIB_FN (png_sig_cmp);
- DEF_IMGLIB_FN (png_create_read_struct);
- DEF_IMGLIB_FN (png_create_info_struct);
- DEF_IMGLIB_FN (png_destroy_read_struct);
-@@ -5824,7 +5824,7 @@
- return 0;
-
- LOAD_IMGLIB_FN (library, png_get_io_ptr);
-- LOAD_IMGLIB_FN (library, png_check_sig);
-+ LOAD_IMGLIB_FN (library, png_sig_cmp);
- LOAD_IMGLIB_FN (library, png_create_read_struct);
- LOAD_IMGLIB_FN (library, png_create_info_struct);
- LOAD_IMGLIB_FN (library, png_destroy_read_struct);
-@@ -5849,7 +5849,7 @@
- #else
-
- #define fn_png_get_io_ptr png_get_io_ptr
--#define fn_png_check_sig png_check_sig
-+#define fn_png_sig_cmp png_sig_cmp
- #define fn_png_create_read_struct png_create_read_struct
- #define fn_png_create_info_struct png_create_info_struct
- #define fn_png_destroy_read_struct png_destroy_read_struct
-@@ -5996,7 +5996,7 @@
-
- /* Check PNG signature. */
- if (fread (sig, 1, sizeof sig, fp) != sizeof sig
-- || !fn_png_check_sig (sig, sizeof sig))
-+ || fn_png_sig_cmp (sig, 0, sizeof sig))
- {
- image_error ("Not a PNG file: `%s'", file, Qnil);
- UNGCPRO;
-@@ -6013,7 +6013,7 @@
-
- /* Check PNG signature. */
- if (tbr.len < sizeof sig
-- || !fn_png_check_sig (tbr.bytes, sizeof sig))
-+ || fn_png_sig_cmp (tbr.bytes, 0, sizeof sig))
- {
- image_error ("Not a PNG image: `%s'", img->spec, Qnil);
- UNGCPRO;
diff --git a/emacs/23.1/06_all_cpp-4.5.patch b/emacs/23.1/06_all_cpp-4.5.patch
deleted file mode 100644
index fdb3f48..0000000
--- a/emacs/23.1/06_all_cpp-4.5.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-http://bugs.gentoo.org/308653
-http://debbugs.gnu.org/5047
-http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
-Fix building with GNU CPP 4.5, patch from upstream CVS.
-
---- emacs-23.1-orig/configure.in
-+++ emacs-23.1/configure.in
-@@ -2983,7 +2983,7 @@
- sed -e '1,/start of cpp stuff/d'\
- -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
- < Makefile.c > junk.c
-- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
-+ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
- sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
- cat junk1.c junk2.c > Makefile.new
- rm -f junk.c junk1.c junk2.c
-@@ -2999,7 +2999,7 @@
- sed -e '1,/start of cpp stuff/d'\
- -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
- < Makefile.c > junk.c
-- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
-+ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
- sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
- cat junk1.c junk2.c > Makefile.new
- rm -f junk.c junk1.c junk2.c