summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-03-10 07:18:47 +0000
committerUlrich Müller <ulm@gentoo.org>2011-03-10 07:18:47 +0000
commit3900591552d5a3ff5f2f734b34362cd9a04d0603 (patch)
treea44e2dafffebc79ee7828a6cbdf296b2ec555441
parentFix an issue with duplicate items in GNU Info directory. (diff)
downloademacs-patches-3900591552d5a3ff5f2f734b34362cd9a04d0603.tar.gz
emacs-patches-3900591552d5a3ff5f2f734b34362cd9a04d0603.tar.bz2
emacs-patches-3900591552d5a3ff5f2f734b34362cd9a04d0603.zip
Initial patchset for Emacs 23.3emacs-23.3_rc1-patches-1emacs-23.3-patches-1
-rw-r--r--emacs/23.3/02_all_gameuser.patch17
-rw-r--r--emacs/23.3/03_all_gnu-linux-crt-dir.patch22
-rw-r--r--emacs/23.3/04_all_ns-appdirs.patch50
3 files changed, 89 insertions, 0 deletions
diff --git a/emacs/23.3/02_all_gameuser.patch b/emacs/23.3/02_all_gameuser.patch
new file mode 100644
index 0000000..8e061a0
--- /dev/null
+++ b/emacs/23.3/02_all_gameuser.patch
@@ -0,0 +1,17 @@
+http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7717
+
+--- emacs-23.2-orig/configure.in
++++ emacs-23.2/configure.in
+@@ -175,6 +175,12 @@
+ This option is only used on x86-64 and s390x GNU/Linux architectures.])])
+ CRT_DIR="${with_crt_dir}"
+
++AC_ARG_WITH(gameuser,dnl
++[AS_HELP_STRING([--with-gameuser=USER],[user for shared game score files])])
++test "X${with_gameuser}" != X && test "${with_gameuser}" != yes \
++ && gameuser="${with_gameuser}"
++test "X$gameuser" = X && gameuser=games
++
+ AC_ARG_WITH([gnustep-conf],dnl
+ [AS_HELP_STRING([--with-gnustep-conf=PATH],[path to GNUstep.conf; default $GNUSTEP_CONFIG_FILE, or /etc/GNUstep/GNUstep.conf])])
+ test "X${with_gnustep_conf}" != X && test "${with_gnustep_conf}" != yes && \
diff --git a/emacs/23.3/03_all_gnu-linux-crt-dir.patch b/emacs/23.3/03_all_gnu-linux-crt-dir.patch
new file mode 100644
index 0000000..fb06459
--- /dev/null
+++ b/emacs/23.3/03_all_gnu-linux-crt-dir.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/350532
+
+--- emacs-23.2-orig/src/s/gnu-linux.h
++++ emacs-23.2/src/s/gnu-linux.h
+@@ -168,7 +168,7 @@
+ /* Ask GCC where to find libgcc.a. */
+ #define LIB_GCC `$(CC) $(C_SWITCH_X_SITE) -print-libgcc-file-name`
+
+-#define START_FILES pre-crt0.o /usr/lib/crt1.o /usr/lib/crti.o
++#define START_FILES pre-crt0.o $(CRT_DIR)/crt1.o $(CRT_DIR)/crti.o
+
+ /* Here is how to find X Windows. LD_SWITCH_X_SITE_AUX gives an -R option
+ says where to find X windows at run time. */
+@@ -198,7 +198,7 @@
+ #define LIBS_DEBUG
+ #undef LIB_GCC
+ #define LIB_GCC
+-#define LIB_STANDARD -lgcc -lc -lgcc /usr/lib/crtn.o
++#define LIB_STANDARD -lgcc -lc -lgcc $(CRT_DIR)/crtn.o
+
+ /* Don't use -g in test compiles in configure.
+ This is so we will use the same shared libs for that linking
diff --git a/emacs/23.3/04_all_ns-appdirs.patch b/emacs/23.3/04_all_ns-appdirs.patch
new file mode 100644
index 0000000..07113ff
--- /dev/null
+++ b/emacs/23.3/04_all_ns-appdirs.patch
@@ -0,0 +1,50 @@
+http://bugs.gentoo.org/268793
+
+--- emacs-23.2-orig/configure.in
++++ emacs-23.2/configure.in
+@@ -1417,10 +1417,10 @@
+ window_system=nextstep
+ with_xft=no
+ # set up packaging dirs
+- exec_prefix=${ns_appbindir}
+- libexecdir=${ns_appbindir}/libexec
+ if test "${EN_NS_SELF_CONTAINED}" = yes; then
+ prefix=${ns_appresdir}
++ exec_prefix=${ns_appbindir}
++ libexecdir=${ns_appbindir}/libexec
+ fi
+ fi
+ CFLAGS="$tmp_CFLAGS"
+--- emacs-23.2-orig/leim/Makefile.in
++++ emacs-23.2/leim/Makefile.in
+@@ -263,11 +263,6 @@
+ [ -n "$${installuser}" ] && break ; \
+ done ; \
+ find ${INSTALLDIR} -exec chown $${installuser} '{}' ';'
+- if [ "${ns_appresdir}" != "" ]; then \
+- ( cd ${ns_appresdir} ; \
+- if test -d share/emacs ; then dir=share/emacs/*/*; $(MV_DIRS); fi;\
+- rm -fr share ) ; \
+- else true ; fi
+
+ clean mostlyclean:
+ rm -f ${TIT-MISC} ${TIT-MISC:.elc=.el} \
+--- emacs-23.2-orig/Makefile.in
++++ emacs-23.2/Makefile.in
+@@ -424,16 +424,6 @@
+ ${INSTALL_DATA} lib-src/$$f $(DESTDIR)${archlibdir}/$$f; \
+ else true; fi ; \
+ done
+- if test "${ns_appdir}" != ""; then \
+- ( cd ${ns_appresdir} ; \
+- if test -d share/emacs ; then dir=share/emacs/*/*; $(MV_DIRS); fi;\
+- if test -d share/info ; then dir=share/info; $(MV_DIRS) ; fi ; \
+- rm -fr share ) ; \
+- ( cd ${ns_appbindir}/libexec ; dir=emacs/*/*/* ; $(MV_DIRS); \
+- rm -fr emacs ) ; \
+- ( cd ${ns_appbindir}/bin ; rm -f emacs emacs-23* ; \
+- ln -sf ../libexec/* .) ; \
+- else true ; fi
+
+ ## http://lists.gnu.org/archive/html/emacs-devel/2007-10/msg01672.html
+ ## Needs to be the user running install, so configure can't set it.