aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-06-10 13:46:58 +0000
committerUlrich Müller <ulm@gentoo.org>2012-06-10 13:46:58 +0000
commite4b6463a055cb55b4648a0df7e09881d1e70880c (patch)
tree837ef7944d7f90ec748716cd360df29c5525a042 /emacs/24.1
parentFix building on systems with PaX enabled kernel, bug 411439. (diff)
downloademacs-patches-e4b6463a055cb55b4648a0df7e09881d1e70880c.tar.gz
emacs-patches-e4b6463a055cb55b4648a0df7e09881d1e70880c.tar.bz2
emacs-patches-e4b6463a055cb55b4648a0df7e09881d1e70880c.zip
Initial patchset for Emacs 24.1emacs-24.1_rc-patches-1emacs-24.1-patches-1
Diffstat (limited to 'emacs/24.1')
-rw-r--r--emacs/24.1/01_all_ns-appdirs.patch41
-rw-r--r--emacs/24.1/02_all_paxctl.patch56
2 files changed, 97 insertions, 0 deletions
diff --git a/emacs/24.1/01_all_ns-appdirs.patch b/emacs/24.1/01_all_ns-appdirs.patch
new file mode 100644
index 0000000..a8e3f82
--- /dev/null
+++ b/emacs/24.1/01_all_ns-appdirs.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/268793
+https://bugs.gentoo.org/399059
+
+--- emacs-24.1-orig/Makefile.in
++++ emacs-24.1/Makefile.in
+@@ -476,21 +476,6 @@
+ -chmod 1755 $(DESTDIR)${bindir}/$(EMACSFULL)
+ rm -f $(DESTDIR)${bindir}/$(EMACS)
+ -ln $(DESTDIR)${bindir}/$(EMACSFULL) $(DESTDIR)${bindir}/$(EMACS)
+- if test "${ns_appresdir}" != ""; then \
+- ( cd ${ns_appresdir} ; \
+- if test -d share/emacs ; then dir=share/emacs/*/*; $(MV_DIRS); fi;\
+- if test -d share/info ; then dir=share/info; $(MV_DIRS) ; fi ; \
+- rm -fr share ) ; \
+- ( cd ${ns_appbindir} ; \
+- if cd libexec ; then dir=emacs/*/*/* ; $(MV_DIRS); \
+- rm -fr emacs; if cd ../bin; then rm -f emacs emacs-24*; \
+- ln -sf ../libexec/* . ; fi ; fi ) ; \
+- else true ; fi
+-
+-## FIXME is the emacs-24* bit above really necessary and correct?
+-## What if I have 24.1 and 24.2 installed at the same time?
+-## In any case, it should use something like echo $version | sed 's/\..*//'
+-## instead of hard-coding a version.
+
+ ## http://lists.gnu.org/archive/html/emacs-devel/2007-10/msg01672.html
+ ## Needs to be the user running install, so configure can't set it.
+--- emacs-24.1-orig/leim/Makefile.in
++++ emacs-24.1/leim/Makefile.in
+@@ -259,11 +259,6 @@
+ [ -n "$${installuser}" ] && break ; \
+ done ; \
+ find ${INSTALLDIR} -exec chown $${installuser} '{}' ';'
+- if [ "${ns_appresdir}" != "" ]; then \
+- ( cd ${ns_appresdir} ; \
+- if test -d share/emacs ; then dir=share/emacs/*/*; $(MV_DIRS); fi;\
+- rm -fr share ) ; \
+- else true ; fi
+
+ clean mostlyclean:
+ rm -f ${TIT_MISC} ${TIT_MISC:.elc=.el} \
diff --git a/emacs/24.1/02_all_paxctl.patch b/emacs/24.1/02_all_paxctl.patch
new file mode 100644
index 0000000..02c00cb
--- /dev/null
+++ b/emacs/24.1/02_all_paxctl.patch
@@ -0,0 +1,56 @@
+Disable memory randomization for the temacs binary via PaX flags
+if the paxctl utility is available.
+https://bugs.gentoo.org/411439
+http://debbugs.gnu.org/11398
+
+--- emacs-24.1-orig/configure.in
++++ emacs-24.1/configure.in
+@@ -756,6 +756,8 @@
+ AC_PATH_PROG(INSTALL_INFO, install-info,:, /sbin)
+ dnl Don't use GZIP, which is used by gzip for additional parameters.
+ AC_PATH_PROG(GZIP_PROG, gzip)
++AC_PATH_PROG(PAXCTL, paxctl,,
++ [$PATH$PATH_SEPARATOR/sbin$PATH_SEPARATOR/usr/sbin])
+
+
+ ## Need makeinfo >= 4.6 (?) to build the manuals.
+--- emacs-24.1-orig/src/Makefile.in
++++ emacs-24.1/src/Makefile.in
+@@ -116,6 +116,12 @@
+ ## $LDFLAGS or empty if NS_IMPL_GNUSTEP (for some reason).
+ TEMACS_LDFLAGS2 = @TEMACS_LDFLAGS2@
+
++## If available, the full path to the paxctl program.
++## On grsecurity/PaX systems, unexec will fail due to a gap between
++## the bss section and the heap. This can be prevented by disabling
++## memory randomization in temacs with "paxctl -r". See bug#11398.
++PAXCTL = @PAXCTL@
++
+ ## Some systems define this to request special libraries.
+ LIBS_SYSTEM=@LIBS_SYSTEM@
+
+@@ -406,6 +412,7 @@
+ -f list-load-path-shadows || true; \
+ else \
+ LC_ALL=C $(RUN_TEMACS) -batch -l loadup dump || exit 1; \
++ test "X$(PAXCTL)" = X || $(PAXCTL) -zex emacs$(EXEEXT); \
+ ln -f emacs$(EXEEXT) bootstrap-emacs$(EXEEXT); \
+ ./emacs -batch -f list-load-path-shadows || true; \
+ fi
+@@ -453,6 +460,8 @@
+ temacs$(EXEEXT): $(START_FILES) stamp-oldxmenu $(obj) $(otherobj) $(lib)/libgnu.a
+ $(CC) $(LD_FIRSTFLAG) $(ALL_CFLAGS) $(TEMACS_LDFLAGS) $(TEMACS_LDFLAGS2) \
+ -o temacs $(START_FILES) $(obj) $(otherobj) $(lib)/libgnu.a $(LIBES)
++ test "$(CANNOT_DUMP)" = "yes" || \
++ test "X$(PAXCTL)" = X || $(PAXCTL) -r temacs$(EXEEXT)
+
+ ## The following oldxmenu-related rules are only (possibly) used if
+ ## HAVE_X11 && !USE_GTK, but there is no harm in always defining them
+@@ -600,6 +609,7 @@
+ ln -f temacs$(EXEEXT) bootstrap-emacs$(EXEEXT); \
+ else \
+ $(RUN_TEMACS) --batch --load loadup bootstrap || exit 1; \
++ test "X$(PAXCTL)" = X || $(PAXCTL) -zex emacs$(EXEEXT); \
+ mv -f emacs$(EXEEXT) bootstrap-emacs$(EXEEXT); \
+ fi
+ @: Compile some files earlier to speed up further compilation.