aboutsummaryrefslogtreecommitdiff
path: root/emacs
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-08-04 02:20:11 +0200
committerUlrich Müller <ulm@gentoo.org>2013-08-04 02:20:11 +0200
commit3294c616fd0d4acd77e1afeef904178dda0a551f (patch)
tree0ababace4789b394cf73883390da8be4547b7715 /emacs
parentFix build failure on FreeBSD 9.1 with GCC 4.6.3, bug 473364. (diff)
downloademacs-patches-3294c616fd0d4acd77e1afeef904178dda0a551f.tar.gz
emacs-patches-3294c616fd0d4acd77e1afeef904178dda0a551f.tar.bz2
emacs-patches-3294c616fd0d4acd77e1afeef904178dda0a551f.zip
Add missing ChangeLog entries.
Diffstat (limited to 'emacs')
-rw-r--r--emacs/18.59/07_all_cpp-4.5.patch17
-rw-r--r--emacs/18.59/08_all_ldflags.patch12
-rw-r--r--emacs/18.59/09_all_syswait.patch15
-rw-r--r--emacs/18.59/10_all_x32.patch49
4 files changed, 70 insertions, 23 deletions
diff --git a/emacs/18.59/07_all_cpp-4.5.patch b/emacs/18.59/07_all_cpp-4.5.patch
index 5750d5e..8d063ec 100644
--- a/emacs/18.59/07_all_cpp-4.5.patch
+++ b/emacs/18.59/07_all_cpp-4.5.patch
@@ -1,7 +1,16 @@
-http://bugs.gentoo.org/308653
-http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
-Fix building with GNU CPP 4.5.
-
+--- emacs-18.59-orig/src/ChangeLog
++++ emacs-18.59/src/ChangeLog
+@@ -1,3 +1,10 @@
++2010-03-11 Ulrich Mueller <ulm@gentoo.org>
++
++ * Makefile (xmakefile): Call C preprocessor with -P option,
++ in order to fix building with GNU CPP 4.5.
++ http://bugs.gentoo.org/308653
++ http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
++
+ 2008-10-21 Ulrich Mueller <ulm@gentoo.org>
+
+ * emacs.c: Handle gap between end of BSS and heap, backported
--- emacs-18.59-orig/src/Makefile
+++ emacs-18.59/src/Makefile
@@ -33,7 +33,7 @@
diff --git a/emacs/18.59/08_all_ldflags.patch b/emacs/18.59/08_all_ldflags.patch
index ec31394..db07fab 100644
--- a/emacs/18.59/08_all_ldflags.patch
+++ b/emacs/18.59/08_all_ldflags.patch
@@ -1,5 +1,13 @@
-Respect LDFLAGS when building programs in etc.
-
+--- emacs-18.59-orig/etc/ChangeLog
++++ emacs-18.59/etc/ChangeLog
+@@ -1,3 +1,7 @@
++2011-12-19 Ulrich Mueller <ulm@gentoo.org>
++
++ * Makefile: Respect LDFLAGS.
++
+ 2009-05-29 Ulrich Mueller <ulm@gentoo.org>
+
+ * etags.c (etags_getline): Renamed from getline, fixes compilation
--- emacs-18.59-orig/etc/Makefile
+++ emacs-18.59/etc/Makefile
@@ -25,35 +25,35 @@
diff --git a/emacs/18.59/09_all_syswait.patch b/emacs/18.59/09_all_syswait.patch
index 0f55500..111895f 100644
--- a/emacs/18.59/09_all_syswait.patch
+++ b/emacs/18.59/09_all_syswait.patch
@@ -1,6 +1,15 @@
-Include sys/wait.h if available.
-Backported from Emacs 21.4.
-
+--- emacs-18.59-orig/src/ChangeLog
++++ emacs-18.59/src/ChangeLog
+@@ -1,3 +1,9 @@
++2011-12-24 Ulrich Mueller <ulm@gentoo.org>
++
++ * process.c: Include sys/wait.h if available.
++ Backported from Emacs 21.4.
++ * s-linux.h (HAVE_SYS_WAIT_H): Define.
++
+ 2010-03-11 Ulrich Mueller <ulm@gentoo.org>
+
+ * Makefile (xmakefile): Call C preprocessor with -P option,
--- emacs-18.59-orig/src/process.c
+++ emacs-18.59/src/process.c
@@ -138,55 +138,37 @@
diff --git a/emacs/18.59/10_all_x32.patch b/emacs/18.59/10_all_x32.patch
index 68062ef..2d8268c 100644
--- a/emacs/18.59/10_all_x32.patch
+++ b/emacs/18.59/10_all_x32.patch
@@ -1,5 +1,38 @@
-Support x32 ABI on x86_64.
-
+--- emacs-18.59-orig/src/ChangeLog
++++ emacs-18.59/src/ChangeLog
+@@ -1,3 +1,8 @@
++2012-06-28 Ulrich Mueller <ulm@gentoo.org>
++
++ Support x32 ABI on x86_64 architecture.
++ * m-x86-x32.h: New file.
++
+ 2011-12-24 Ulrich Mueller <ulm@gentoo.org>
+
+ * process.c: Include sys/wait.h if available.
+--- emacs-18.59-orig/src/m-x86-x32.h
++++ emacs-18.59/src/m-x86-x32.h
+@@ -0,0 +1,9 @@
++/* m- file for x32 ABI on x86_64. */
++
++#include "m-intel386.h"
++
++#define NO_ARG_ARRAY
++
++#undef ULIMIT_BREAK_VALUE
++#undef DATA_SEG_BITS
++#undef SEGMENT_MASK
+--- emacs-18.59-orig/etc/ChangeLog
++++ emacs-18.59/etc/ChangeLog
+@@ -1,3 +1,9 @@
++2012-06-28 Ulrich Mueller <ulm@gentoo.org>
++
++ * fakemail.c (make_file_preface): time(2) returns a value of
++ type time_t. Declare variable accordingly.
++ * wakeup.c (main): Ditto.
++
+ 2011-12-19 Ulrich Mueller <ulm@gentoo.org>
+
+ * Makefile: Respect LDFLAGS.
--- emacs-18.59-orig/etc/fakemail.c
+++ emacs-18.59/etc/fakemail.c
@@ -272,7 +272,7 @@
@@ -22,15 +55,3 @@ Support x32 ABI on x86_64.
struct tm *tp;
if (argc > 1)
---- emacs-18.59-orig/src/m-x86-x32.h
-+++ emacs-18.59/src/m-x86-x32.h
-@@ -0,0 +1,9 @@
-+/* m- file for x32 ABI on x86_64. */
-+
-+#include "m-intel386.h"
-+
-+#define NO_ARG_ARRAY
-+
-+#undef ULIMIT_BREAK_VALUE
-+#undef DATA_SEG_BITS
-+#undef SEGMENT_MASK