aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emacs/22.3/08_all_gameuser.patch18
-rw-r--r--emacs/23.2/02_all_gameuser.patch17
2 files changed, 35 insertions, 0 deletions
diff --git a/emacs/22.3/08_all_gameuser.patch b/emacs/22.3/08_all_gameuser.patch
new file mode 100644
index 0000000..4a6ba5e
--- /dev/null
+++ b/emacs/22.3/08_all_gameuser.patch
@@ -0,0 +1,18 @@
+http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7717
+Patch backported to Emacs 22.
+
+--- emacs-22.3-orig/configure.in
++++ emacs-22.3/configure.in
+@@ -156,6 +156,12 @@
+ locallisppath=${enableval}
+ fi)
+
++AC_ARG_WITH(gameuser,
++[ --with-gameuser=USER user for shared game score files])
++test "X${with_gameuser}" != X && test "${with_gameuser}" != yes \
++ && gameuser="${with_gameuser}"
++test "X$gameuser" = X && gameuser=games
++
+ #### Make srcdir absolute, if it isn't already. It's important to
+ #### avoid running the path through pwd unnecessarily, since pwd can
+ #### give you automounter prefixes, which can go away. We do all this
diff --git a/emacs/23.2/02_all_gameuser.patch b/emacs/23.2/02_all_gameuser.patch
new file mode 100644
index 0000000..8e061a0
--- /dev/null
+++ b/emacs/23.2/02_all_gameuser.patch
@@ -0,0 +1,17 @@
+http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7717
+
+--- emacs-23.2-orig/configure.in
++++ emacs-23.2/configure.in
+@@ -175,6 +175,12 @@
+ This option is only used on x86-64 and s390x GNU/Linux architectures.])])
+ CRT_DIR="${with_crt_dir}"
+
++AC_ARG_WITH(gameuser,dnl
++[AS_HELP_STRING([--with-gameuser=USER],[user for shared game score files])])
++test "X${with_gameuser}" != X && test "${with_gameuser}" != yes \
++ && gameuser="${with_gameuser}"
++test "X$gameuser" = X && gameuser=games
++
+ AC_ARG_WITH([gnustep-conf],dnl
+ [AS_HELP_STRING([--with-gnustep-conf=PATH],[path to GNUstep.conf; default $GNUSTEP_CONFIG_FILE, or /etc/GNUstep/GNUstep.conf])])
+ test "X${with_gnustep_conf}" != X && test "${with_gnustep_conf}" != yes && \