aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emacs/24.4/01_all_pax-xattr.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/emacs/24.4/01_all_pax-xattr.patch b/emacs/24.4/01_all_pax-xattr.patch
new file mode 100644
index 0000000..7cfce4b
--- /dev/null
+++ b/emacs/24.4/01_all_pax-xattr.patch
@@ -0,0 +1,16 @@
+Fix temacs startup failure with hardened Linux kernel when both
+CONFIG_PAX_PT_PAX_FLAGS and CONFIG_PAX_XATTR_PAX_FLAGS are enabled.
+https://bugs.gentoo.org/497498
+https://bugs.gentoo.org/526948
+
+--- emacs-24.4-orig/src/Makefile.in
++++ emacs-24.4/src/Makefile.in
+@@ -497,7 +497,7 @@
+ test "$(CANNOT_DUMP)" = "yes" || \
+ test "X$(PAXCTL)" = X || $(PAXCTL) -r temacs$(EXEEXT)
+ test "$(CANNOT_DUMP)" = "yes" || test -z "$(SETFATTR)" || \
+- $(SETFATTR) -n user.pax.flags -v r $@
++ $(SETFATTR) -n user.pax.flags -v er $@
+
+ ## The following oldxmenu-related rules are only (possibly) used if
+ ## HAVE_X11 && !USE_GTK, but there is no harm in always defining them.