aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'emacs/24.2/08_all_ncurses-tinfo.patch')
-rw-r--r--emacs/24.2/08_all_ncurses-tinfo.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/emacs/24.2/08_all_ncurses-tinfo.patch b/emacs/24.2/08_all_ncurses-tinfo.patch
new file mode 100644
index 0000000..e4a6117
--- /dev/null
+++ b/emacs/24.2/08_all_ncurses-tinfo.patch
@@ -0,0 +1,35 @@
+Fix build failure with separate tinfo library.
+Patch taken from upstream bzr (emacs-24 branch) and backported to 24.2.
+https://bugs.gentoo.org/459458
+http://debbugs.gnu.org/9741
+
+--- emacs-24.2-orig/configure.in
++++ emacs-24.2/configure.in
+@@ -2813,7 +2813,7 @@
+ ])
+ # Maybe curses should be tried earlier?
+ # See http://debbugs.gnu.org/cgi/bugreport.cgi?bug=9736#35
+-for tputs_library in '' ncurses terminfo termcap curses; do
++for tputs_library in '' tinfo ncurses terminfo termcap curses; do
+ OLIBS=$LIBS
+ if test -z "$tputs_library"; then
+ LIBS_TERMCAP=
+@@ -2833,7 +2833,8 @@
+ AC_MSG_RESULT([$msg])
+ if test "X$msg" = Xno; then
+ AC_MSG_ERROR([The required function `tputs' was not found in any library.
+-These libraries were tried: libncurses, libterminfo, libtermcap, libcurses.
++The following libraries were tried (in order):
++ libtinfo, libncurses, libterminfo, libtermcap, libcurses
+ Please try installing whichever of these libraries is most appropriate
+ for your system, together with its header files.
+ For example, a libncurses-dev(el) or similar package.])
+@@ -2865,7 +2866,7 @@
+ ## (HAVE_LIBNCURSES was not always true, but is since 2010-03-18.)
+ if test "x$HAVE_LIBNCURSES" = "xyes"; then
+ TERMINFO=yes
+- LIBS_TERMCAP="-lncurses"
++ test -z "$LIBS_TERMCAP" && LIBS_TERMCAP="-lncurses"
+ fi
+ ;;
+