aboutsummaryrefslogtreecommitdiff
path: root/emacs
diff options
context:
space:
mode:
Diffstat (limited to 'emacs')
-rw-r--r--emacs/24.1/07_all_ar.patch47
-rw-r--r--emacs/24.2/07_all_ar.patch47
2 files changed, 94 insertions, 0 deletions
diff --git a/emacs/24.1/07_all_ar.patch b/emacs/24.1/07_all_ar.patch
new file mode 100644
index 0000000..179a9da
--- /dev/null
+++ b/emacs/24.1/07_all_ar.patch
@@ -0,0 +1,47 @@
+Get AR and ARFLAGS from configure.
+https://bugs.gentoo.org/436758
+http://debbugs.gnu.org/12549
+
+--- emacs-24.2-orig/lwlib/Makefile.in
++++ emacs-24.2/lwlib/Makefile.in
+@@ -37,7 +37,8 @@
+ CPPFLAGS=@CPPFLAGS@
+ RANLIB=@RANLIB@
+
+-AR = ar cq
++AR = @AR@
++ARFLAGS = @ARFLAGS@
+
+ LUCID_OBJS = lwlib-Xlw.o xlwmenu.o lwlib-Xaw.o
+ MOTIF_OBJS = lwlib-Xm.o
+@@ -65,7 +66,7 @@
+
+ liblw.a: $(OBJS)
+ rm -f $@
+- $(AR) $@ $(OBJS)
++ $(AR) $(ARFLAGS) $@ $(OBJS)
+ $(RANLIB) $@
+
+ ## Generated files in ../src, non-generated in $(srcdir)/../src.
+--- emacs-24.2-orig/oldXMenu/Makefile.in
++++ emacs-24.2/oldXMenu/Makefile.in
+@@ -57,8 +57,8 @@
+ TAGS = etags
+ RM = rm -f
+ RANLIB = @RANLIB@
+-# Solaris 2.1 ar doesn't accept the 'l' option.
+-AR = ar cq
++AR = @AR@
++ARFLAGS = @ARFLAGS@
+
+ OBJS = Activate.o \
+ AddPane.o \
+@@ -98,7 +98,7 @@
+
+ libXMenu11.a: $(OBJS) $(EXTRA)
+ $(RM) $@
+- $(AR) $@ $(OBJS) $(EXTRA)
++ $(AR) $(ARFLAGS) $@ $(OBJS) $(EXTRA)
+ $(RANLIB) $@
+
+ Activate.o: Activate.c XMenuInt.h XMenu.h X10.h
diff --git a/emacs/24.2/07_all_ar.patch b/emacs/24.2/07_all_ar.patch
new file mode 100644
index 0000000..179a9da
--- /dev/null
+++ b/emacs/24.2/07_all_ar.patch
@@ -0,0 +1,47 @@
+Get AR and ARFLAGS from configure.
+https://bugs.gentoo.org/436758
+http://debbugs.gnu.org/12549
+
+--- emacs-24.2-orig/lwlib/Makefile.in
++++ emacs-24.2/lwlib/Makefile.in
+@@ -37,7 +37,8 @@
+ CPPFLAGS=@CPPFLAGS@
+ RANLIB=@RANLIB@
+
+-AR = ar cq
++AR = @AR@
++ARFLAGS = @ARFLAGS@
+
+ LUCID_OBJS = lwlib-Xlw.o xlwmenu.o lwlib-Xaw.o
+ MOTIF_OBJS = lwlib-Xm.o
+@@ -65,7 +66,7 @@
+
+ liblw.a: $(OBJS)
+ rm -f $@
+- $(AR) $@ $(OBJS)
++ $(AR) $(ARFLAGS) $@ $(OBJS)
+ $(RANLIB) $@
+
+ ## Generated files in ../src, non-generated in $(srcdir)/../src.
+--- emacs-24.2-orig/oldXMenu/Makefile.in
++++ emacs-24.2/oldXMenu/Makefile.in
+@@ -57,8 +57,8 @@
+ TAGS = etags
+ RM = rm -f
+ RANLIB = @RANLIB@
+-# Solaris 2.1 ar doesn't accept the 'l' option.
+-AR = ar cq
++AR = @AR@
++ARFLAGS = @ARFLAGS@
+
+ OBJS = Activate.o \
+ AddPane.o \
+@@ -98,7 +98,7 @@
+
+ libXMenu11.a: $(OBJS) $(EXTRA)
+ $(RM) $@
+- $(AR) $@ $(OBJS) $(EXTRA)
++ $(AR) $(ARFLAGS) $@ $(OBJS) $(EXTRA)
+ $(RANLIB) $@
+
+ Activate.o: Activate.c XMenuInt.h XMenu.h X10.h