summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-08-23 11:43:01 +0000
committerPeter Volkov <pva@gentoo.org>2009-08-23 11:43:01 +0000
commit7dafa1e1e5a8cbdddaec9251e9fd2c637404a865 (patch)
tree6bb1ede0e94cc24200429955842882ca2ab3a044 /dev-python/python-e_dbus
parentapp-text/poppler -> virtual/poppler (diff)
downloadenlightenment-7dafa1e1e5a8cbdddaec9251e9fd2c637404a865.tar.gz
enlightenment-7dafa1e1e5a8cbdddaec9251e9fd2c637404a865.tar.bz2
enlightenment-7dafa1e1e5a8cbdddaec9251e9fd2c637404a865.zip
Added python bindings required to run paroli.
Diffstat (limited to 'dev-python/python-e_dbus')
-rw-r--r--dev-python/python-e_dbus/ChangeLog8
-rw-r--r--dev-python/python-e_dbus/Manifest3
-rw-r--r--dev-python/python-e_dbus/metadata.xml8
-rw-r--r--dev-python/python-e_dbus/python-e_dbus-9999.ebuild21
4 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-e_dbus/ChangeLog b/dev-python/python-e_dbus/ChangeLog
new file mode 100644
index 0000000..82afc97
--- /dev/null
+++ b/dev-python/python-e_dbus/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/python-e_dbus
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 23 Aug 2009; Peter Volkov <pva@gentoo.org> python-e_dbus-9999.ebuild,
+ metadata.xml:
+ Initial import.
+
diff --git a/dev-python/python-e_dbus/Manifest b/dev-python/python-e_dbus/Manifest
new file mode 100644
index 0000000..4f2167d
--- /dev/null
+++ b/dev-python/python-e_dbus/Manifest
@@ -0,0 +1,3 @@
+EBUILD python-e_dbus-9999.ebuild 435 RMD160 48718dc30345fc094c8cf811dd27b5a865e32095 SHA1 3788f7dcacb61bc5e583a943a29603f73967315c SHA256 0a34cc509c5eeff0351eb579533fab9b00499ab2a61c76ddfcc77e2ecfcc3513
+MISC ChangeLog 232 RMD160 4da62436f298a424674b5f9078b856288465e991 SHA1 c22e25c87866853d888c30848f252c985eefcb7a SHA256 a0a642dce6959afb3b14309fd9fb4eeb187af4dfcffbcf87c9633e2c4cb8c337
+MISC metadata.xml 228 RMD160 1890a2965ed780e661e20adcfc4f4cce5f7ca8e9 SHA1 777d2a3ad7f7075c7e75fa5055f3941440e4e875 SHA256 42ea435327140212f3beb05aafebad5053cbad84532f9bb78987de8540c6459a
diff --git a/dev-python/python-e_dbus/metadata.xml b/dev-python/python-e_dbus/metadata.xml
new file mode 100644
index 0000000..832c5fc
--- /dev/null
+++ b/dev-python/python-e_dbus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>enlightenment@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-e_dbus/python-e_dbus-9999.ebuild b/dev-python/python-e_dbus/python-e_dbus-9999.ebuild
new file mode 100644
index 0000000..c04cded
--- /dev/null
+++ b/dev-python/python-e_dbus/python-e_dbus-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON="2.4"
+ESVN_SUB_PROJECT="BINDINGS/python"
+
+inherit enlightenment distutils
+
+DESCRIPTION="Python bindings for E_DBUS library"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+RDEPEND=">=x11-libs/e_dbus-9999"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-python/setuptools-0.6_rc9"
+
+src_unpack() {
+ enlightenment_src_unpack
+}