summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/ethumb/ChangeLog5
-rw-r--r--media-libs/ethumb/ethumb-9999.ebuild15
2 files changed, 13 insertions, 7 deletions
diff --git a/media-libs/ethumb/ChangeLog b/media-libs/ethumb/ChangeLog
index b731ac2..5287273 100644
--- a/media-libs/ethumb/ChangeLog
+++ b/media-libs/ethumb/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for media-libs/ethumb
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Dec 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> ethumb-9999.ebuild:
+ Update live ebuild
+
*ethumb-9999 (17 Aug 2009)
17 Aug 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
diff --git a/media-libs/ethumb/ethumb-9999.ebuild b/media-libs/ethumb/ethumb-9999.ebuild
index dfbf5ba..1052b6d 100644
--- a/media-libs/ethumb/ethumb-9999.ebuild
+++ b/media-libs/ethumb/ethumb-9999.ebuild
@@ -1,19 +1,22 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
+
inherit enlightenment
DESCRIPTION="Enlightenment thumbnailing library (meant to replace epsilon)"
-
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Ethumb"
LICENSE="LGPL-3"
-IUSE="dbus emotion epdf"
+IUSE="+dbus emotion epdf static-libs"
DEPEND=">=dev-libs/eina-9999
- >=media-libs/edje-9999
>=dev-libs/ecore-9999
+ >=media-libs/edje-9999
>=media-libs/evas-9999
+ media-libs/libexif
dbus? ( >=dev-libs/e_dbus-9999 )
emotion? ( >=media-libs/emotion-9999 )
@@ -21,10 +24,10 @@ DEPEND=">=dev-libs/eina-9999
RDEPEND="${DEPEND}"
-src_compile() {
+src_configure() {
MY_ECONF="$(use_enable dbus ethumbd)
$(use_enable emotion)
$(use_enable epdf)"
- enlightenment_src_compile
+ enlightenment_src_configure
}