aboutsummaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2014-01-09 12:20:25 -0500
committerAnthony G. Basile <blueness@gentoo.org>2014-01-09 12:21:20 -0500
commit7ed87c74dfb81761cbcefc10cd4f79394a1d36a3 (patch)
treed42454fd7146d18041770ace67e7d623bdc77830 /test
parentMerge pull request #80 from michaelforney/udevadm-symlink (diff)
downloadeudev-7ed87c74dfb81761cbcefc10cd4f79394a1d36a3.tar.gz
eudev-7ed87c74dfb81761cbcefc10cd4f79394a1d36a3.tar.bz2
eudev-7ed87c74dfb81761cbcefc10cd4f79394a1d36a3.zip
move utf8 functions from libudev-private.h to utf8.h
There's now some more obvious overlap amongst the two utf8 validation functions, but no more than there already was previously. This also adds some menial tests for anyone who wants to do more merging of these two in the future. Adopted for eudev: Anthony G. Basile <blueness@gentoo.org> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am12
-rw-r--r--test/test-utf8.c59
2 files changed, 70 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index eac141f12..a9c28c931 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -8,7 +8,8 @@ AM_CPPFLAGS = \
noinst_PROGRAMS = \
test-libudev \
- test-udev
+ test-udev \
+ test_utf8
test_libudev_SOURCES = \
test-libudev.c
@@ -30,6 +31,15 @@ test_udev_LDADD = \
$(BLKID_LIBS) \
$(SELINUX_LIBS)
+test_utf8_SOURCES = \
+ test-utf8.c
+
+test_utf8_CFLAGS = \
+ $(AM_CFLAGS)
+
+test_utf8_LDADD = \
+ $(top_builddir)/src/libudev/libudev-private.la
+
if HAVE_LIBKMOD
test_udev_LDADD += $(KMOD_LIBS)
endif
diff --git a/test/test-utf8.c b/test/test-utf8.c
new file mode 100644
index 000000000..d2b9771f4
--- /dev/null
+++ b/test/test-utf8.c
@@ -0,0 +1,59 @@
+/*-*- Mode: C; c-basic-offset: 8; indent-tabs-mode: nil -*-*/
+
+/***
+ This file is part of systemd.
+
+ Copyright 2013 Dave Reisner
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+
+#include "utf8.h"
+#include "util.h"
+
+/* helpers for test_udev_encode_string */
+static char *do_encode_string(const char *in) {
+ size_t out_len = strlen(in) * 4;
+ char *out = malloc(out_len);
+
+ assert_se(out);
+ assert_se(udev_encode_string(in, out, out_len) >= 0);
+ puts(out);
+
+ return out;
+}
+
+static bool expect_encoded_as(const char *in, const char *expected) {
+ _cleanup_free_ char *encoded = do_encode_string(in);
+ return streq(encoded, expected);
+}
+
+static void test_udev_encode_string(void) {
+ assert_se(expect_encoded_as("systemd sucks", "systemd\\x20sucks"));
+ assert_se(expect_encoded_as("pinkiepie", "pinkiepie"));
+ assert_se(expect_encoded_as("valíd\\ųtf8", "valíd\\x5cųtf8"));
+ assert_se(expect_encoded_as("s/ash/ng", "s\\x2fash\\x2fng"));
+}
+
+static void test_utf8_is_valid(void) {
+ assert_se(utf8_is_valid("ascii is valid unicode"));
+ assert_se(utf8_is_valid("\341\204\242"));
+ assert_se(!utf8_is_valid("\341\204"));
+}
+
+int main(int argc, char *argv[]) {
+ test_utf8_is_valid();
+ test_udev_encode_string();
+}