summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/app-text/voikko/voikko-1.4_rc1.ebuild')
-rw-r--r--trunk/app-text/voikko/voikko-1.4_rc1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/trunk/app-text/voikko/voikko-1.4_rc1.ebuild b/trunk/app-text/voikko/voikko-1.4_rc1.ebuild
new file mode 100644
index 0000000..8324458
--- /dev/null
+++ b/trunk/app-text/voikko/voikko-1.4_rc1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_PN="lib${P}"
+DESCRIPTION="Free Finnish spellchecking and hyphenation library"
+HOMEPAGE="http://www.lemi.fi/voikko/"
+#SRC_URI="mirror://sourceforge/voikko/${MY_PN}.tar.gz"
+SRC_URI="http://www.hunspell-fi.org/debian/unstable/libvoikko_1.4~rc1.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="sci-misc/malaga
+ || ( =sci-misc/suomi-malaga-1.0* =sci-misc/suomi-malaga-0.7*
+ =sci-misc/suomi-malaga-9999 )
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_PN/_rc1/}
+
+src_compile() {
+ econf --with-dictionary-path="${ROOT}/usr/lib/suomi-malaga/" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README TODO
+}
+
+pkg_postinst() {
+ ewarn "This is a release candidate for early testers:"
+ ewarn "only report bugs with solutions."
+}