summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Szymaniak <lazy_bum@o2.pl>2010-05-03 19:42:13 +0200
committerPiotr Szymaniak <lazy_bum@o2.pl>2010-05-03 19:42:13 +0200
commit9f388192cbfef6eeb55559d16c6df642354cf9c4 (patch)
tree2f2ad2603d38ae90a6bc577ec3093f8bfdad10cd
parent[games-simulation/openttd-1.0.1] Bump from rc2. (diff)
downloadgamerlay-9f388192cbfef6eeb55559d16c6df642354cf9c4.tar.gz
gamerlay-9f388192cbfef6eeb55559d16c6df642354cf9c4.tar.bz2
gamerlay-9f388192cbfef6eeb55559d16c6df642354cf9c4.zip
osmosdemo: New package.
-rw-r--r--games-puzzle/osmosdemo/Manifest2
-rw-r--r--games-puzzle/osmosdemo/osmosdemo-1.6.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/games-puzzle/osmosdemo/Manifest b/games-puzzle/osmosdemo/Manifest
new file mode 100644
index 0000000..72d9458
--- /dev/null
+++ b/games-puzzle/osmosdemo/Manifest
@@ -0,0 +1,2 @@
+DIST OsmosDemo_1.6.0.tar.gz 7796374 RMD160 b069cafac15acfc8dc50efcc2a60a1be04b6415d SHA1 ed0a55d5b451c87041b2dacb846195868e91046f SHA256 ebc208652edaee4995cc55cdd1e422743462567de340b647a8dd454f853dd161
+EBUILD osmosdemo-1.6.0.ebuild 1102 RMD160 320cc0ddb7e6c4d11b09f00718ff21d939750f06 SHA1 bb5ecbf7c154012abceb2aacca8317d3097fe5d6 SHA256 95c1390a4f777f659367a2cff2b598f3fe7afc05166385652dc4a986986eb5aa
diff --git a/games-puzzle/osmosdemo/osmosdemo-1.6.0.ebuild b/games-puzzle/osmosdemo/osmosdemo-1.6.0.ebuild
new file mode 100644
index 0000000..538c07b
--- /dev/null
+++ b/games-puzzle/osmosdemo/osmosdemo-1.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils games
+
+MY_PN="OsmosDemo"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Play as a single-celled organism absorbing others"
+HOMEPAGE="http://www.hemispheregames.com/osmos/"
+SRC_URI="http://www.hemispheregames.com/blog/wp-content/uploads/2010/04/${MY_P}.tar.gz"
+
+LICENSE="OSMOS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+PROPERTIES="interactive"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ x11-libs/libX11
+ media-libs/freetype:2
+ sys-libs/glibc
+ media-libs/openal
+ media-libs/libvorbis"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+GAMES_CHECK_LICENSE="yes"
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doexe ${MY_PN} ${MY_PN}.bin{32,64} || die "doexe"
+ dohtml readme.html
+ doins -r Fonts/ Sounds/ Textures/ Osmos-* *.cfg || die "doins failed"
+ newicon Icons/256x256.png ${PN}.png
+
+ games_make_wrapper ${PN} ./${MY_PN} "${dir}"
+ make_desktop_entry ${PN} "Osmos Demo"
+
+ prepgamesdirs
+}