summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-07-12 23:13:46 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-07-12 23:45:59 +0300
commitbb14430918c8efadda0508faef1a10423e5150c1 (patch)
tree432984c2ba2a9d8505261eaf450646cf3eb8014e
parentgames-engines/fifengine: migrate to cmake.eclass (diff)
downloadgamerlay-bb14430918c8efadda0508faef1a10423e5150c1.tar.gz
gamerlay-bb14430918c8efadda0508faef1a10423e5150c1.tar.bz2
gamerlay-bb14430918c8efadda0508faef1a10423e5150c1.zip
games-fps/dhewm3: update to 1.5.1
Migrage to cmake.eclass Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
-rw-r--r--games-fps/dhewm3/Manifest2
-rw-r--r--games-fps/dhewm3/dhewm3-1.5.1.ebuild51
2 files changed, 52 insertions, 1 deletions
diff --git a/games-fps/dhewm3/Manifest b/games-fps/dhewm3/Manifest
index a49bb93..f2216e5 100644
--- a/games-fps/dhewm3/Manifest
+++ b/games-fps/dhewm3/Manifest
@@ -1 +1 @@
-DIST dhewm3-1.5.1_pre1.tar.gz 5385402 SHA256 bb454cfdf6e698bac2c6b1cfca19d7b1381b8a59cfb8bc4d38b483b7ee23da47 SHA512 73b2c43e16a82bc1a4fd6646493e7c69049a3c3abaac2206436f10d6180d616ad38c2c3480538e2690654c2cb73ec1be47d312939d64fd92ce03aff7fe64ceba WHIRLPOOL 822c121e05d8fdff1748bfdce70acddbe1f88805d362eba0f9958ef3dd081ce5d5fe78fb4a8eb10ba60e82279afb6b6d5f93980c25d7a56864c3d638dc2efb9b
+DIST dhewm3-1.5.1-src.tar.xz 3353652 SHA256 31671f35fb6f83272dfa2a27c0dad6183bc228f1f1a448ef925052cf4dcf4b68 SHA512 d9a90a5bca31840df3cf68e6b998f8b102dbcb17057588a11cd437995628b0454988cf50767d3ddf1371ff67c65cb2b8f83370a200b75c6e0d977426704da0ce WHIRLPOOL 59eebd8f5da2d14a50b57cf00414f1bc8440bbb48eea2499ee433066dff9c8a9a26de7c6c02e509ef98637380681e5d4411876db67b9e1ee7e1ec0f5833769bf
diff --git a/games-fps/dhewm3/dhewm3-1.5.1.ebuild b/games-fps/dhewm3/dhewm3-1.5.1.ebuild
new file mode 100644
index 0000000..91f55cb
--- /dev/null
+++ b/games-fps/dhewm3/dhewm3-1.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A Doom 3 GPL source modification."
+HOMEPAGE="https://github.com/dhewm/dhewm3"
+SRC_URI="https://github.com/dhewm/dhewm3/releases/download/${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dedicated"
+
+DEPEND="
+ virtual/jpeg:0
+ media-libs/libogg
+ media-libs/libsdl2
+ media-libs/libvorbis
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib:=
+"
+RDEPEND="${DEPEND}"
+
+CMAKE_USE_DIR="${S}/neo"
+
+DATADIR=/usr/share/dhewm3
+DOCS="README.md"
+
+# TODO: patch for common games-dir with roe and doom3-data
+
+src_configure() {
+ mycmakeargs=(
+ -DDEDICATED=ON
+ -DSDL2=ON
+ -DCORE=$(usex dedicated OFF ON)
+ -DBASE=$(usex dedicated OFF ON)
+ -DD3XP=$(usex dedicated OFF ON)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "You need to copy *.pk4 from either your installation media or your hard drive to"
+ elog "/usr/share/dhewm3/base before running the game,"
+ elog "or 'emerge games-fps/doom3-data' to install from CD."
+ echo
+}