summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Unbehaun <frostworks@gmx.de>2009-10-12 17:09:42 +0200
committerMarcel Unbehaun <frostworks@gmx.de>2009-10-12 17:09:42 +0200
commit8e0d1dab29d4e5b8c45fb73990cd60016e195fa0 (patch)
tree09bcbecf63d643bc1aab1e145e009d3eafe5790d /dev-libs/box2d/files/box2d-2.0.1-gcc4.patch
parent(games-puzzle/laserreaction) fixed depend on fmod-3* /laserreaction-1.0.ebuild (diff)
downloadgamerlay-8e0d1dab29d4e5b8c45fb73990cd60016e195fa0.tar.gz
gamerlay-8e0d1dab29d4e5b8c45fb73990cd60016e195fa0.tar.bz2
gamerlay-8e0d1dab29d4e5b8c45fb73990cd60016e195fa0.zip
(dev-libs/box2d) initial box2d-2.0.1.ebuild
(dev-libs/box2d) new Manifest (dev-libs/box2d) new files/box2d-2.0.1-gcc4.patch (dev-libs/box2d) new metadata.xml (games-arcade/jamp) new Manifest (games-arcade/jamp) new files/jamp-1.0.2-ownbox2d.patch (games-arcade/jamp) initial jamp-1.0.2.ebuild (games-arcade/jamp) new metadata.xml
Diffstat (limited to 'dev-libs/box2d/files/box2d-2.0.1-gcc4.patch')
-rw-r--r--dev-libs/box2d/files/box2d-2.0.1-gcc4.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/box2d/files/box2d-2.0.1-gcc4.patch b/dev-libs/box2d/files/box2d-2.0.1-gcc4.patch
new file mode 100644
index 0000000..16da07c
--- /dev/null
+++ b/dev-libs/box2d/files/box2d-2.0.1-gcc4.patch
@@ -0,0 +1,25 @@
+diff -Naur Box2D/Source/Common/b2BlockAllocator.cpp Box2D/Source/Common/b2BlockAllocator.cpp
+--- Box2D/Source/Common/b2BlockAllocator.cpp 2007-11-24 11:25:02.000000000 +0100
++++ Box2D/Source/Common/b2BlockAllocator.cpp 2009-10-12 15:56:39.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <cstdlib>
+ #include <memory>
+ #include <climits>
++#include <cstring>
+
+ int32 b2BlockAllocator::s_blockSizes[b2_blockSizes] =
+ {
+diff -Naur Box2D/Source/Common/b2Math.h Box2D/Source/Common/b2Math.h
+--- Box2D/Source/Common/b2Math.h 2008-04-07 23:35:04.000000000 +0200
++++ Box2D/Source/Common/b2Math.h 2009-10-12 15:55:44.000000000 +0200
+@@ -23,8 +23,8 @@
+ #include <cmath>
+ #include <cfloat>
+ #include <cstdlib>
+-
+-#include <stdio.h>
++#include <cstring>
++#include <cstdio>
+
+ #ifdef TARGET_FLOAT32_IS_FIXED
+