summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Unbehaun <frostworks@gmx.de>2009-07-29 14:05:32 +0200
committerMarcel Unbehaun <frostworks@gmx.de>2009-07-29 14:05:32 +0200
commit0ff3702126a2c5e8dd0a693ffd9c583bfb67a10b (patch)
treef4500430a31dd762e40d0cb44cad10c96f965c70 /games-action
parent(games-action/gunroar) added Manifest (diff)
downloadgamerlay-0ff3702126a2c5e8dd0a693ffd9c583bfb67a10b.tar.gz
gamerlay-0ff3702126a2c5e8dd0a693ffd9c583bfb67a10b.tar.bz2
gamerlay-0ff3702126a2c5e8dd0a693ffd9c583bfb67a10b.zip
(games-action/gunroarhi) added Manifest
(games-action/gunroarhi) added files/digest-gunroarhi-0.30 (games-action/gunroarhi) added files/gunroarhi-0.30.diff (games-action/gunroarhi) added files/gunroarhi.png (games-action/gunroarhi) added gunroarhi-0.30.ebuild (games-action/gunroarhi) added metadata.xml
Diffstat (limited to 'games-action')
-rw-r--r--games-action/gunroarhi/Manifest5
-rw-r--r--games-action/gunroarhi/files/digest-gunroarhi-0.303
-rw-r--r--games-action/gunroarhi/files/gunroarhi-0.30.diff153
-rw-r--r--games-action/gunroarhi/files/gunroarhi.pngbin0 -> 3544 bytes
-rw-r--r--games-action/gunroarhi/gunroarhi-0.30.ebuild75
-rw-r--r--games-action/gunroarhi/metadata.xml9
6 files changed, 245 insertions, 0 deletions
diff --git a/games-action/gunroarhi/Manifest b/games-action/gunroarhi/Manifest
new file mode 100644
index 0000000..fe8c7cb
--- /dev/null
+++ b/games-action/gunroarhi/Manifest
@@ -0,0 +1,5 @@
+AUX gunroarhi-0.30.diff 5154 RMD160 c1aaf017b13622a8cf9474ec34f245b96e8cd601 SHA1 662f35305195cc68b9b89cc16b54e70723e7c344 SHA256 0aba15b7e043e40f2f033ff619f909d9f371b670c2d6d3f4d546a5d9a2ff447a
+AUX gunroarhi.png 3544 RMD160 f98b11eb0250eaf0bd859d8b3aad3545d52e404e SHA1 8694da4a1fbb34cf7dedc7ead192f62d2b43350a SHA256 c855b79b3c1c95da5fcdf592261f56568114a03252821f71a2cd9a1e60c15e65
+DIST gr_hi0_30.zip 5502395 RMD160 d321ba0f8a4eaa2f1f84c6c3a48f4d29f43c7f07 SHA1 4238a995f5d766f22ea396ccce86036886b32205 SHA256 c2adc4d1aa616736e968d4214a2bc52b0d2a21ae1dbbe5a01e9c57826901692a
+EBUILD gunroarhi-0.30.ebuild 1924 RMD160 7324d372ab94904fdb57779e68636f46fe081672 SHA1 3f3cfe46e9eb570266f56280a7e29cc729b1e5ce SHA256 713981098edb2778665501fff275ccace9f11d8c7a05c3f055d6ac7abdc77326
+MISC metadata.xml 249 RMD160 220cde0fc1a8d7d355705f0f6772bd8d77cdc17a SHA1 34b33eb8d24cd8bfef2ddfb8e80334fd77cc9488 SHA256 3875fd5008d7f5bfe7f3cf7bf330c209a5034f5988d37c1699fb3be35a7be906
diff --git a/games-action/gunroarhi/files/digest-gunroarhi-0.30 b/games-action/gunroarhi/files/digest-gunroarhi-0.30
new file mode 100644
index 0000000..28c60c0
--- /dev/null
+++ b/games-action/gunroarhi/files/digest-gunroarhi-0.30
@@ -0,0 +1,3 @@
+MD5 0702fc87bcf9d77530af0e84e8a94d7a gr_hi0_30.zip 5502395
+RMD160 d321ba0f8a4eaa2f1f84c6c3a48f4d29f43c7f07 gr_hi0_30.zip 5502395
+SHA256 c2adc4d1aa616736e968d4214a2bc52b0d2a21ae1dbbe5a01e9c57826901692a gr_hi0_30.zip 5502395
diff --git a/games-action/gunroarhi/files/gunroarhi-0.30.diff b/games-action/gunroarhi/files/gunroarhi-0.30.diff
new file mode 100644
index 0000000..0acba13
--- /dev/null
+++ b/games-action/gunroarhi/files/gunroarhi-0.30.diff
@@ -0,0 +1,153 @@
+diff -Naur gr_hi/import/opengl.d gr_hi-gentoo/import/opengl.d
+--- gr_hi/import/opengl.d 2005-06-18 02:46:00.000000000 +0200
++++ gr_hi-gentoo/import/opengl.d 2007-09-20 08:18:12.000000000 +0200
+@@ -1,10 +1,4 @@
+-version (Win32) {
+- private import std.c.windows.windows;
+- extern(Windows):
+-}
+-version (linux) {
+ extern(C):
+-}
+
+ alias uint GLenum;
+ alias ubyte GLboolean;
+@@ -1116,7 +1110,7 @@
+ /*************************************************************/
+
+ void /*APIENTRY*/glAccum (GLenum op, GLfloat value);
+-void /*APIENTRY*/glAlphaFunc (GLenum func, GLclampf ref);
++void /*APIENTRY*/glAlphaFunc (GLenum func, GLclampf);
+ GLboolean /*APIENTRY*/glAreTexturesResident (GLsizei n, GLuint *textures, GLboolean *residences);
+ void /*APIENTRY*/glArrayElement (GLint i);
+ void /*APIENTRY*/glBegin (GLenum mode);
+@@ -1369,7 +1363,7 @@
+ void /*APIENTRY*/glScissor (GLint x, GLint y, GLsizei width, GLsizei height);
+ void /*APIENTRY*/glSelectBuffer (GLsizei size, GLuint *buffer);
+ void /*APIENTRY*/glShadeModel (GLenum mode);
+-void /*APIENTRY*/glStencilFunc (GLenum func, GLint ref, GLuint mask);
++void /*APIENTRY*/glStencilFunc (GLenum func, GLint, GLuint mask);
+ void /*APIENTRY*/glStencilMask (GLuint mask);
+ void /*APIENTRY*/glStencilOp (GLenum fail, GLenum zfail, GLenum zpass);
+ void /*APIENTRY*/glTexCoord1d (GLdouble s);
+diff -Naur gr_hi/import/openglu.d gr_hi-gentoo/import/openglu.d
+--- gr_hi/import/openglu.d 2005-06-18 02:46:00.000000000 +0200
++++ gr_hi-gentoo/import/openglu.d 2007-09-20 08:15:01.000000000 +0200
+@@ -1,11 +1,6 @@
+ import opengl;
+
+-version (Win32) {
+- extern(Windows):
+-}
+-version (linux) {
+ extern(C):
+-}
+
+ GLubyte* gluErrorString (
+ GLenum errCode);
+diff -Naur gr_hi/import/SDL.d gr_hi-gentoo/import/SDL.d
+--- gr_hi/import/SDL.d 2005-06-18 02:46:00.000000000 +0200
++++ gr_hi-gentoo/import/SDL.d 2007-09-20 08:14:23.000000000 +0200
+@@ -20,18 +20,28 @@
+ slouken@devolution.com
+ */
+
+-import SDL_types;
+-import SDL_getenv;
+-import SDL_error;
+-import SDL_rwops;
+-import SDL_timer;
+-import SDL_audio;
+-import SDL_cdrom;
+-import SDL_joystick;
+-import SDL_events;
+-import SDL_video;
+-import SDL_byteorder;
+-import SDL_Version;
++public import SDL_Keysym;
++public import SDL_Version;
++public import SDL_active;
++public import SDL_audio;
++public import SDL_byteorder;
++public import SDL_cdrom;
++public import SDL_copying;
++public import SDL_endian;
++public import SDL_error;
++public import SDL_events;
++public import SDL_getenv;
++public import SDL_joystick;
++public import SDL_keyboard;
++public import SDL_mouse;
++public import SDL_mutex;
++public import SDL_quit;
++public import SDL_rwops;
++public import SDL_syswm;
++public import SDL_thread;
++public import SDL_timer;
++public import SDL_types;
++public import SDL_video;
+
+ extern(C):
+
+diff -Naur gr_hi/Makefile gr_hi-gentoo/Makefile
+--- gr_hi/Makefile 1970-01-01 01:00:00.000000000 +0100
++++ gr_hi-gentoo/Makefile 2007-09-20 08:14:23.000000000 +0200
+@@ -0,0 +1,25 @@
++DC=gdmd
++#DC=gdc
++ifeq ($(DC), gdmd)
++DFLAGS=-O -d -release -Iimport -Isrc
++#DFLAGS=-g -debug -Iimport -Isrc
++DOUT=-of
++else
++DFLAGS=-O -frelease -Iimport -Isrc
++#DFLAGS=-g -fdebug -Iimport -Isrc
++DOUT=-o
++endif
++
++DSRC=$(shell find src/abagames -name "*.d")
++SOURCES=$(DSRC) import/SDL_video.d import/SDL_mixer.d
++OBJS=$(SOURCES:.d=.o)
++EXE=gunroarhi
++
++all: $(EXE)
++
++$(EXE): $(OBJS)
++ gcc -o $@ $(OBJS) -lgphobos -lpthread -lm -lSDL -lGL -lGLU -lSDL_mixer
++
++$(OBJS): %.o: %.d
++ $(DC) -c $(DOUT)$@ $(DFLAGS) $<
++
+diff -Naur gr_hi/src/abagames/util/sdl/luminous.d gr_hi-gentoo/src/abagames/util/sdl/luminous.d
+--- gr_hi/src/abagames/util/sdl/luminous.d 2005-06-18 02:46:00.000000000 +0200
++++ gr_hi-gentoo/src/abagames/util/sdl/luminous.d 2007-09-20 08:14:23.000000000 +0200
+@@ -34,7 +34,7 @@
+ private void makeLuminousTexture() {
+ uint *data = td;
+ int i;
+- memset(data, 0, luminousTextureWidth * luminousTextureHeight * 4 * uint.sizeof);
++ // memset(data, 0, luminousTextureWidth * luminousTextureHeight * 4 * uint.sizeof);
+ glGenTextures(1, &luminousTexture);
+ glBindTexture(GL_TEXTURE_2D, luminousTexture);
+ glTexImage2D(GL_TEXTURE_2D, 0, 4, luminousTextureWidth, luminousTextureHeight, 0,
+diff -Naur gr_hi/src/abagames/util/sdl/mouse.d gr_hi-gentoo/src/abagames/util/sdl/mouse.d
+--- gr_hi/src/abagames/util/sdl/mouse.d 2005-09-11 02:47:42.000000000 +0200
++++ gr_hi-gentoo/src/abagames/util/sdl/mouse.d 2007-09-20 08:14:23.000000000 +0200
+@@ -11,6 +11,17 @@
+ private import abagames.util.sdl.input;
+ private import abagames.util.sdl.recordableinput;
+ private import abagames.util.sdl.screen;
++
++uint SDL_BUTTON(uint X) { return SDL_PRESSED << (X-1); }
++const uint SDL_BUTTON_LEFT = 1;
++const uint SDL_BUTTON_MIDDLE = 2;
++const uint SDL_BUTTON_RIGHT = 3;
++const uint SDL_BUTTON_WHEELUP = 4;
++const uint SDL_BUTTON_WHEELDOWN = 5;
++const uint SDL_BUTTON_LMASK = SDL_PRESSED << (SDL_BUTTON_LEFT - 1);
++const uint SDL_BUTTON_MMASK = SDL_PRESSED << (SDL_BUTTON_MIDDLE - 1);
++const uint SDL_BUTTON_RMASK = SDL_PRESSED << (SDL_BUTTON_RIGHT - 1);
++
+
+ /**
+ * Mouse input.
diff --git a/games-action/gunroarhi/files/gunroarhi.png b/games-action/gunroarhi/files/gunroarhi.png
new file mode 100644
index 0000000..68943a2
--- /dev/null
+++ b/games-action/gunroarhi/files/gunroarhi.png
Binary files differ
diff --git a/games-action/gunroarhi/gunroarhi-0.30.ebuild b/games-action/gunroarhi/gunroarhi-0.30.ebuild
new file mode 100644
index 0000000..6ddd349
--- /dev/null
+++ b/games-action/gunroarhi/gunroarhi-0.30.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+MY_PN=gr_hi
+MY_PV=${PV//./_}
+
+DESCRIPTION="Guns, Guns, Guns! 360-degree gunboat shooter, fork of ABAs 'Gunroar'"
+HOMEPAGE="http://www.edit.ne.jp/~otoyan/soft/gr_hi.html"
+SRC_URI="http://www.edit.ne.jp/~otoyan/soft/gr_hi/${MY_PN}${MY_PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/mesa
+ media-libs/sdl-mixer"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_setup() {
+ games_pkg_setup
+
+ # gcc must be built with "d" USE-FLAG
+ if ! built_with_use sys-devel/gcc:4.1 d; then
+ ewarn "sys-devel/gcc must be built with d for this package"
+ ewarn "to function."
+ die "recompile gcc with USE=\"d\""
+ fi
+ if [ "$(gcc-major-version)" == "4" ] && [ "$(gcc-minor-version)" == "2" ] ; then
+ die "gdc doesn't work with sys-devel/gcc-4.2 currently - use 4.1 instead"
+ fi
+
+}
+
+src_unpack(){
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}.diff
+ sed -i \
+ -e 's:"\(images/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i gr_hi/src/abagames/util/sdl/texture.d \
+ -e 's:"\(sounds/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i gr_hi/src/abagames/util/sdl/sound.d \
+ -e 's:"\(gr.prf[^"]*\)":"'${GAMES_STATEDIR}'/'${PN}'/\1":g' -i gr_hi/src/abagames/gr/prefmanager.d \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin ${PN}
+ dodir "${GAMES_STATEDIR}/${PN}" "${GAMES_STATEDIR}/${PN}/replay"
+ local statedir="${GAMES_STATEDIR}"/${PN}
+
+ if [ ! -e ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf ]; then
+ touch ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf
+ chmod ug+rw ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf
+ fi
+
+ local datadir="${GAMES_DATADIR}"/${PN}
+ dodir ${datadir}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r images sounds || die
+ newicon "${FILESDIR}"/${PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN}
+ dodoc readme*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}
+
+
diff --git a/games-action/gunroarhi/metadata.xml b/games-action/gunroarhi/metadata.xml
new file mode 100644
index 0000000..4e4714e
--- /dev/null
+++ b/games-action/gunroarhi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>frostworks@gmx.de</email>
+ <name>Marcel Unbehaun</name>
+</maintainer>
+<herd>games</herd>
+</pkgmetadata>