summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Unbehaun <marcel@frostworx.de>2011-10-30 14:39:41 +0100
committerMarcel Unbehaun <marcel@frostworx.de>2011-10-30 14:39:41 +0100
commit196415525069e15258f288cf14766b53e7ddd148 (patch)
tree2667828b852f4aab2cefda60d4138a5922390547 /games-emulation
parent[games-emulation/pcsx2] added plugin useflags, dropped pcsx2-meta (diff)
downloadgamerlay-196415525069e15258f288cf14766b53e7ddd148.tar.gz
gamerlay-196415525069e15258f288cf14766b53e7ddd148.tar.bz2
gamerlay-196415525069e15258f288cf14766b53e7ddd148.zip
[games-emulation/ps2emu-zerospu+spu2-x] added soundtouch useflag to allow choosing system/internal soundtouch
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ps2emu-spu2-x/Manifest4
-rw-r--r--games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-1.4.ebuild10
-rw-r--r--games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-9999.ebuild10
-rw-r--r--games-emulation/ps2emu-zerospu/Manifest4
-rw-r--r--games-emulation/ps2emu-zerospu/ps2emu-zerospu-0.4.6.ebuild8
-rw-r--r--games-emulation/ps2emu-zerospu/ps2emu-zerospu-9999.ebuild8
6 files changed, 28 insertions, 16 deletions
diff --git a/games-emulation/ps2emu-spu2-x/Manifest b/games-emulation/ps2emu-spu2-x/Manifest
index cae7cbd..5f07a97 100644
--- a/games-emulation/ps2emu-spu2-x/Manifest
+++ b/games-emulation/ps2emu-spu2-x/Manifest
@@ -1,3 +1,3 @@
DIST pcsx2-0.9.8.7z 10488726 RMD160 92e5cd6ec958092fe1ba6cff79763dec99dac60a SHA1 80f23ad79892306de738cf4138edc6d9563eb9c4 SHA256 1037b2418e7523f565d86c3a4ec4a2b4f4664e8c84dee73d62289961c69ab814
-EBUILD ps2emu-spu2-x-1.4.ebuild 3422 RMD160 fbaf13b18edb8a6634a27f41f48faae19f5d4baa SHA1 c1fa5f1ca42fc60c60b5be3229291d51aafc3723 SHA256 3bc9c15e8c53384ef3f3e6359fa2af6d98ef07376a2890f87a323f7ab06d6be8
-EBUILD ps2emu-spu2-x-9999.ebuild 3497 RMD160 78111905e49c5120f9a7f81f4e1c45e34fd01cb0 SHA1 31d4d312a8ff9af7be5e6b889d359a3225e42a6e SHA256 f527d8d38b6776066826b152c50b95780346863eb4a35857dcec64a483401f23
+EBUILD ps2emu-spu2-x-1.4.ebuild 3529 RMD160 dbf254cb02de6b759bfc476cc9495f5c4d23a69a SHA1 625dd735d69bb1b7a614688c609c8c04b9db3119 SHA256 c528096a08026324cefb729c567004f12479634b50be6f70ada0dea5857d2335
+EBUILD ps2emu-spu2-x-9999.ebuild 3605 RMD160 515ef7657c6ef3bb369a24732cefcca931f9d659 SHA1 9726d9763faaca58a5cb3942d0d2b32f8db91871 SHA256 fbc7e86069500b97a429db50daedf05679cc5fc0c2072c16ce15985bf9c8c522
diff --git a/games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-1.4.ebuild b/games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-1.4.ebuild
index 922d051..1fdfd89 100644
--- a/games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-1.4.ebuild
+++ b/games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-1.4.ebuild
@@ -16,7 +16,7 @@ SRC_URI="http://forums.pcsx2.net/attachment.php?aid=28280 -> pcsx2-0.9.8.7z"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86"
-IUSE="debug"
+IUSE="debug soundtouch"
if use amd64; then
ABI="x86"
fi
@@ -52,11 +52,15 @@ DEPEND="dev-cpp/sparsehash
app-emulation/emul-linux-x86-sdl
app-emulation/emul-linux-x86-soundlibs
app-emulation/emul-linux-x86-wxGTK
- )"
+ )
+ soundtouch? ( media-libs/libsoundtouch )
+ "
RDEPEND="${DEPEND}"
src_prepare() {
+ if use soundtouch; then
sed -i -e "s:add_subdirectory(3rdparty)::g" -i CMakeLists.txt
+ fi
sed -i -e "s:INSTALL(FILES:#INSTALL(FILES:g" -i CMakeLists.txt
sed -i -e "s:add_subdirectory(locales)::g" -i CMakeLists.txt
sed -i -e "s:add_subdirectory(tools)::g" -i CMakeLists.txt
@@ -95,7 +99,7 @@ src_configure() {
-DPLUGIN_DIR=$(games_get_libdir)/pcsx2
-DPLUGIN_DIR_COMPILATION=$(games_get_libdir)/pcsx2
-DCMAKE_INSTALL_PREFIX=/usr
- -DFORCE_INTERNAL_SOUNDTOUCH=FALSE
+ $(cmake-utils_use !soundtouch FORCE_INTERNAL_SOUNDTOUCH)
${wxgtk_config}
${cg_config}
"
diff --git a/games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-9999.ebuild b/games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-9999.ebuild
index 16ec3ac..f8c120b 100644
--- a/games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-9999.ebuild
+++ b/games-emulation/ps2emu-spu2-x/ps2emu-spu2-x-9999.ebuild
@@ -21,7 +21,7 @@ ESVN_PROJECT="pcsx2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="debug"
+IUSE="debug soundtouch"
if use amd64; then
ABI="x86"
fi
@@ -57,11 +57,15 @@ DEPEND="dev-cpp/sparsehash
app-emulation/emul-linux-x86-sdl
app-emulation/emul-linux-x86-soundlibs
app-emulation/emul-linux-x86-wxGTK
- )"
+ )
+ soundtouch? ( media-libs/libsoundtouch )
+ "
RDEPEND="${DEPEND}"
src_prepare() {
+ if use soundtouch; then
sed -i -e "s:add_subdirectory(3rdparty)::g" -i CMakeLists.txt
+ fi
sed -i -e "s:INSTALL(FILES:#INSTALL(FILES:g" -i CMakeLists.txt
sed -i -e "s:add_subdirectory(locales)::g" -i CMakeLists.txt
sed -i -e "s:add_subdirectory(tools)::g" -i CMakeLists.txt
@@ -99,7 +103,7 @@ src_configure() {
-DPLUGIN_DIR=$(games_get_libdir)/pcsx2
-DPLUGIN_DIR_COMPILATION=$(games_get_libdir)/pcsx2
-DCMAKE_INSTALL_PREFIX=/usr
- -DFORCE_INTERNAL_SOUNDTOUCH=FALSE
+ $(cmake-utils_use !soundtouch FORCE_INTERNAL_SOUNDTOUCH)
${wxgtk_config}
${cg_config}
"
diff --git a/games-emulation/ps2emu-zerospu/Manifest b/games-emulation/ps2emu-zerospu/Manifest
index ed099e1..b38feea 100644
--- a/games-emulation/ps2emu-zerospu/Manifest
+++ b/games-emulation/ps2emu-zerospu/Manifest
@@ -1,3 +1,3 @@
DIST pcsx2-0.9.8.7z 10488726 RMD160 92e5cd6ec958092fe1ba6cff79763dec99dac60a SHA1 80f23ad79892306de738cf4138edc6d9563eb9c4 SHA256 1037b2418e7523f565d86c3a4ec4a2b4f4664e8c84dee73d62289961c69ab814
-EBUILD ps2emu-zerospu-0.4.6.ebuild 2732 RMD160 4e8b90a1282dcbc78194d7ce836a5a1a3116bfdc SHA1 09208840bfbadecd5d9ef85d693c702673473895 SHA256 c6cc8e9feb66cb28395b55aa75455c3351cb08e7c87841c842fef0361e9b5127
-EBUILD ps2emu-zerospu-9999.ebuild 2643 RMD160 2986df6e1ddafd98f2c4538e8e6868a26c418f0e SHA1 8218b55dbd4e52f4634525daabe22c8397c45c2a SHA256 86806ae2038695262a8ccc9e70c964d4aa485cfeb11a97a165ea6b9455f8d844
+EBUILD ps2emu-zerospu-0.4.6.ebuild 2835 RMD160 d9e2050fef8a824ea52874218136d266269b464c SHA1 09b9894808a73f25c992e5102e29f27b28b1136c SHA256 614ae1a3883712c3ce5257a4238a9f2a5d3bab0b9c29c97b6adcc20ceddeac77
+EBUILD ps2emu-zerospu-9999.ebuild 2746 RMD160 f5bad67d8b96d16f5583c570a06398abaf5934e2 SHA1 ad0b66d6fda6ab31baa5afd0d629404a9b118db9 SHA256 b8296e538e8ef67fbb351abfa712aea826f95ffb0d74d9a70ff0d04c29f03275
diff --git a/games-emulation/ps2emu-zerospu/ps2emu-zerospu-0.4.6.ebuild b/games-emulation/ps2emu-zerospu/ps2emu-zerospu-0.4.6.ebuild
index 0486128..bb7b97f 100644
--- a/games-emulation/ps2emu-zerospu/ps2emu-zerospu-0.4.6.ebuild
+++ b/games-emulation/ps2emu-zerospu/ps2emu-zerospu-0.4.6.ebuild
@@ -16,7 +16,7 @@ SRC_URI="http://forums.pcsx2.net/attachment.php?aid=28280 -> pcsx2-0.9.8.7z"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86"
-IUSE="debug"
+IUSE="debug soundtouch"
if use amd64; then
ABI="x86"
fi
@@ -26,7 +26,7 @@ else
CMAKE_BUILD_TYPE="Release"
fi
-DEPEND="
+DEPEND="soundtouch? ( media-libs/libsoundtouch )
x86? (
media-libs/alsa-lib
media-libs/portaudio
@@ -36,7 +36,9 @@ DEPEND="
RDEPEND="${DEPEND}"
src_prepare() {
+ if use soundtouch; then
sed -i -e "s:add_subdirectory(3rdparty)::g" -i CMakeLists.txt
+ fi
sed -i -e "s:INSTALL(FILES:#INSTALL(FILES:g" -i CMakeLists.txt
sed -i -e "s:add_subdirectory(locales)::g" -i CMakeLists.txt
sed -i -e "s:add_subdirectory(tools)::g" -i CMakeLists.txt
@@ -68,7 +70,7 @@ src_configure() {
-DPLUGIN_DIR=$(games_get_libdir)/pcsx2
-DPLUGIN_DIR_COMPILATION=$(games_get_libdir)/pcsx2
-DCMAKE_INSTALL_PREFIX=/usr
- -DFORCE_INTERNAL_SOUNDTOUCH=FALSE
+ $(cmake-utils_use !soundtouch FORCE_INTERNAL_SOUNDTOUCH)
"
cmake-utils_src_configure
}
diff --git a/games-emulation/ps2emu-zerospu/ps2emu-zerospu-9999.ebuild b/games-emulation/ps2emu-zerospu/ps2emu-zerospu-9999.ebuild
index aca7024..f3b0851 100644
--- a/games-emulation/ps2emu-zerospu/ps2emu-zerospu-9999.ebuild
+++ b/games-emulation/ps2emu-zerospu/ps2emu-zerospu-9999.ebuild
@@ -16,7 +16,7 @@ ESVN_PROJECT="pcsx2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="debug"
+IUSE="debug soundtouch"
if use amd64; then
ABI="x86"
fi
@@ -26,7 +26,7 @@ else
CMAKE_BUILD_TYPE="Release"
fi
-DEPEND="
+DEPEND="soundtouch? ( media-libs/libsoundtouch )
x86? (
media-libs/alsa-lib
media-libs/portaudio
@@ -36,7 +36,9 @@ DEPEND="
RDEPEND="${DEPEND}"
src_prepare() {
+ if use soundtouch; then
sed -i -e "s:add_subdirectory(3rdparty)::g" -i CMakeLists.txt
+ fi
sed -i -e "s:INSTALL(FILES:#INSTALL(FILES:g" -i CMakeLists.txt
sed -i -e "s:add_subdirectory(locales)::g" -i CMakeLists.txt
sed -i -e "s:add_subdirectory(tools)::g" -i CMakeLists.txt
@@ -66,7 +68,7 @@ src_configure() {
-DPLUGIN_DIR=$(games_get_libdir)/pcsx2
-DPLUGIN_DIR_COMPILATION=$(games_get_libdir)/pcsx2
-DCMAKE_INSTALL_PREFIX=/usr
- -DFORCE_INTERNAL_SOUNDTOUCH=FALSE
+ $(cmake-utils_use !soundtouch FORCE_INTERNAL_SOUNDTOUCH)
"
cmake-utils_src_configure
}