summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2014-05-16 23:24:50 +0600
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2014-05-16 23:24:50 +0600
commitec0510969387bcf428f02bf5bf9c4708dab8f45f (patch)
treef1f83bd5d2299736d46f49285b999c4a9a3aec5f /games-fps
parent[games-arcade/frogatto] audio -> sound (bug #357661), cleanup. (diff)
downloadgamerlay-ec0510969387bcf428f02bf5bf9c4708dab8f45f.tar.gz
gamerlay-ec0510969387bcf428f02bf5bf9c4708dab8f45f.tar.bz2
gamerlay-ec0510969387bcf428f02bf5bf9c4708dab8f45f.zip
[games-fps/xonotic] audio -> sound (bug #357661), cleanup.
Package-Manager: portage-2.2.8-r1 Manifest-Sign-Key: A018DE8C
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic/Manifest2
-rw-r--r--games-fps/xonotic/xonotic-0.5.0.ebuild148
-rw-r--r--games-fps/xonotic/xonotic-0.7.0.ebuild136
-rw-r--r--games-fps/xonotic/xonotic-9999.ebuild4
4 files changed, 2 insertions, 288 deletions
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
deleted file mode 100644
index c2e7325..0000000
--- a/games-fps/xonotic/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST xonotic-0.5.0.zip 988512100 SHA256 58e7226a8b534858f8161c378071f4dab168e2c683f1f986e6e65be75a5b730f SHA512 586aa86df63cd295bdb21d9da532cf6a1ace0d084b601bbad3742a066844a2d4f70cdbc617c58cf2c33464ab2b0ed63cddbee6eba0e04bf5025fa0cc268372da WHIRLPOOL a87ff2966b10aa63da41df57dd8a055a12d6ee5bae3e11b3ab99ff05fcb6b15f35ea60b5cfd7e141a326b56b2cb5d2615eb9ca4c79c35ff48e154ffd7e18057a
-DIST xonotic-0.7.0.zip 1040631083 SHA256 21a5fb5493c269cd3843789cb8598f952d4196e8bc71804b9bd5808b646542c6 SHA512 bde7d23251b80b0071693f013c1620ead3f0ac42f266921c9b37b1a8e4cc24935c9c2a4d5ddee588ce68042ba0341b720417b186b907eaba9e4c731cc3a9697c WHIRLPOOL 8e4340228a3c3f7c565c4aed4513f9fd37b6f702fe5af97e8f01f12e23d61c922355db30520c94034ea20f31353e6227224da85b3385dea5f3e20aa62ba754a9
diff --git a/games-fps/xonotic/xonotic-0.5.0.ebuild b/games-fps/xonotic/xonotic-0.5.0.ebuild
deleted file mode 100644
index a4e5397..0000000
--- a/games-fps/xonotic/xonotic-0.5.0.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-
-inherit eutils games toolchain-funcs check-reqs
-
-MY_PN="${PN^}"
-DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
-HOMEPAGE="http://www.xonotic.org/"
-SRC_URI="http://dl.xonotic.org/${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa crypt debug dedicated opengl +s3tc sdl"
-
-UIRDEPEND="
- media-libs/libogg
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/libmodplug
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- virtual/opengl
- media-libs/freetype:2
- alsa? ( media-libs/alsa-lib )
- s3tc? ( media-libs/libtxc_dxtn )
- sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video,alsa?] )
-"
-UIDEPEND="
- x11-proto/xextproto
- x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- x11-proto/xproto
-"
-RDEPEND="
- sys-libs/zlib
- virtual/jpeg
- media-libs/libpng
- net-misc/curl
- ~dev-libs/d0_blind_id-0.5
- opengl? ( ${UIRDEPEND} )
- !dedicated? ( !opengl? ( ${UIRDEPEND} ) )
-"
-DEPEND="${RDEPEND}
- opengl? ( ${UIDEPEND} )
- !dedicated? ( !opengl? ( ${UIDEPEND} ) )
-"
-
-S="${WORKDIR}/${MY_PN}"
-
-pkg_setup() {
- ewarn "You need 943 MiB diskspace for distfiles."
- CHECKREQS_DISK_BUILD="1960M"
- CHECKREQS_DISK_USR="900M"
- check-reqs_pkg_setup
-}
-
-src_prepare() {
- # for darkplaces
- tc-export CC
-
- # use system libs
- rm -rf misc/buildfiles/
-
- # Engine
- pushd source/darkplaces
- sed -i \
- -e "/^EXE_/s:darkplaces:${PN}:" \
- -e "s:-O3:${CFLAGS}:" \
- -e "/-lm/s:$: ${LDFLAGS}:" \
- -e '/^STRIP/s/strip/true/' \
- makefile.inc || die "sed failed"
-
- if use !alsa; then
- sed -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
- -i makefile || die "sed failed"
- fi
- popd
-}
-
-src_compile() {
- # Engine
- cd source/darkplaces
- if use debug; then
- ENGINEOPTS="debug"
- else
- ENGINEOPTS="release"
- fi
- ENGINEOPTS+=" DP_LINK_TO_LIBJPEG=1 DP_FS_BASEDIR=${GAMES_DATADIR}/${PN}"
-
- if use opengl || ! use dedicated; then
- emake cl-${ENGINEOPTS} || die "emake cl-${ENGINEOPTS} failed"
- if use sdl; then
- emake sdl-${ENGINEOPTS} || die "emake sdl-${ENGINEOPTS} failed"
- fi
- fi
-
- if use dedicated; then
- emake sv-${ENGINEOPTS} || die "emake sv-${ENGINEOPTS} failed"
- fi
-}
-
-src_install() {
- # Engine & docs
- pushd source/darkplaces
- if use opengl || use !dedicated; then
- dogamesbin ${PN}-glx || die "dogamesbin glx failed"
- newicon ../../misc/logos/${PN}_icon.svg ${PN}.svg
- make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
-
- if use sdl; then
- dogamesbin ${PN}-sdl || die "dogamesbin sdl failed"
- make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
- dosym ${PN}-sdl "${GAMES_BINDIR}"/${PN}
- else
- dosym ${PN}-glx "${GAMES_BINDIR}"/${PN}
- fi
- fi
-
- if use dedicated; then
- dogamesbin ${PN}-dedicated || die "dogamesbin dedicated failed"
- fi
- popd
-
- dodoc Docs/*.txt
- dohtml -r Docs
-
- insinto "${GAMES_DATADIR}/${PN}"
-
- # public key for d0_blind_id
- doins key_0.d0pk || die
-
- if use dedicated; then
- doins -r server || die "doins server failed"
- fi
-
- # Data
- doins -r data || die "doins data failed"
-
- prepgamesdirs
-}
diff --git a/games-fps/xonotic/xonotic-0.7.0.ebuild b/games-fps/xonotic/xonotic-0.7.0.ebuild
deleted file mode 100644
index e94fc9d..0000000
--- a/games-fps/xonotic/xonotic-0.7.0.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit eutils games toolchain-funcs flag-o-matic check-reqs
-
-MY_PN="${PN^}"
-DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
-HOMEPAGE="http://www.xonotic.org/"
-SRC_URI="http://dl.xonotic.org/${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa ode opengl +s3tc +sdl +server"
-REQUIRED_USE="
- || ( opengl sdl server )
-"
-
-UIRDEPEND="
- media-libs/libogg
- media-libs/libtheora[encode]
- media-libs/libvorbis
- media-libs/libmodplug
- x11-libs/libX11
- virtual/opengl
- media-libs/freetype:2
- s3tc? ( media-libs/libtxc_dxtn )
-"
-RDEPEND="
- sys-libs/zlib
- virtual/jpeg
- media-libs/libpng:0=
- net-misc/curl
- >=dev-libs/d0_blind_id-0.5
- ode? ( dev-games/ode[double-precision] )
- opengl? (
- ${UIRDEPEND}
- x11-libs/libXext
- x11-libs/libXpm
- x11-libs/libXxf86vm
- alsa? ( media-libs/alsa-lib )
- )
- sdl? (
- ${UIRDEPEND}
- media-libs/libsdl[X,audio,joystick,opengl,video,alsa?]
- )
-"
-DEPEND="${RDEPEND}
- opengl? (
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- x11-proto/xproto
- )
-"
-
-S="${WORKDIR}/${MY_PN}"
-
-CHECKREQS_DISK_BUILD="2100M"
-CHECKREQS_DISK_USR="950M"
-
-pkg_pretend() {
- check-reqs_pkg_pretend
-}
-
-pkg_setup() {
- check-reqs_pkg_setup
- games_pkg_setup
-}
-
-src_prepare() {
- tc-export CC
- # Required for DP_PRELOAD_DEPENDENCIES=1
- append-ldflags $(no-as-needed)
-
- epatch_user
-
- sed -i \
- -e "/^EXE_/s:darkplaces:${PN}:" \
- -e "/^OPTIM_RELEASE=/s:$: ${CFLAGS}:" \
- -e "/^LDFLAGS_RELEASE=/s:$: ${LDFLAGS}:" \
- source/darkplaces/makefile.inc || die
-
- if use !alsa; then
- sed -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
- -i source/darkplaces/makefile || die
- fi
-}
-
-src_compile() {
- local targets=""
- local i
-
- use opengl && targets+=" cl-release"
- use sdl && targets+=" sdl-release"
- use server && targets+=" sv-release"
-
- cd source/darkplaces || die
- for i in ${targets}; do
- emake STRIP=true \
- DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
- DP_PRELOAD_DEPENDENCIES=1 \
- ${i}
- done
-}
-
-src_install() {
- if use opengl; then
- dogamesbin source/darkplaces/${PN}-glx
- make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
- fi
- if use sdl; then
- dogamesbin source/darkplaces/${PN}-sdl
- make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
- fi
- if use opengl || use sdl; then
- newicon misc/logos/icons_png/${PN}_512.png ${PN}.png
- fi
- use server && dogamesbin source/darkplaces/${PN}-dedicated
-
- dodoc Docs/*.txt
- dohtml -r Docs
-
- insinto "${GAMES_DATADIR}/${PN}"
-
- # public key for d0_blind_id
- doins key_0.d0pk
-
- use server && doins -r server
-
- doins -r data
-
- prepgamesdirs
-}
diff --git a/games-fps/xonotic/xonotic-9999.ebuild b/games-fps/xonotic/xonotic-9999.ebuild
index 7f43629..8012eb0 100644
--- a/games-fps/xonotic/xonotic-9999.ebuild
+++ b/games-fps/xonotic/xonotic-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -49,7 +49,7 @@ RDEPEND="
)
sdl? (
${UIRDEPEND}
- !sdl2? ( media-libs/libsdl[X,audio,joystick,opengl,video] )
+ !sdl2? ( media-libs/libsdl[X,joystick,opengl,sound,video] )
sdl2? ( media-libs/libsdl2[X,opengl,video] )
)
"