summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2010-12-16 04:23:41 +0500
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2010-12-16 04:23:41 +0500
commit827c7edb4e24dbe87c84fd1ffb3466876d94ad04 (patch)
tree1cabbbc76cf4b0a96afeaa1538e9707f4b7b3393 /games-puzzle/osmos/osmos-1.6.0.ebuild
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/gamerlay (diff)
downloadgamerlay-827c7edb4e24dbe87c84fd1ffb3466876d94ad04.tar.gz
gamerlay-827c7edb4e24dbe87c84fd1ffb3466876d94ad04.tar.bz2
gamerlay-827c7edb4e24dbe87c84fd1ffb3466876d94ad04.zip
[games-puzzle/osmos]: fixed font rendering
See http://www.hemispheregames.com/forum/viewtopic.php?f=8&t=498&start=0 for more info
Diffstat (limited to 'games-puzzle/osmos/osmos-1.6.0.ebuild')
-rw-r--r--games-puzzle/osmos/osmos-1.6.0.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/games-puzzle/osmos/osmos-1.6.0.ebuild b/games-puzzle/osmos/osmos-1.6.0.ebuild
index 4e1db9f..6461501 100644
--- a/games-puzzle/osmos/osmos-1.6.0.ebuild
+++ b/games-puzzle/osmos/osmos-1.6.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=3
inherit eutils games
@@ -21,12 +21,12 @@ RESTRICT="mirror strip"
PROPERTIES="interactive"
RDEPEND="virtual/opengl
- virtual/glu
- x11-libs/libX11
- media-libs/freetype:2
- sys-libs/glibc
- media-libs/openal
- media-libs/libvorbis"
+ virtual/glu
+ x11-libs/libX11
+ media-libs/freetype:2
+ sys-libs/glibc
+ media-libs/openal
+ media-libs/libvorbis"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_PN}
@@ -40,7 +40,13 @@ src_install() {
exeinto "${dir}"
doexe ${MY_PN} ${MY_PN}.bin{32,64} || die "doexe"
dohtml readme.html
- doins -r Fonts/ Sounds/ Textures/ Osmos-* *.cfg || die "doins failed"
+ doins -r Sounds/ Textures/ Osmos-* *.cfg || die "doins failed"
+
+ # Fix for font error
+ # See http://www.hemispheregames.com/forum/viewtopic.php?f=8&t=498&start=0
+ insinto "${dir}"/Fonts
+ doins "${FILESDIR}"/FortuneCity.ttf
+
newicon Icons/256x256.png ${PN}.png
games_make_wrapper ${PN} ./${MY_PN} "${dir}"