summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 14:45:56 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 14:47:46 +0300
commitda17ef200ad9ee9879c5809a04fefe6f1e8b0e8f (patch)
tree6dbc226d763c94c7cf0cab619ae0059d7e668fe0 /games-puzzle
parentgames-puzzle/puzzlemoppet: add metadata.xml (diff)
downloadgamerlay-da17ef200ad9ee9879c5809a04fefe6f1e8b0e8f.tar.gz
gamerlay-da17ef200ad9ee9879c5809a04fefe6f1e8b0e8f.tar.bz2
gamerlay-da17ef200ad9ee9879c5809a04fefe6f1e8b0e8f.zip
games-puzzle/snapshot: update package
Migrate from deprecated eclass. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/snapshot/metadata.xml11
-rw-r--r--games-puzzle/snapshot/snapshot-28-r1.ebuild (renamed from games-puzzle/snapshot/snapshot-28.ebuild)29
2 files changed, 24 insertions, 16 deletions
diff --git a/games-puzzle/snapshot/metadata.xml b/games-puzzle/snapshot/metadata.xml
new file mode 100644
index 0000000..aec4945
--- /dev/null
+++ b/games-puzzle/snapshot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>mva@mva.name</email>
+<name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/games-puzzle/snapshot/snapshot-28.ebuild b/games-puzzle/snapshot/snapshot-28-r1.ebuild
index 308dfde..11b3391 100644
--- a/games-puzzle/snapshot/snapshot-28.ebuild
+++ b/games-puzzle/snapshot/snapshot-28-r1.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: games-puzzle/kinetris/kinetris-1.0.0b_pre5.ebuild frostwork Exp $
-EAPI="5"
+EAPI=7
MY_PN="${PN/s/S}"
BASE_URI="${MY_PN}-linux-v${PV}"
-inherit multilib games
+inherit desktop eutils
-DESCRIPTION="Join PIC on his awesome journey into the unknown armed with only his camera that can capture the world around him!"
+DESCRIPTION="Join PIC on his awesome journey into the unknown armed with only his camera!"
HOMEPAGE="http://www.retroaffect.com/games/1/snapshot/"
SRC_URI="
x86? ( ${BASE_URI}-x86.tar.gz )
amd64? ( ${BASE_URI}-x64.tar.gz )
"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
SLOT="0"
RESTRICT="fetch"
KEYWORDS="~amd64 ~x86"
@@ -57,15 +56,15 @@ RDEPEND="${DEPEND}
x11-libs/libXfixes
x11-libs/libXtst
x11-libs/libXxf86vm
- || ( dev-lang/luajit:2 =dev-lang/lua-5.1 )
+ || ( dev-lang/luajit:2 dev-lang/lua:0 )
luajit? ( dev-lang/luajit:2 )
- !luajit? ( =dev-lang/lua-5.1* )
+ !luajit? ( dev-lang/lua:0 )
"
S="${WORKDIR}"
src_install() {
local lib=liblua.so;
- GAMEDIR="${GAMES_PREFIX_OPT}/${PN}"
+ dir="/opt/${PN}"
use luajit && lib=libluajit-5.1.so
@@ -78,16 +77,14 @@ src_install() {
# Fixing bundled lua (requires non-standard soname)
ln -s "/usr/$(get_libdir)/${lib}" "./liblua5.1.so.0"
- exeinto "${GAMEDIR}"
- insinto "${GAMEDIR}"
+ exeinto "${dir}"
+ insinto "${dir}"
doins -r "resources"
doins "liblua5.1.so.0"
doexe "${PN}.bin"
doicon "${FILESDIR}/snapshot.png"
- # install shortcuts
- games_make_wrapper "${PN}" "./${PN}.bin" "${GAMEDIR}" "${GAMEDIR}" || die "install shortcut"
- make_desktop_entry "${PN}" "${PN}" "${PN}"
-
- prepgamesdirs
+ # install shortcuts
+ make_wrapper "${PN}" "./${PN}.bin" "${dir}" "${dir}" || die "install shortcut"
+ make_desktop_entry "${PN}" "${PN}" "${PN}"
}