summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-02-05 22:13:34 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-02-05 22:26:09 +0300
commit81b9a02d3ccc4e89e0fa08ce79a053ac409f2473 (patch)
tree291d6343d1ee86bca40bd5963c41b0fe3f77fa23 /games-strategy/wyrmsun/wyrmsun-4.1.3.ebuild
parentgames-engines/wyrmgus: update package (diff)
downloadgamerlay-81b9a02d3ccc4e89e0fa08ce79a053ac409f2473.tar.gz
gamerlay-81b9a02d3ccc4e89e0fa08ce79a053ac409f2473.tar.bz2
gamerlay-81b9a02d3ccc4e89e0fa08ce79a053ac409f2473.zip
games-strategy/wyrmsun: update package
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-strategy/wyrmsun/wyrmsun-4.1.3.ebuild')
-rw-r--r--games-strategy/wyrmsun/wyrmsun-4.1.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-strategy/wyrmsun/wyrmsun-4.1.3.ebuild b/games-strategy/wyrmsun/wyrmsun-4.1.3.ebuild
new file mode 100644
index 0000000..953a348
--- /dev/null
+++ b/games-strategy/wyrmsun/wyrmsun-4.1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Strategy game based on history, mythology and fiction"
+HOMEPAGE="https://andrettin.github.io/"
+SRC_URI="https://github.com/Andrettin/Wyrmsun/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="games-engines/wyrmgus"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Wyrmsun-${PV}"
+
+src_prepare() {
+ cmake_src_prepare
+ sed -i -e 's:share/appdata:share/metainfo:g' CMakeLists.txt
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCSDIR="share/doc/${PF}"
+ )
+ cmake_src_configure
+}
+
+#src_install() {
+# cmake_src_install
+#}