summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2016-09-06 04:22:45 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2016-09-06 04:22:59 +0700
commit48b738bcd413691ceac5acf6b9892123083d3cfa (patch)
treeecc419da515f5c6f8eb61d2ff2d9e78ac633c5c0 /games-util
parentdev-games/aseprite: Bump to 1.17, remove old. (diff)
downloadgamerlay-48b738bcd413691ceac5acf6b9892123083d3cfa.tar.gz
gamerlay-48b738bcd413691ceac5acf6b9892123083d3cfa.tar.bz2
gamerlay-48b738bcd413691ceac5acf6b9892123083d3cfa.zip
fixes
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lgogdownloader/Manifest4
-rw-r--r--games-util/lgogdownloader/lgogdownloader-2.28.ebuild26
-rw-r--r--games-util/lgogdownloader/lgogdownloader-2.6.ebuild29
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild29
4 files changed, 40 insertions, 48 deletions
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
index 85b6d5e..7d8559c 100644
--- a/games-util/lgogdownloader/Manifest
+++ b/games-util/lgogdownloader/Manifest
@@ -1,3 +1 @@
-DIST lgogdownloader-2.6.tar.gz 21041 SHA256 0d955d497f5006db694a4571d570f2f50d9eda78bc166ae3e3ab5746117454ef SHA512 f98ad75e3bb071fec98548398b7580e87ec3bb1940f1d5a390df7da476a80302770509ebb85b51d38411d8055182eb32dd1b377201f12c8fb8030906dabd943c WHIRLPOOL 05006373054c25bc7bdfe83c0d5651742bb9b374e02c4f51edd52af90cb66279ba95471077fba3f7b6e4be15da9748a3b63780cb7bfc5ab63b760eb8a09e8154
-EBUILD lgogdownloader-2.6.ebuild 649 SHA256 48d4c9cc24bdcd6a2c2161388fff650bd1500fe1ade0d064310ef87d948e76f7 SHA512 45739ae211b10982b158944a371435c1057e7de02251652d465b459a7254333243b9acdd45f9de9a6e98e8b5593d9a9a71617aee19c8ff7df910aa286edc7668 WHIRLPOOL 170f27a7a89f0d4b3c278a2f2d43a0b9cd3dfd4be222cbacd24f8194270e057c47bc9f0b9958926cf04a6e045a19e83eb5282032ac3db0b56fc66991d809213f
-EBUILD lgogdownloader-9999.ebuild 637 SHA256 134aabb96fbb11bfbe4d318fa219e252e037a76dd7b8558f06723129b8169e82 SHA512 2d912ffbce368054cc49fe2710838f204c358a515e655ec7410ee33a9754cf0afa03889fca45b35896b07ee5c94f6243cda64ae2787d279c2f3899ee81e7587f WHIRLPOOL e6adc3555238dc732180182209c9c79702269c53009b9692b851ed5edd1943327f19374855635c4953c02773abbc89d4110cd647c7116267fde971bca30babf2
+DIST lgogdownloader-2.28.tar.gz 52469 SHA256 da169dd21bdbd6e693c7da9da708ee0f8d18780a625095d5abb94a0d153fc588 SHA512 6eb52e13ae3926d9e395d067922f40cfab8ab3c0e1a25a8ff09eab8dae9b7d1ec6beb3119c42def7d70cd231199141310d322e31528fe283e04849a2b0cfdeb0 WHIRLPOOL 0dd9c113ef56661dcc5a9c37ff901e834949ff17e4f29d5f314a83cd60b587c42a552d7d6f4b10920ef3e8080c57dc0780b25fa6f9b8952fc882b340e439726b
diff --git a/games-util/lgogdownloader/lgogdownloader-2.28.ebuild b/games-util/lgogdownloader/lgogdownloader-2.28.ebuild
new file mode 100644
index 0000000..0bbca8b
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-2.28.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="Linux compatible gog.com downloader"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://github.com/Sude-/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="WTFPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/jsoncpp
+ net-libs/liboauth
+ net-misc/curl
+ dev-libs/boost
+ dev-libs/tinyxml
+ app-crypt/librhash
+ net-libs/htmlcxx
+"
+DEPEND="${RDEPEND}"
diff --git a/games-util/lgogdownloader/lgogdownloader-2.6.ebuild b/games-util/lgogdownloader/lgogdownloader-2.6.ebuild
deleted file mode 100644
index a6f031a..0000000
--- a/games-util/lgogdownloader/lgogdownloader-2.6.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: lgogdownloader-2.4.ebuild,v 1.0 2013/04/28 10:15:41 by frostwork Exp $
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="Linux compatible gog.com downloader"
-HOMEPAGE="https://sites.google.com/site/gogdownloader/"
-SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
-
-LICENSE="WTFPL"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-libs/jsoncpp
- net-libs/liboauth
- net-misc/curl
- dev-libs/boost
- dev-libs/tinyxml
- app-crypt/librhash
- net-libs/htmlcxx"
-DEPEND="${RDEPEND}"
-
-src_install() {
- dobin bin/Release/${PN}
-}
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
index 4a20f3c..429eed9 100644
--- a/games-util/lgogdownloader/lgogdownloader-9999.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -1,29 +1,26 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: lgogdownloader-9999.ebuild,v 1.0 2013/04/28 15:06:41 by frostwork Exp $
-EAPI="4"
+EAPI="6"
-inherit eutils git-2
+inherit cmake-utils git-r3
DESCRIPTION="Linux compatible gog.com downloader"
HOMEPAGE="https://sites.google.com/site/gogdownloader/"
-EGIT_REPO_URI="git://github.com/Sude-/lgogdownloader.git"
+EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
LICENSE="WTFPL"
SLOT="0"
KEYWORDS=""
IUSE=""
-RDEPEND="dev-libs/jsoncpp
- net-libs/liboauth
- net-misc/curl
- dev-libs/boost
- dev-libs/tinyxml
- app-crypt/librhash
- net-libs/htmlcxx"
+RDEPEND="
+ dev-libs/jsoncpp
+ net-libs/liboauth
+ net-misc/curl
+ dev-libs/boost
+ dev-libs/tinyxml
+ app-crypt/librhash
+ net-libs/htmlcxx
+"
DEPEND="${RDEPEND}"
-
-src_install() {
- dobin bin/Release/${PN}
-}