summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/supertirititran')
-rw-r--r--games-action/supertirititran/Manifest5
-rw-r--r--games-action/supertirititran/files/0.9-gentoopath.diff24
-rw-r--r--games-action/supertirititran/files/supertirititran.pngbin0 -> 5767 bytes
-rw-r--r--games-action/supertirititran/metadata.xml9
-rw-r--r--games-action/supertirititran/supertirititran-0.9.ebuild40
5 files changed, 78 insertions, 0 deletions
diff --git a/games-action/supertirititran/Manifest b/games-action/supertirititran/Manifest
new file mode 100644
index 0000000..30ffc62
--- /dev/null
+++ b/games-action/supertirititran/Manifest
@@ -0,0 +1,5 @@
+AUX 0.9-gentoopath.diff 940 RMD160 585e47da0a8b6b75db74f0bd6249e525ca3106d9 SHA1 062e411bf083e724c99e0229eb47261105790fd7 SHA256 85305b576430a22e80f071db9efe4ddfdba65eb8daf29c464231e2a51204a0b6
+AUX supertirititran.png 5767 RMD160 063d6d5b2357d6d5c1afcbea9dffd3a334471898 SHA1 d431a423ee200f11ad85b7e60b7e8982095c1372 SHA256 be523a9fb217d7c6b57e99e9b3dcb5956bd89cdd9e903d8c542eb097b5e69330
+DIST supertirititran-09-linux-sources.tar.gz 34338560 RMD160 0746474849716286451ac7af1deb2e2b5e7cc7c0 SHA1 86d0cec3aceaba8389ab55bba2c130e0374eec8b SHA256 f76c00390046ef7e797a16b8c9ad0e761277365561be834546121ad887b2fb6c
+EBUILD supertirititran-0.9.ebuild 845 RMD160 102eeb8d8701a75a0ee52939e1d3ede05f93dfe9 SHA1 93e2d5cb81fdf5fd55698c48fd2f2799198ad93b SHA256 d1360492eb8adaa200315fae13d6b9e045693eadc232847f0139de2532a31f16
+MISC metadata.xml 249 RMD160 220cde0fc1a8d7d355705f0f6772bd8d77cdc17a SHA1 34b33eb8d24cd8bfef2ddfb8e80334fd77cc9488 SHA256 3875fd5008d7f5bfe7f3cf7bf330c209a5034f5988d37c1699fb3be35a7be906
diff --git a/games-action/supertirititran/files/0.9-gentoopath.diff b/games-action/supertirititran/files/0.9-gentoopath.diff
new file mode 100644
index 0000000..336ca99
--- /dev/null
+++ b/games-action/supertirititran/files/0.9-gentoopath.diff
@@ -0,0 +1,24 @@
+diff -Naur org/Makefile patch/Makefile
+--- org/Makefile 2006-09-05 14:53:11.000000000 +0200
++++ patch/Makefile 2009-08-20 10:47:22.000000000 +0200
+@@ -27,7 +27,7 @@
+ # OBJETIVOS
+ #---------------------------
+
+-NAME_EXE= tirititran
++NAME_EXE= supertirititran
+ PROGRAMA = $(SRCDIR)/tirititran.cpp
+
+ DEP = SDL_rotozoom.o barra.o cargar.o configuracion.o disparojugador.o disparosenemigos.o elementos.o explosion.o fuente.o intercom.o joystick.o juego.o mapa.o niveles.o opciones.o pantalla.o SDL_Animation.o sonido.o tiempo.o unrarlib.o tirititran.o
+diff -Naur org/src/defines.h patch/src/defines.h
+--- org/src/defines.h 2006-09-17 19:05:07.000000000 +0200
++++ patch/src/defines.h 2009-08-20 10:47:32.000000000 +0200
+@@ -30,7 +30,7 @@
+ #ifndef DEFINES_H_
+ #define DEFINES_H_
+
+-#define DATA_DIR "/usr/share/tirititran/data"
++#define DATA_DIR "/usr/share/games/supertirititran/data"
+
+ #define NOPCIONES 8
+ #define NOPCIONES_OPCIONES 8
diff --git a/games-action/supertirititran/files/supertirititran.png b/games-action/supertirititran/files/supertirititran.png
new file mode 100644
index 0000000..e046f08
--- /dev/null
+++ b/games-action/supertirititran/files/supertirititran.png
Binary files differ
diff --git a/games-action/supertirititran/metadata.xml b/games-action/supertirititran/metadata.xml
new file mode 100644
index 0000000..4e4714e
--- /dev/null
+++ b/games-action/supertirititran/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>frostworks@gmx.de</email>
+ <name>Marcel Unbehaun</name>
+</maintainer>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/supertirititran/supertirititran-0.9.ebuild b/games-action/supertirititran/supertirititran-0.9.ebuild
new file mode 100644
index 0000000..cf7bb0d
--- /dev/null
+++ b/games-action/supertirititran/supertirititran-0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils games
+
+DESCRIPTION="super hero shoot em up"
+HOMEPAGE="http://www.super-tirititran.com"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-09-linux-sources.tar.gz"
+LICENSE="CCPL-Attribution-NonCommercial-NoDerivs-2.0"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ dev-libs/expat"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoopath.diff || die "patch failed"
+}
+
+src_install() {
+ dogamesbin supertirititran
+ dodoc README
+ insinto "${GAMES_DATADIR}"/"${PN}"
+ doins -r data || die
+ newicon "${FILESDIR}"/${PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN}
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}