summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/anomaly-mobilecampaign/anomaly-mobilecampaign-20130613-r1.ebuild')
-rw-r--r--games-strategy/anomaly-mobilecampaign/anomaly-mobilecampaign-20130613-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/games-strategy/anomaly-mobilecampaign/anomaly-mobilecampaign-20130613-r1.ebuild b/games-strategy/anomaly-mobilecampaign/anomaly-mobilecampaign-20130613-r1.ebuild
new file mode 100644
index 0000000..f31afbc
--- /dev/null
+++ b/games-strategy/anomaly-mobilecampaign/anomaly-mobilecampaign-20130613-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils multilib-minimal unpacker
+
+DESCRIPTION="An extraordinary mixture of action and strategy/"
+HOMEPAGE="http://www.anomalythegame.com/"
+# Is it non-HiB distfile?
+SRC_URI="AnomalyMobileCampaign-lin_1371139237-Installer"
+RESTRICT="fetch strip"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ media-libs/openal[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXau[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXdmcp[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+ virtual/opengl
+ app-arch/unzip
+"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+pkg_nofetch() {
+ ewarn
+ ewarn "Put ${A} (downloaded from Humble Store) to ${DISTDIR}, please"
+ ewarn
+}
+
+src_install() {
+ cd "${S}/data"
+ local dir="/opt/${PN}"
+
+ newicon "icon.png" "${PN}.png"
+ make_desktop_entry "${PN}" "Anomaly: Warzone Earth. Mobile Campaign" "${PN}"
+ make_wrapper "${PN}" "./AnomalyMobileCampaign" "${dir}"
+ dodoc README
+ exeinto "${dir}"
+ doexe "AnomalyMobileCampaign"
+ rm "libopenal.so.1" \
+ "icon.png" \
+ "README" \
+ "AnomalyMobileCampaign" \
+ "Copyright license Lua" \
+ "Copyright license OggVorbis" \
+ "Copyright license Theora" \
+ "Copyright license Xpm"
+ insinto "${dir}"
+ doins -r .
+}