summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/recoil/recoil-5.0.0.ebuild')
-rw-r--r--media-gfx/recoil/recoil-5.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/recoil/recoil-5.0.0.ebuild b/media-gfx/recoil/recoil-5.0.0.ebuild
new file mode 100644
index 0000000..25eb746
--- /dev/null
+++ b/media-gfx/recoil/recoil-5.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Retro Computer Image Library"
+HOMEPAGE="http://recoil.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libpng:0="
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" recoil2png
+}
+
+src_install() {
+ dobin recoil2png
+ doman recoil2png.1
+ dodoc README
+}