aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-18 22:03:44 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-18 22:03:44 +0100
commitf696831884a2c0ed929bc70a336f53369ec0ccac (patch)
tree56ebe0d3d1e42138d554aa98326a4835a69a0dae
parent8.2.0: update 105_all_libgfortran-Werror.patch to include configure.ac (diff)
downloadgcc-patches-f696831884a2c0ed929bc70a336f53369ec0ccac.tar.gz
gcc-patches-f696831884a2c0ed929bc70a336f53369ec0ccac.tar.bz2
gcc-patches-f696831884a2c0ed929bc70a336f53369ec0ccac.zip
7.3.0: pull in all -Werror patches from 8.2.0
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--7.3.0/gentoo/102_all_libgfortran-Werror.patch20
-rw-r--r--7.3.0/gentoo/103_all_libgomp-Werror.patch20
-rw-r--r--7.3.0/gentoo/104_all_libitm-Werror.patch19
-rw-r--r--7.3.0/gentoo/105_all_libatomic-Werror.patch19
-rw-r--r--7.3.0/gentoo/106_all_libbacktrace-Werror.patch17
-rw-r--r--7.3.0/gentoo/107_all_libsanitizer-libbacktrace-Werror.patch17
-rw-r--r--7.3.0/gentoo/README.history6
7 files changed, 118 insertions, 0 deletions
diff --git a/7.3.0/gentoo/102_all_libgfortran-Werror.patch b/7.3.0/gentoo/102_all_libgfortran-Werror.patch
new file mode 100644
index 0000000..f6c26bf
--- /dev/null
+++ b/7.3.0/gentoo/102_all_libgfortran-Werror.patch
@@ -0,0 +1,20 @@
+libgfortran does not respect --disable-werror
+
+https://bugs.gentoo.org/433435
+http://gcc.gnu.org/PR54724
+
+
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -140,3 +140,3 @@ AM_PROG_CC_C_O
+ if test "x$GCC" = "xyes"; then
+- AM_FCFLAGS="-I . -Wall -Werror -fimplicit-none -fno-repack-arrays -fno-underscoring"
++ AM_FCFLAGS="-I . -Wall -fimplicit-none -fno-repack-arrays -fno-underscoring"
+ ## We like to use C11 and C99 routines when available. This makes
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -5764,3 +5764,3 @@ fi
+ # Add -Wall -fno-repack-arrays -fno-underscoring if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- AM_FCFLAGS="-I . -Wall -Werror -fimplicit-none -fno-repack-arrays -fno-underscoring"
++ AM_FCFLAGS="-I . -Wall -fimplicit-none -fno-repack-arrays -fno-underscoring"
diff --git a/7.3.0/gentoo/103_all_libgomp-Werror.patch b/7.3.0/gentoo/103_all_libgomp-Werror.patch
new file mode 100644
index 0000000..416808a
--- /dev/null
+++ b/7.3.0/gentoo/103_all_libgomp-Werror.patch
@@ -0,0 +1,20 @@
+libgomp does not respect --disable-werror
+
+https://bugs.gentoo.org/229059
+http://gcc.gnu.org/PR38436
+--- a/libgomp/configure.ac
++++ b/libgomp/configure.ac
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
+--- a/libgomp/configure
++++ b/libgomp/configure
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
diff --git a/7.3.0/gentoo/104_all_libitm-Werror.patch b/7.3.0/gentoo/104_all_libitm-Werror.patch
new file mode 100644
index 0000000..27181e0
--- /dev/null
+++ b/7.3.0/gentoo/104_all_libitm-Werror.patch
@@ -0,0 +1,19 @@
+libitm does not respect --disable-werror
+
+https://bugs.gentoo.org/475350
+--- a/libitm/configure.ac
++++ b/libitm/configure.ac
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
+--- a/libitm/configure
++++ b/libitm/configure
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
diff --git a/7.3.0/gentoo/105_all_libatomic-Werror.patch b/7.3.0/gentoo/105_all_libatomic-Werror.patch
new file mode 100644
index 0000000..0550722
--- /dev/null
+++ b/7.3.0/gentoo/105_all_libatomic-Werror.patch
@@ -0,0 +1,19 @@
+libatomic does not respect --disable-werror
+
+https://bugs.gentoo.org/475350
+--- a/libatomic/configure.ac
++++ b/libatomic/configure.ac
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
+--- a/libatomic/configure
++++ b/libatomic/configure
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
diff --git a/7.3.0/gentoo/106_all_libbacktrace-Werror.patch b/7.3.0/gentoo/106_all_libbacktrace-Werror.patch
new file mode 100644
index 0000000..57dd284
--- /dev/null
+++ b/7.3.0/gentoo/106_all_libbacktrace-Werror.patch
@@ -0,0 +1,17 @@
+libbacktrace does not respect --disable-werror
+
+https://bugs.gentoo.org/667104
+--- a/libbacktrace/configure
++++ b/libbacktrace/configure
+@@ -11634,3 +11634,3 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+ if test -n "${with_target_subdir}"; then
+- WARN_FLAGS="$WARN_FLAGS -Werror"
++ WARN_FLAGS="$WARN_FLAGS"
+ fi
+--- a/libbacktrace/configure.ac
++++ b/libbacktrace/configure.ac
+@@ -138,3 +138,3 @@ ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings -Wstrict-prototypes \
+ if test -n "${with_target_subdir}"; then
+- WARN_FLAGS="$WARN_FLAGS -Werror"
++ WARN_FLAGS="$WARN_FLAGS"
+ fi
diff --git a/7.3.0/gentoo/107_all_libsanitizer-libbacktrace-Werror.patch b/7.3.0/gentoo/107_all_libsanitizer-libbacktrace-Werror.patch
new file mode 100644
index 0000000..46a219a
--- /dev/null
+++ b/7.3.0/gentoo/107_all_libsanitizer-libbacktrace-Werror.patch
@@ -0,0 +1,17 @@
+libsanitizer/libbacktrace does not respect --disable-werror
+
+https://bugs.gentoo.org/667104
+--- a/libsanitizer/libbacktrace/Makefile.am
++++ b/libsanitizer/libbacktrace/Makefile.am
+@@ -37,3 +37,3 @@ AM_CPPFLAGS = -I $(top_srcdir)/../include -I $(top_srcdir)/../libgcc \
+ WARN_FLAGS = -W -Wall -Wwrite-strings -Wmissing-format-attribute \
+- -Wcast-qual -Werror
++ -Wcast-qual
+ C_WARN_FLAGS = $(WARN_FLAGS) -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition
+--- a/libsanitizer/libbacktrace/Makefile.in
++++ b/libsanitizer/libbacktrace/Makefile.in
+@@ -293,3 +293,3 @@ AM_CPPFLAGS = -I $(top_srcdir)/../include -I $(top_srcdir)/../libgcc \
+ WARN_FLAGS = -W -Wall -Wwrite-strings -Wmissing-format-attribute \
+- -Wcast-qual -Werror
++ -Wcast-qual
+
diff --git a/7.3.0/gentoo/README.history b/7.3.0/gentoo/README.history
index 97821a1..1a482bc 100644
--- a/7.3.0/gentoo/README.history
+++ b/7.3.0/gentoo/README.history
@@ -1,5 +1,11 @@
1.8 TODO
+ 101_all_remove-lieee.patch
+ + 102_all_libgfortran-Werror.patch
+ + 103_all_libgomp-Werror.patch
+ + 104_all_libitm-Werror.patch
+ + 105_all_libatomic-Werror.patch
+ + 106_all_libbacktrace-Werror.patch
+ + 107_all_libsanitizer-libbacktrace-Werror.patch
1.7 23 Sep 2018
+ 98_all_msp430-partial-int.patch