summaryrefslogtreecommitdiff
blob: df57acb7573ccd2306f46420975393b02b7fe16e (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
# Azamat H. Hackimov <azamat.hackimov@gmail.com>, 2010.
msgid ""
msgstr ""
"Project-Id-Version: \n"
"POT-Creation-Date: 2010-10-21 23:56+0600\n"
"PO-Revision-Date: 2011-01-25 19:18+0500\n"
"Last-Translator: Azamat H. Hackimov <azamat.hackimov@gmail.com>\n"
"Language-Team: Russian <kde-russian@lists.kde.ru>\n"
"Language: ru\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
"X-Generator: Lokalize 1.0\n"
"X-Poedit-Language: Russian\n"
"X-Poedit-Country: RUSSIAN FEDERATION\n"
"X-Poedit-SourceCharset: utf-8\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(guide:link):6
msgid "/doc/en/gcc-upgrading.xml"
msgstr "/doc/ru/gcc-upgrading.xml"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):7
msgid "Gentoo GCC Upgrade Guide"
msgstr "Руководство Gentoo по обновлению GCC"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(author:title):9
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(author:title):12
msgid "Author"
msgstr "автор"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(mail:link):10
msgid "amne@gentoo.org"
msgstr "amne@gentoo.org"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(mail):10
msgid "Wernfried Haas"
msgstr "Wernfried Haas"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(mail:link):13
msgid "jkt@gentoo.org"
msgstr "jkt@gentoo.org"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(mail):13
msgid "Jan Kundrát"
msgstr "Jan Kundrát"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(author:title):15
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(author:title):18
msgid "Editor"
msgstr "редактор"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(mail:link):16
msgid "halcy0n"
msgstr "halcy0n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(mail:link):19
msgid "nightmorph"
msgstr "nightmorph"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(abstract):22
msgid "This document will guide the user through the process of upgrading GCC."
msgstr "Этот документ поможет пользователю осуществить обновление GCC."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(version):30
msgid "23"
msgstr "23"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(date):31
msgid "2008-07-19"
msgstr "2008-07-19"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):34
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):80
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):167
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):333
msgid "Introduction"
msgstr "Введение"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):36
msgid "GCC Upgrading"
msgstr "Обновление GCC"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):39
msgid "Why should you upgrade? Well, GCC is quite similar to any other package on your system, just a bit more critical. You should upgrade GCC whenever a new version fixes some bug that annoys you, new functionality you need is introduced, or if you want to keep your system up-to-date. If none of the previous cases apply to you, you can safely postpone upgrade as long as your GCC version is supported by Gentoo developers."
msgstr "Зачем нужно обновлять? Ну, GCC схож с любым другим пакетов в вашей системе, только он чуточку важнее. GCC следует обновлять всякий раз, когда в новой версии исправляются какие-нибудь раздражающие вас ошибки, добавляется новые нужные функции, или если вы хотите держать свою систему обновленной. Если ни один из этих случаев к вам не относится, обновление можно спокойно откладывать, пока ваша версия GCC поддерживается разработчиками Gentoo."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):48
msgid "If you install a new major version of GCC (such as 3.3.6 to 3.4.5), the system will not switch over to use it automatically. You'll have to explicitly request the change because the migration process might require some additional steps. If you decide not to switch, Portage will continue to use older version of your compiler until you change your mind, or remove the old compiler from the system. Non-major gcc upgrades are switched automatically for you (such as 3.4.5 to 3.4.6)."
msgstr "Если вы обновляете основную версию GCC (например, с 3.3.6 на 3.4.5), система не переключится на ее использование автоматически. Вам необходимо явно запросить изменение, потому что в процессе перехода может потребоваться несколько дополнительных действий. Если вы решите не переключаться, система Portage будет использовать более старую версию компилятора до тех пор, пока вы не передумаете или пока не удалите старый компилятор из своей системы. Неосновные обновления GCC (например, с 3.4.5 на 3.4.6) переключаются автоматически."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):58
msgid "This guide will document the necessary steps required to perform a seamless upgrade of the compiler used by your Gentoo box. A specific section is dedicated to the <uri link=\"#upgrade-3.3-to-3.4\">upgrade from GCC 3.3 to 3.4</uri> and issues with <c>libstdc++</c>. A second specific section is for users <uri link=\"#first-install\">first installing</uri> Gentoo using a stage3 tarball, after a new GCC major/minor version has been released."
msgstr "В этом руководстве описываются обязательные шаги, необходимые для полноценного обновления компилятора, используемого в вашей системе Gentoo. Отдельный разделпосвящен <uri link=\"#upgrade-3.3-to-3.4\">переходу с GCC 3.3 на 3.4</uri> и проблемам с <c>libstdc++</c>. Другой частный раздел предназначен пользователям, <uri link=\"#first-install\">впервые устанавливающим</uri> Gentoo из архива третьей стадии (stage3) после выхода новой основной/неосновной версии GCC."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(warn):67
msgid "It should be noted that upgrading from GCC-3.4 (or 3.3) to GCC-4.1 or greater still requires you to follow the <uri link=\"#upgrade-general\">general upgrading instructions</uri>, as GCC-3.4 and GCC-4.1 use slightly different ABIs."
msgstr "Необходимо заметить, что обновление с GCC-3.4 (или 3.3) до GCC-4.1 или более нового также требует от вас следованию <uri link=\"#upgrade-general\">общим инструкциям по обновлению</uri>, так как в GCC-3.4 и GCC-4.1 используются слегка отличные друг от друга двоичные прикладные интерфейсы (ABI)."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):78
msgid "General Upgrade Instructions"
msgstr "Общие указания по обновлению"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(impo):83
msgid "If you're looking for instructions specific to upgrades from GCC-3.3 to GCC-3.4, please consult the <uri link=\"#upgrade-3.3-to-3.4\">dedicated section</uri>."
msgstr "Если вам нужны указания по обновлению с GCC-3.3 на GCC-3.4, обратитесь к <uri link=\"#upgrade-3.3-to-3.4\">соответствующему разделу</uri>."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(impo):89
msgid "If you're looking for instructions specific to upgrades in GCC for new installs, please consult the <uri link=\"#first-install\">dedicated section</uri>."
msgstr "Если вам нужны указания по обновлению GCC на вновь установленных системах, обратитесь к <uri link=\"#first-install\">соответствующему разделу</uri>."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):95
msgid "Generally speaking, upgrades to <e>bug fix releases</e>, like from 3.3.5 to 3.3.6, should be quite safe -- just emerge new version, switch your system to use it and rebuild the only affected package, <c>libtool</c>. However, some GCC upgrades break binary compatibility; in such cases a rebuild of the affected packages (or even whole toolchain and system) might be required."
msgstr "Вообще говоря, переход на <e>версии с исправленными ошибками (bugfix release)</e>, как с 3.3.5 на 3.3.6, должен быть довольно безопасен — надо только установить новую версию, переключиться на нее и пересобрать единственный затрагиваемый пакет — <c>libtool</c>. Однако при некоторых обновлениях GCC может нарушаться двоичная совместимость; в таких случаях необходима пересборка всех затрагиваемых пакетов (или даже всего системного набора и пакетов, необходимых для компиляции)."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):103
msgid "When we spoke about the need to switch your compiler to the newer version by hand, we said it won't happen automatically. However, there is one exception -- upgrades to bug fix releases, like from 3.3.5 to 3.3.6 in case you don't use the \"multislot\" feature allowing them to coexist on one system. Multislot is disabled by default as the majority of users won't benefit from it."
msgstr "Говоря о необходимости ручного переключения на новую версию компилятора, мы сказали, что оно не происходит автоматически. Тем не менее, есть одно исключение — переход на версию с исправленными ошибками (например, с 3.3.5 на 3.3.6), если при этом не задействован режим «multislot», позволяющий обеим версиям сосуществовать в одной системе. По умолчанию этот режим выключен, ведь большинству пользователей он ничего не даст."

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):111
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):278
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):366
msgid "Upgrading GCC"
msgstr "Обновление GCC"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):111
#, no-wrap
msgid ""
"\n"
"# <i>emerge -uav gcc</i>\n"
"\n"
"<comment>(Please substitute \"i686-pc-linux-gnu-4.1.1\" with the GCC\n"
"version and CHOST settings you've upgraded to:)</comment>\n"
"# <i>gcc-config i686-pc-linux-gnu-4.1.1</i>\n"
"# <i>env-update &amp;&amp; source /etc/profile</i>\n"
"\n"
"<comment>If you upgraded from gcc 3 to 4 (e.g. from 3.4.6 to 4.1.1 in this\n"
"example) you will have to run fix_libtool_files.sh manually</comment>\n"
"<comment>(Replace $CHOST with your actual CHOST, found in /etc/make.conf)</comment>\n"
"<comment>(Replace &lt;gcc-version&gt; with your new, updated GCC version)</comment>\n"
"# <i>/usr/share/gcc-data/$CHOST/&lt;gcc-version&gt;/fix_libtool_files.sh 3.4.6</i>\n"
"\n"
"<comment>(Rebuilding libtool)</comment>\n"
"# <i>emerge --oneshot -av libtool</i>\n"
msgstr ""
"\n"
"# <i>emerge -uav gcc</i>\n"
"\n"
"<comment>(Вместо \"i686-pc-linux-gnu-4.4.1\" укажите обновленную\n"
" версию GCC и настройки CHOST)</comment>\n"
"# <i>gcc-config i686-pc-linux-gnu-4.1.1</i>\n"
"# <i>env-update &amp;&amp; source /etc/profile</i>\n"
"\n"
"<comment>Если вы обновляетесь с gcc 3 на 4 (например, с 3.4.6 на 4.1.1)\n"
"вам понадобится запустить fix_libtool_files.sh вручную</comment>\n"
"<comment>(Замените $CHOST собственным значением CHOST из /etc/make.conf)</comment>\n"
"<comment>(Замените &lt;gcc-version&gt; новой версией GCC)</comment>\n"
"# <i>/usr/share/gcc-data/$CHOST/&lt;gcc-version&gt;/fix_libtool_files.sh 3.4.6</i>\n"
"\n"
"<comment>(Пересборка libtool)</comment>\n"
"# <i>emerge --oneshot -av libtool</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):129
msgid "To be completely safe that your system is in a sane state, you <e>must</e> rebuild the toolchain and then world to make use of the new compiler."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):134
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):433
msgid "Rebuilding system"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):134
#, no-wrap
msgid ""
"\n"
"# <i>emerge -eav system</i>\n"
"# <i>emerge -eav world</i>\n"
msgstr ""
"\n"
"# <i>emerge -eav system</i>\n"
"# <i>emerge -eav world</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):139
msgid "It is safe to remove the older GCC version at this time. If you feel the need, please issue the following command (as usual, substitute <c>=sys-devel/gcc-3.4*</c> with the version you want to uninstall):"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):145
msgid "Removing older GCC version"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):145
#, no-wrap
msgid ""
"\n"
"# <i>emerge -aC =sys-devel/gcc-3.4*</i>\n"
msgstr ""
"\n"
"# <i>emerge -aC =sys-devel/gcc-3.4*</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(impo):149
msgid "Please note that the GCC 4.1 and newer can compile only kernels newer than 2.4.34. Don't remove your old GCC version if you want to use an older kernel."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(impo):154
msgid "In case you're upgrading from GCC-3.3, you should run <c>emerge --oneshot sys-libs/libstdc++-v3</c> to provide compatibility with older binary C++ applications."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):165
msgid "Upgrading from GCC-3.3 to 3.4"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):170
msgid "The upgrade from GCC-3.3 to 3.4 is not seamless as the C++ ABI changed between these two versions. There is an issue with the <c>libstdc++</c> library which must be taken care of, as well."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):179
msgid "The Choices"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(impo):182
msgid "If you upgrade from gcc 3.4 to 4.1, please consult the <uri link=\"#upgrade-general\">General Update instructions</uri>."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(impo):187
msgid "If you're upgrading on a SPARC machine, you will have to take the way of <uri link=\"#upgrade-3.3-to-3.4-emerge-e\">complete system rebuild</uri> due to some internal <uri link=\"http://gcc.gnu.org/gcc-3.4/sparc-abi.html\">ABI changes</uri> in GCC's parameter passing."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):194
msgid "If you upgrade from gcc 3.3 to 3.4, you have two possibilities on how to upgrade your system. The <uri link=\"#upgrade-3.3-to-3.4-revdep-rebuild\">first method</uri> is faster and requires use of the <c>revdep-rebuild</c> tool from package <c>gentoolkit</c> while the <uri link=\"#upgrade-3.3-to-3.4-emerge-e\">second one</uri> rebuilds the entire system from scratch so it will make use of new GCC features. It's up to you to decide which of these two ways you will choose. In most cases, the first method is sufficient."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):205
msgid "If you upgrade from gcc 3.3 to 4.1, do not use the method based on revdep-rebuild, but do a <uri link=\"#upgrade-3.3-to-3.4-emerge-e\">complete system rebuild</uri>."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):214
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):242
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):390
msgid "Using revdep-rebuild"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):217
msgid "This method requires that you first install <c>gentoolkit</c> if you have not already done so. Then we will upgrade GCC and switch to the new compiler. We will also rebuild the <c>libtool</c> package to ensure that toolchain is in healthy state."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):224
msgid "Installing gentoolkit and upgrading GCC"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):224
#, no-wrap
msgid ""
"\n"
"# <i>emerge -an gentoolkit</i>\n"
"# <i>emerge -uav gcc</i>\n"
"<comment>(Please substitute \"i686-pc-linux-gnu-3.4.5\" with the GCC\n"
"version and CHOST settings you've upgraded to:)</comment>\n"
"# <i>gcc-config i686-pc-linux-gnu-3.4.5</i>\n"
"# <i>source /etc/profile</i>\n"
"\n"
"<comment>(Rebuilding libtool)</comment>\n"
"# <i>emerge --oneshot -av libtool</i>\n"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):236
msgid "Now, we want to see which packages that revdep-rebuild will want to rebuild. Then we will tell revdep-rebuild to actually rebuild the packages. This may take some time, so have some patience."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):242
#, no-wrap
msgid ""
"\n"
"# <i>revdep-rebuild --library libstdc++.so.5 -- -p -v</i>\n"
"# <i>revdep-rebuild --library libstdc++.so.5</i>\n"
msgstr ""
"\n"
"# <i>revdep-rebuild --library libstdc++.so.5 -- -p -v</i>\n"
"# <i>revdep-rebuild --library libstdc++.so.5</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(note):247
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(note):405
msgid "It is possible that you might have problems with non-existing package versions due to them being outdated or masked. If this is the case, you will want to use the <c>--package-names</c> option to <c>revdep-rebuild</c>. This causes packages to be recompiled based on the package name, rather than the exact name and version."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):255
msgid "To provide compatibility with older binary C++ applications and any packages that revdep-rebuild might have missed, <c>sys-libs/libstdc++-v3</c> needs to be merged before you unmerge GCC 3.3 from your system."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):261
msgid "Installing libstdc++-v3 and cleaning up"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):261
#, no-wrap
msgid ""
"\n"
"# <i>emerge --oneshot sys-libs/libstdc++-v3</i>\n"
"# <i>emerge -aC =sys-devel/gcc-3.3*</i>\n"
msgstr ""
"\n"
"# <i>emerge --oneshot sys-libs/libstdc++-v3</i>\n"
"# <i>emerge -aC =sys-devel/gcc-3.3*</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):269
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):416
msgid "Using emerge -e"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):272
msgid "This method, while much slower, will rebuild your whole system to ensure that everything has been rebuilt with your new compiler, and therefore safer. At first, you will upgrade GCC and libtool and switch to your new compiler."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):278
#, no-wrap
msgid ""
"\n"
"# <i>emerge -uav gcc</i>\n"
"<comment>(Please substitute \"i686-pc-linux-gnu-3.4.5\" with the GCC\n"
"version and CHOST settings you've upgraded to:)</comment>\n"
"# <i>gcc-config i686-pc-linux-gnu-3.4.5</i>\n"
"# <i>source /etc/profile</i>\n"
"\n"
"<comment>If you upgraded from gcc 3 to 4 (e.g. from 3.3.6 to 4.1.1 in this\n"
"example) you will have to run fix_libtool_files.sh manually</comment>\n"
"<comment>(Replace $CHOST with your actual CHOST, found in /etc/make.conf)</comment>\n"
"<comment>(Replace &lt;gcc-version&gt; with your new, updated GCC version)</comment>\n"
"# <i>/usr/share/gcc-data/$CHOST/&lt;gcc-version&gt;/fix_libtool_files.sh 3.3.6</i>\n"
"\n"
"<comment>(Rebuilding libtool)</comment>\n"
"# <i>emerge --oneshot -av libtool</i>\n"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):295
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):377
msgid "To provide compatibility with older binary C++ applications, <c>sys-libs/libstdc++-v3</c> needs to be merged onto your system."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):300
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):382
msgid "Installing libstdc++-v3"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):300
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):382
#, no-wrap
msgid ""
"\n"
"# <i>emerge --oneshot sys-libs/libstdc++-v3</i>\n"
msgstr ""
"\n"
"# <i>emerge --oneshot sys-libs/libstdc++-v3</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):304
msgid "Now we will go about first rebuilding the system target, then the world target. This will take a very long time, depending on the number of packages that you have installed, as it will rebuild your entire toolchain and supporting system files, followed by every package on your system, including the toolchain. This is necessary to ensure that all packages have been compiled with the new toolchain, including the toolchain itself."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):313
msgid "Rebuilding system and world"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):313
#, no-wrap
msgid ""
"\n"
"# <i>emerge -e system</i>\n"
"# <i>emerge -e world</i>\n"
msgstr ""
"\n"
"# <i>emerge -e system</i>\n"
"# <i>emerge -e world</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):318
msgid "It is also safe to remove older GCC versions at this time:"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):322
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):440
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):448
msgid "Cleaning up"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):322
#, no-wrap
msgid ""
"\n"
"# <i>emerge -aC =sys-devel/gcc-3.3*</i>\n"
msgstr ""
"\n"
"# <i>emerge -aC =sys-devel/gcc-3.3*</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):331
msgid "Upgrading to GCC on a First Install"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):336
msgid "A GCC upgrade on a system after installation from a stage3 tarball is a simple affair. One advantage users of new installations have is they do not have a plethora of software installed that links against the older version of GCC. The following example is for a GCC-3.3 to 3.4 upgrade. Certain parts will be different if upgrading from other versions of GCC. For example, the library names used for <c>revdep-rebuild</c> below are GCC 3.3 specific, as well as the need to install <c>libstdc++-v3</c>."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):346
msgid "If a user has not made any customizations to their system yet, then there are very few steps to get their system upgraded to a new GCC version. As with the GCC-3.3 to 3.4 upgrade, the user has a couple options. However, unlike the GCC-3.3 to 3.4 upgrade, this one is less complicated as there are fewer differences between the methods. The <uri link=\"#first-install-revdep-rebuild\">first method</uri> is faster and makes use of the <c>revdep-rebuild</c> tool from <c>gentoolkit</c>, similar to the above procedure. Using revdep-rebuild causes only packages which actually link against GCC libraries to be rebuilt, while the <uri link=\"#first-install-emerge-e\">second method</uri> causes your entire new install to be recompiled with the new GCC version and takes much longer. This second method is never required and only documented for completeness."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):361
msgid "These first steps are common between both methods, and should be completed by everyone."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):366
#, no-wrap
msgid ""
"\n"
"# <i>emerge -uav gcc</i>\n"
"<comment>(Please substitute \"i686-pc-linux-gnu-3.4.5\" with the GCC\n"
"version and CHOST settings you've upgraded to:)</comment>\n"
"# <i>gcc-config i686-pc-linux-gnu-3.4.5</i>\n"
"# <i>source /etc/profile</i>\n"
"\n"
"<comment>(Rebuilding libtool)</comment>\n"
"# <i>emerge --oneshot -av libtool</i>\n"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):393
msgid "This method requires that you first install <c>gentoolkit</c> if you have not already done so. We will then run <c>revdep-rebuild</c> to actually scan the installed packages for ones we need to rebuild, then rebuild them."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):399
msgid "Installing gentoolkit and running revdep-rebuild"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):399
#, no-wrap
msgid ""
"\n"
"# <i>emerge -an gentoolkit</i>\n"
"# <i>revdep-rebuild --library libstdc++.so.5 -- -p -v</i>\n"
"# <i>revdep-rebuild --library libstdc++.so.5</i>\n"
msgstr ""
"\n"
"# <i>emerge -an gentoolkit</i>\n"
"# <i>revdep-rebuild --library libstdc++.so.5 -- -p -v</i>\n"
"# <i>revdep-rebuild --library libstdc++.so.5</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):419
msgid "This method, while much slower, will rebuild the system target to ensure that everything has been rebuilt with your new compiler. This is not necessary, but is valid if you are also making changes to CFLAGS or other make.conf variables that will affect the system compile."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):426
msgid "Since we are performing these actions after an initial installation, we do not need to recompile the <c>world</c> target as we would when doing an upgrade on an already installed system. However, you may choose to perform a world update in place of the system update, to ensure that all packages are updated."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):433
#, no-wrap
msgid ""
"\n"
"# <i>emerge -e system</i>\n"
msgstr ""
"\n"
"# <i>emerge -e system</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):443
msgid "It is also safe to remove older GCC versions at this time. Please substitute <c>YOUR-NEW-GCC-VERSION</c> with the actual version you've upgraded to:"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):448
#, fuzzy, no-wrap
msgid ""
"\n"
"# <i>emerge -aC \"&lt;sys-devel/gcc-YOUR-NEW-GCC-VERSION\"</i>\n"
msgstr ""
"\n"
"# <i>emerge -aC \"&lt;sys-devel/gcc-YOUR-NEW-GCC-VERSION\"</i>\n"

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):457
msgid "Common Pitfalls"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):461
msgid "It's important to disable <c>distcc</c> during upgrade. Mixing compiler versions on your nodes <e>will</e> cause build issues. This is not required for ccache, as the cache objects will be invalidated anyway."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):467
msgid "Always use same GCC version for your kernel and additional kernel modules. Once you rebuild your world with new GCC, external modules (like <c>app-emulation/qemu-softmmu</c>) will fail to load. Please rebuild your kernel with the new GCC to fix that."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):474
msgid "If you're upgrading on a SPARC machine, make sure to rerun <c>silo -f</c> after re-emerging world to avoid possible issues."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(title):482
msgid "Frequent Error Messages"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):485
msgid "If your system complains about something like <e>libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la' is not a valid libtool archive</e>, please run <c>/usr/share/gcc-data/$CHOST/&lt;gcc-version&gt;/fix_libtool_files.sh 3.3.6</c> (substitute \"3.3.6\" with the version numbers from the error message, and $CHOST and &lt;gcc-version&gt; with your actual CHOST and GCC version)."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):494
msgid "If you see <e>error: /usr/bin/gcc-config: line 632: /etc/env.d/gcc/i686-pc-linux-gnu-3.3.5: No such file or directory</e>, then try deleting <path>/etc/env.d/gcc/config-i686-pc-linux-gnu</path> and running <c>gcc-config</c> again, followed by <c>source /etc/profile</c>. Only do this if you do not have any cross-compilers set up, though."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):502
msgid "If a package fails during <c>emerge -e system</c> or <c>emerge -e world</c>, you can resume operation with <c>emerge --resume</c>. If a package fails repeatedly, skip it with <c>emerge --resume --skipfirst</c>. Don't run any other instances of emerge in between or you will lose the resume information."
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(p):509
msgid "If you get an error message <e>spec failure: unrecognized spec option</e> while upgrading your compiler, try to switch back to your default compiler, unset the <c>GCC_SPECS</c> variable and upgrade GCC again:"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre:caption):515
msgid "Restoring primary specs"
msgstr ""

#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(pre):515
#, no-wrap
msgid ""
"\n"
"# <i>gcc-config 1</i>\n"
"# <i>source /etc/profile</i>\n"
"# <i>unset GCC_SPECS</i>\n"
"# <i>emerge -uav gcc</i>\n"
msgstr ""
"\n"
"# <i>gcc-config 1</i>\n"
"# <i>source /etc/profile</i>\n"
"# <i>unset GCC_SPECS</i>\n"
"# <i>emerge -uav gcc</i>\n"

#. Place here names of translator, one per line. Format should be NAME; ROLE; E-MAIL
#: ../../gentoo/xml/htdocs/doc/en//gcc-upgrading.xml(None):0
msgid "translator-credits"
msgstr ""