summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 09:42:34 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 09:42:34 -0400
commit66faa4ab6ebd13b2b1a5e04a248dfb80b4e45fca (patch)
tree5b02a5690612cba139f75d98adfedf76230089b7
parentmate-base/mate-session-manager: Bump to 1.24.3 (diff)
downloadgentoo-mate-66faa4ab6ebd13b2b1a5e04a248dfb80b4e45fca.tar.gz
gentoo-mate-66faa4ab6ebd13b2b1a5e04a248dfb80b4e45fca.tar.bz2
gentoo-mate-66faa4ab6ebd13b2b1a5e04a248dfb80b4e45fca.zip
mate-base/mate-panel: Bump to 1.24.2
Bug: https://bugs.gentoo.org/778857 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.24.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index fc108d1..99c7f37 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1 +1,2 @@
DIST mate-panel-1.24.1.tar.xz 3265000 BLAKE2B eb5d2c8b6668ecb1d072e80ac4062574c97b7d52a1473133efff0fb12eca4e765df016d8ede4c6745f7bd9e6ea64114ccfcdf87045ca00797e63ab9ec215435c SHA512 1a1e62207d58472daa00d409ef2b04944929af7f9fe05592076adcc069e2d70012424b3386d30f8b9adccf05c328b8ab1662b8726e507465881a4ae26c26829f
+DIST mate-panel-1.24.2.tar.xz 3271432 BLAKE2B ca866ae2ba743d5871f75ba8840f05b556d77bcfb9263542f5e945310ebbaccdb211a266c3235ab706c70209740cd4a8a9f390363ddf18fc305ffd875723974d SHA512 6dd7b1329fc51389ad6213b5490fd44f8db7b76d17c1fa8f24b197390e9f24d4090fc7c439b7cc9c94be76f6b896ac31e69e920e903c067e297f941c844a1280
diff --git a/mate-base/mate-panel/mate-panel-1.24.2.ebuild b/mate-base/mate-panel/mate-panel-1.24.2.ebuild
new file mode 100644
index 0000000..c715fb2
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.24.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +introspection wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/librsvg-2.36.2:2
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.21.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1.0.0[X?]
+ >=x11-libs/gdk-pixbuf-2.25.2:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}