summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 10:21:44 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 10:21:44 -0400
commit8d8e6b164dd12031f162241aeac4d9b564186f4c (patch)
tree4178cad8ff144e5d46a74bd6d911348c3d0d8464
parentmate-extra/mate-power-manager: Bump to 1.24.2 (diff)
downloadgentoo-mate-8d8e6b164dd12031f162241aeac4d9b564186f4c.tar.gz
gentoo-mate-8d8e6b164dd12031f162241aeac4d9b564186f4c.tar.bz2
gentoo-mate-8d8e6b164dd12031f162241aeac4d9b564186f4c.zip
mate-extra/mate-system-monitor: Update 9999
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-9999.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-9999.ebuild
index a489ee3..1c7ebff 100644
--- a/mate-extra/mate-system-monitor/mate-system-monitor-9999.ebuild
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit mate
+inherit mate toolchain-funcs
if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
@@ -51,9 +51,10 @@ src_configure() {
if use elogind || use systemd; then
myconf+=( --enable-systemd )
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
- SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags 'libelogind')"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs 'libelogind')"
)
fi
else