aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 23:27:06 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 23:27:06 +0100
commitcf5f268f8b19262515105739bdcc112cd2a6cdbc (patch)
treea1bd1060e9034c95d9a7b38b65323ab4dcf3d517
parentMakefile: remove the old tagging logic (diff)
downloadgentoo-syntax-cf5f268f8b19262515105739bdcc112cd2a6cdbc.tar.gz
gentoo-syntax-cf5f268f8b19262515105739bdcc112cd2a6cdbc.tar.bz2
gentoo-syntax-cf5f268f8b19262515105739bdcc112cd2a6cdbc.zip
Makefile: add a new "tag" target
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 91ed461..04bfcdb 100644
--- a/Makefile
+++ b/Makefile
@@ -28,6 +28,9 @@ install-dir-%:
install-file-%: $(subst _,/,$*)
cp "$(subst _,/,$*)" "$(PREFIX)/$(subst _,/,$*)"
+tag:
+ git tag -s v$$(( $$(git tag -l --sort=-creatordate | sed -n -e 's:^v::p') + 1 ))
+
uninstall : uninstall-files
uninstall-files: $(foreach a, $(sort $(files)), \