summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-11 13:42:46 +0200
committerMichał Górny <mgorny@gentoo.org>2013-09-11 13:43:15 +0200
commit57aef87f446c9517a82375350ac2e7a4dc52777e (patch)
tree1c3b61a29af3806fab33108752e10de7e8c2977a
parentRequire systemdsystem{unit,generator}dir. Drop stale unitdir. (diff)
downloadgentoo-systemd-integration-57aef87f446c9517a82375350ac2e7a4dc52777e.tar.gz
gentoo-systemd-integration-57aef87f446c9517a82375350ac2e7a4dc52777e.tar.bz2
gentoo-systemd-integration-57aef87f446c9517a82375350ac2e7a4dc52777e.zip
Enable var-*.mount units in sysinit.target.
-rw-r--r--Makefile.am8
-rw-r--r--configure.ac1
2 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5099c6d..778f8f8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,14 @@ dist_systemdsystemunit_DATA = \
dist_systemdsystemgenerator_SCRIPTS = \
system-generators/gentoo-local-generator
+install-data-hook: \
+ systemd-system-unit-install-hook
+
+systemd-system-unit-install-hook:
+ mkdir -p $(DESTDIR)$(systemdsystemunitdir)/sysinit.target.wants
+ $(LN_S) ../var-lock.mount ../var-run.mount \
+ $(DESTDIR)$(systemdsystemunitdir)/sysinit.target.wants/
+
DISTCLEANFILES = \
$(systemdsystemunit_DATA)
diff --git a/configure.ac b/configure.ac
index 0e03a5e..df0a38d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,7 @@ AC_INIT([gentoo-systemd-integration], [0])
AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE([1.6 foreign dist-bzip2 subdir-objects])
+AC_PROG_LN_S
AC_PROG_SED
# https://bitbucket.org/mgorny/systemd-m4/