aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2020-01-07 22:42:27 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2020-01-07 22:42:27 +0100
commitfa6d9c14cc7cf4f8f0eecefce8b120f9cc2629c6 (patch)
tree9e28e9e5c87214e8dcaa30ec001790acfca0e22b
parentproj/gentoo-vdr-scripts: Bumped to version 2.8 (diff)
downloadgentoo-vdr-scripts-fa6d9c14cc7cf4f8f0eecefce8b120f9cc2629c6.tar.gz
gentoo-vdr-scripts-fa6d9c14cc7cf4f8f0eecefce8b120f9cc2629c6.tar.bz2
gentoo-vdr-scripts-fa6d9c14cc7cf4f8f0eecefce8b120f9cc2629c6.zip
gentoo-vdr-scripts.git: removed acpi wakeup support
removed acpi wakeup support, this was announced in earlier g-v-s versions, taken changes from https://github.com/lucianm/gentoo-vdr-scripts Suggested-by: Lucian Muresan <lucianm@users.sourceforge.net> Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
-rw-r--r--ChangeLog3
-rw-r--r--README.shutdown3
-rw-r--r--etc/conf.d/vdr.shutdown6
-rw-r--r--usr/sbin/Makefile2
-rwxr-xr-xusr/sbin/acpi-wakeup.sh81
-rwxr-xr-xusr/sbin/rtc-wakeup.sh2
-rw-r--r--usr/share/vdr/rcscript/pre-start-50-shutdown.sh9
-rw-r--r--usr/share/vdr/shutdown/Makefile2
-rw-r--r--usr/share/vdr/shutdown/wakeup-acpi.sh19
9 files changed, 7 insertions, 120 deletions
diff --git a/ChangeLog b/ChangeLog
index 1537112..2a056be 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
# ChangeLog for gentoo-vdr-scripts
+ -removed rtc-wakeup, anounced in privius version
+ Suggested-by: Lucian Muresan <lucianm@users.sourceforge.net>
+
*gentoo-vdr-scripts-2.8 (15 Dec 2019)
diff --git a/README.shutdown b/README.shutdown
index d237424..36ddc47 100644
--- a/README.shutdown
+++ b/README.shutdown
@@ -8,11 +8,10 @@ Almost all code related to shutdown is stored under
= wakeup-modules:
=================
-
Wakeup-modules are named wakeup-${NAME}.sh
The used wakeup-module is selected by WAKEUP_METHOD in /etc/conf.d/vdr.shutdown.
-Here acpi is used by default if nothing has been set.
+Here rtc and nvram is tried by default if nothing has been set.
The module is sourced by the shell. The wakeup-module is executed as user root.
diff --git a/etc/conf.d/vdr.shutdown b/etc/conf.d/vdr.shutdown
index f79d13f..cce1c5c 100644
--- a/etc/conf.d/vdr.shutdown
+++ b/etc/conf.d/vdr.shutdown
@@ -21,12 +21,6 @@
# allowed values: rtc nvram none
# default: try all values
#
-# allowed value: acpi
-# acpi wakup is deprecated since kernel > 2.6.38
-# if you would like use it,
-# you have to set this explicit below
-# Note: support will removed in future versions of gentoo-vdr-scripts
-#
#WAKEUP_METHOD=""
###########################################################
diff --git a/usr/sbin/Makefile b/usr/sbin/Makefile
index f718a61..f4cd664 100644
--- a/usr/sbin/Makefile
+++ b/usr/sbin/Makefile
@@ -4,7 +4,7 @@ SHELL = /bin/bash
MYDIR = $(DESTDIR)/usr/sbin
SUBDIRS =
-BINS = acpi-wakeup.sh rtc-wakeup.sh vdr-watchdogd dvb-reload-modules vdr-get-header-checksum
+BINS = rtc-wakeup.sh vdr-watchdogd dvb-reload-modules vdr-get-header-checksum
CONFS =
all: compile
diff --git a/usr/sbin/acpi-wakeup.sh b/usr/sbin/acpi-wakeup.sh
deleted file mode 100755
index a840053..0000000
--- a/usr/sbin/acpi-wakeup.sh
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/sh
-# $Id$
-
-##
-# based on vdrshutdown-acpi.pl
-# by Thomas Koch <tom@linvdr.org>
-##
-
-# Author:
-# Matthias Schwarzott <zzam at gmx dot de>
-#
-# Parameter:
-# $1 : Time to be up and running as unix-timestamp
-#
-
-PROC_ALARM="/proc/acpi/alarm"
-
-die() {
- echo "ERROR: $@" 1>&2
- exit 1
-}
-
-checkUTC() {
- unset clock
- unset CLOCK
- local f
- for f in /etc/conf.d/hwclock /etc/conf.d/clock /etc/rc.conf; do
- if [ -f "${f}" ]; then
- . "${f}"
- break
- fi
- done
- clock="${clock:-${CLOCK}}"
-
- [ "${clock}" = "UTC" ]
-}
-
-writeAlarm() {
- # write 2 times (some bioses need this)
- echo "$1" > "${PROC_ALARM}"
- echo "$1" > "${PROC_ALARM}"
-}
-
-
-# main part starts here
-
-if [ ! -w "${PROC_ALARM}" ]; then
- die "Can not access ${PROC_ALARM}."
-fi
-
-test $# -ge 1 || die "Wrong Parameter Count"
-# time the system should be up
-Next="${1}"
-
-# write time to RTC now, as it may disable wakeup if done after writing alarm time
-if [ -x /etc/init.d/hwclock ]; then
- /etc/init.d/hwclock --quiet save
-else
- /etc/init.d/clock --quiet save
-fi
-
-if [ "${Next}" -eq 0 ]; then
- # This hopefully deactivates wakeup
- writeAlarm "2003-10-20 99:00:00"
- exit 0
-fi
-
-# abort if recording less then 10min in future
-now=$(date +%s)
-[ "${Next}" -lt "$(($now+600))" ] && die "wakeup time too near, alarm not set"
-
-# boot 5min (=300s) before recording
-timestamp=$(($Next-300))
-checkUTC && dateparam="-u"
-
-timestr=$(date ${dateparam} --date="1970-01-01 UTC ${timestamp} seconds" +"%Y-%m-%d %H:%M:00")
-[ -z "${timestr}" ] && die "date did not return a string"
-
-writeAlarm "${timestr}"
-
-exit 0
diff --git a/usr/sbin/rtc-wakeup.sh b/usr/sbin/rtc-wakeup.sh
index 2978a38..f2f0d24 100755
--- a/usr/sbin/rtc-wakeup.sh
+++ b/usr/sbin/rtc-wakeup.sh
@@ -21,7 +21,7 @@ die() {
}
if [ ! -w "${RTC_ALARM}" ]; then
- die "Can not access acpi-rtc-clock."
+ die "Can not access rtc-clock."
fi
test $# -ge 1 || die "Wrong Parameter Count"
diff --git a/usr/share/vdr/rcscript/pre-start-50-shutdown.sh b/usr/share/vdr/rcscript/pre-start-50-shutdown.sh
index a151a06..29c1dee 100644
--- a/usr/share/vdr/rcscript/pre-start-50-shutdown.sh
+++ b/usr/share/vdr/rcscript/pre-start-50-shutdown.sh
@@ -12,14 +12,5 @@ addon_main() {
# no custum shutdown-script
add_param "--shutdown=/usr/share/vdr/bin/vdrshutdown-gate.sh"
- # warning about depricated acpi wakeup kernel > 2.6.38
- if [ "${WAKEUP_METHOD}" = acpi ]; then
- ewarn "use of acpi wakeup method is deprecated"
- einfo "use rtc or nvram instead"
- logger -t vdr "WARNING:"
- logger -t vdr "use of acpi wakeup method is deprecated"
- logger -t vdr "use rtc or nvram instead"
- fi
-
return 0
}
diff --git a/usr/share/vdr/shutdown/Makefile b/usr/share/vdr/shutdown/Makefile
index 3b8a703..c2e4d4e 100644
--- a/usr/share/vdr/shutdown/Makefile
+++ b/usr/share/vdr/shutdown/Makefile
@@ -5,7 +5,7 @@ SHELL = /bin/bash
MYDIR = $(DESTDIR)/usr/share/vdr/shutdown
SUBDIRS =
BINS =
-WAKEUP = wakeup-acpi.sh wakeup-rtc.sh wakeup-nvram.sh wakeup-none.sh
+WAKEUP = wakeup-rtc.sh wakeup-nvram.sh wakeup-none.sh
CONFS = $(wildcard shutdown*.sh pre*.sh periodic*.sh) $(WAKEUP)
all:
diff --git a/usr/share/vdr/shutdown/wakeup-acpi.sh b/usr/share/vdr/shutdown/wakeup-acpi.sh
deleted file mode 100644
index 6a00ed7..0000000
--- a/usr/share/vdr/shutdown/wakeup-acpi.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-# $Id$
-# Author:
-# Matthias Schwarzott <zzam@gmx.de>
-# Various other contributors from gentoo.de
-#
-
-ACPI_WAKEUP=/usr/sbin/acpi-wakeup.sh
-
-if [ ! -x "${ACPI_WAKEUP}" ]; then
- mesg "acpi-wakeup.sh not found"
- return 1
-fi
-
-if [ ! -e /proc/acpi/alarm ]; then
- mesg "/proc/acpi/alarm does not exist"
- return 1
-fi
-
-"${ACPI_WAKEUP}" "${VDR_WAKEUP_TIME}"