summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-pda/gtkpod/Manifest1
-rw-r--r--app-pda/gtkpod/gtkpod-9999.ebuild43
-rw-r--r--media-libs/libgpod/Manifest1
-rw-r--r--media-libs/libgpod/libgpod-9999.ebuild45
4 files changed, 90 insertions, 0 deletions
diff --git a/app-pda/gtkpod/Manifest b/app-pda/gtkpod/Manifest
new file mode 100644
index 0000000..204f1f7
--- /dev/null
+++ b/app-pda/gtkpod/Manifest
@@ -0,0 +1 @@
+EBUILD gtkpod-9999.ebuild 1028 RMD160 97f10408798d04c81f6b0701885f4c7a501f4d59 SHA1 d1611cfc7390ed97c3f5e396987cf16a26b8ea54 SHA256 56bd0ef091d1aaa9c388544d319e7120d44e185a2706651244fc5c484fc6320f
diff --git a/app-pda/gtkpod/gtkpod-9999.ebuild b/app-pda/gtkpod/gtkpod-9999.ebuild
new file mode 100644
index 0000000..17fde13
--- /dev/null
+++ b/app-pda/gtkpod/gtkpod-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit gnome2-live
+
+DESCRIPTION="GUI for iPod using GTK2"
+HOMEPAGE="http://gtkpod.sourceforge.net/"
+
+EGIT_REPO_URI="git://gtkpod.git.sourceforge.net/gitroot/gtkpod/${PN}"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="aac flac mp3 nls ogg"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ >=media-libs/libid3tag-0.15
+ >=gnome-base/libglade-2.4
+ >=gnome-base/libgnomecanvas-2.14
+ >=media-libs/libgpod-0.7
+ >=net-misc/curl-7.10
+ >=dev-libs/glib-2.16.0
+ mp3? ( media-sound/lame )
+ aac? ( media-libs/libmp4v2 )
+ ogg? ( media-libs/libvorbis
+ media-sound/vorbis-tools )
+ flac? ( media-libs/flac )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ nls? ( >=dev-util/intltool-0.33
+ sys-devel/gettext )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable nls)
+ $(use_with ogg)
+ $(use_with flac)"
+ DOCS="AUTHORS ChangeLog NEWS README TROUBLESHOOTING TODOandBUGS.txt itunesdb_info.txt"
+}
diff --git a/media-libs/libgpod/Manifest b/media-libs/libgpod/Manifest
new file mode 100644
index 0000000..fd3bcca
--- /dev/null
+++ b/media-libs/libgpod/Manifest
@@ -0,0 +1 @@
+EBUILD libgpod-9999.ebuild 1078 RMD160 f84dc3e97f8e591e6bbe11591a892365cacf30cb SHA1 4ead248fe354c8c0765af01a3dfe1196a704849c SHA256 f7b58db50e043db0417132cd64bcd4580e4acd3a76aa2f85d558fd73b45ca28a
diff --git a/media-libs/libgpod/libgpod-9999.ebuild b/media-libs/libgpod/libgpod-9999.ebuild
new file mode 100644
index 0000000..080af90
--- /dev/null
+++ b/media-libs/libgpod/libgpod-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit gnome2-live
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod/"
+
+EGIT_REPO_URI="git://gtkpod.git.sourceforge.net/gitroot/gtkpod/${PN}"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk python +udev iphone"
+
+RDEPEND=">=dev-libs/glib-2.16
+ sys-apps/sg3_utils
+ dev-libs/libxml2
+ >=app-pda/libplist-1.0
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ python? ( >=dev-lang/python-2.3
+ >=media-libs/mutagen-1.8
+ >=dev-python/pygobject-2.8 )
+ udev? ( sys-fs/udev )"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.24 )
+ iphone? ( app-pda/libimobiledevice )
+ dev-util/pkgconfig
+ dev-libs/libxslt"
+
+pkg_setup() {
+ # XXX: Add mono support
+ G2CONF="${G2CONF}
+ --without-hal
+ --without-mono
+ $(use_enable udev)
+ $(use_enable gtk gdk-pixbuf)
+ $(use_enable python pygobject)
+ $(use_with python)
+ $(use_with iphone libimobiledevice)"
+ DOCS="README TROUBLESHOOTING AUTHORS NEWS README.SysInfo"
+}