summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gmail.com>2011-08-20 17:32:29 -0400
committerAlexandre Rostovtsev <tetromino@gmail.com>2011-08-20 22:55:26 -0400
commit2a0d08c529c97dfb2c74fde41e8c4a7b6877b532 (patch)
tree83b4b95461dd18a3ae12958bb1fa8bac14ddebb0
parentapp-accessibility/at-spi2-atk: 2.1.4 → 2.1.5 (diff)
downloadgnome-2a0d08c529c97dfb2c74fde41e8c4a7b6877b532.tar.gz
gnome-2a0d08c529c97dfb2c74fde41e8c4a7b6877b532.tar.bz2
gnome-2a0d08c529c97dfb2c74fde41e8c4a7b6877b532.zip
games-board/aisleriot: new package
In gnome-3.1.x, aisleriot was split off from gnome-games into a separate package.
-rw-r--r--games-board/aisleriot/Manifest3
-rw-r--r--games-board/aisleriot/aisleriot-3.1.1.ebuild83
-rw-r--r--games-board/aisleriot/files/aisleriot-3.1.1-help-directory.patch28
3 files changed, 114 insertions, 0 deletions
diff --git a/games-board/aisleriot/Manifest b/games-board/aisleriot/Manifest
new file mode 100644
index 00000000..6a666eda
--- /dev/null
+++ b/games-board/aisleriot/Manifest
@@ -0,0 +1,3 @@
+AUX aisleriot-3.1.1-help-directory.patch 878 RMD160 76307aa8229e13d2318c7677506075d37c8b5b02 SHA1 6832fd320e434a2ae40c87477563a8e2c49c98fa SHA256 a7115ff6c7cd8eeb884f902c7cf68e6b5fe4da66bf909b2f63987be176ef169c
+DIST aisleriot-3.1.1.tar.xz 4349688 RMD160 66849ea07baafa77e6feb80279ed3586ff08d959 SHA1 e9a436e4c5b70985ca09808773dbb0d6c6674c2f SHA256 a0d66e5fb8956d10822946767c64baee975900a381391dcb5186800c94e60a8a
+EBUILD aisleriot-3.1.1.ebuild 2217 RMD160 ae98b01ef5d0981b073d2fc9086c0e8f6a03e1bc SHA1 ff263d5e457dbf373e32a2d4a77a439a9cbdb5dd SHA256 ef482cd15ca94ebf660c9ef4086c80642061d96413acf41426482401edf58c03
diff --git a/games-board/aisleriot/aisleriot-3.1.1.ebuild b/games-board/aisleriot/aisleriot-3.1.1.ebuild
new file mode 100644
index 00000000..476e6b1c
--- /dev/null
+++ b/games-board/aisleriot/aisleriot-3.1.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+GNOME_TARBALL_SUFFIX="xz"
+
+# make sure games is inherited first so that the gnome2
+# functions will be called if they are not overridden
+inherit eutils games gnome2
+
+DESCRIPTION="A collection of solitaire card games for GNOME"
+HOMEPAGE="http://live.gnome.org/Aisleriot"
+
+LICENSE="GPL-3 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="artworkextra gnome sound"
+
+# FIXME: quartz support?
+COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
+ >=dev-scheme/guile-1.8.0:12[deprecated,regex]
+ >=gnome-base/librsvg-2.32.0
+ >=x11-libs/cairo-1.10.0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.0.0:3
+ x11-libs/libICE
+ x11-libs/libSM
+ gnome? ( >=gnome-base/gconf-2.0:2 )
+ sound? ( >=media-libs/libcanberra-0.26[gtk3] )"
+# aisleriot was split off from gnome-games
+RDEPEND="${COMMON_DEPEND}
+ artworkextra? ( >=gnome-extra/gnome-games-extra-data-3.0.0 )
+ !!<gnome-extra/gnome-games-3.1.1[aisleriot]"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/gnome-doc-utils-0.10
+ >=dev-util/intltool-0.40.4
+ >=dev-util/pkgconfig-0.15
+ sys-apps/lsb-release
+ >=sys-devel/gettext-0.12"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog TODO"
+
+ if use gnome; then
+ G2CONF="${G2CONF} --with-platform=gnome --with-help-method=ghelp"
+ else
+ G2CONF="${G2CONF} --with-platform=gtk-only --with-help-method=library"
+ fi
+
+ if use artworkextra; then
+ G2CONF="${G2CONF} --with-card-theme-formats=all
+ --with-kde-card-theme-path=${EPREFIX}usr/share/apps/carddecks
+ --with-pysol-card-theme-path=${EPREFIX}${GAMES_DATADIR}/pysolfc"
+ else
+ G2CONF="${G2CONF} --with-card-theme-formats=default"
+ fi
+
+ # Disable clutter per upstream recommendation in configure.ac
+ G2CONF="${G2CONF}
+ --with-gtk=3.0
+ --without-clutter
+ --with-smclient
+ --with-guile=1.8
+ $(use_enable sound)
+ --disable-schemas-compile
+ --disable-maintainer-mode"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=656967
+ epatch "${FILESDIR}/${P}-help-directory.patch"
+}
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use artworkextra; then
+ elog "Aisleriot can use additional card themes from games-board/pysolfc"
+ elog "and kde-base/libkdegames."
+ fi
+}
diff --git a/games-board/aisleriot/files/aisleriot-3.1.1-help-directory.patch b/games-board/aisleriot/files/aisleriot-3.1.1-help-directory.patch
new file mode 100644
index 00000000..e77871bd
--- /dev/null
+++ b/games-board/aisleriot/files/aisleriot-3.1.1-help-directory.patch
@@ -0,0 +1,28 @@
+From 8c5e36910e958444565cee177427059a0c37e3d3 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gmail.com>
+Date: Sat, 20 Aug 2011 13:38:55 -0400
+Subject: [PATCH] s/AR_RUNTIME_GAME_HELP_DIRECTORY/AR_RUNTIME_HELP_DIRECTORY/
+
+Use the correct name for the help directory.
+
+Addresses https://bugzilla.gnome.org/show_bug.cgi?id=656967
+---
+ src/lib/ar-help.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/lib/ar-help.c b/src/lib/ar-help.c
+index 3be709e..deb53e1 100644
+--- a/src/lib/ar-help.c
++++ b/src/lib/ar-help.c
+@@ -72,7 +72,7 @@ ar_help_display_full (GtkWidget *window,
+ guint i;
+
+ langs = g_get_language_names ();
+- help_dir = ar_runtime_get_directory (AR_RUNTIME_GAME_HELP_DIRECTORY);
++ help_dir = ar_runtime_get_directory (AR_RUNTIME_HELP_DIRECTORY);
+
+ help_uri = NULL;
+ for (i = 0; langs[i] != NULL; ++i) {
+--
+1.7.6
+