aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-06 08:24:47 (GMT)
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-06 08:38:10 (GMT)
commit3a4a482651f7d7d9e5a00efba702074c492d273f (patch)
tree13d886e98a35ff0fff284ac195e480618bb7545d
parentnet-im/empathy: 3.4.0.1 → 3.4.0.2 (diff)
downloadgnome-3a4a4826.zip
gnome-3a4a4826.tar.gz
gnome-3a4a4826.tar.bz2
gnome-base/gnome-settings-daemon: 3.3.92 → 3.4.0
Now with systemd and wacom support.
-rw-r--r--gnome-base/gnome-settings-daemon/Manifest8
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.0-optional-color-wacom.patch (renamed from gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.3.92-optional-color-wacom.patch)12
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.0.ebuild (renamed from gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.3.92.ebuild)23
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild23
4 files changed, 34 insertions, 32 deletions
diff --git a/gnome-base/gnome-settings-daemon/Manifest b/gnome-base/gnome-settings-daemon/Manifest
index 278358d..4ac510e 100644
--- a/gnome-base/gnome-settings-daemon/Manifest
+++ b/gnome-base/gnome-settings-daemon/Manifest
@@ -1,5 +1,5 @@
AUX gnome-settings-daemon-3.0.2-short-touchpad-timeout.patch 519 RMD160 a1f9801351d469aed5f626787c1ce1917468fda7 SHA1 4100b4d7c0e4f3fd85afe3eb4b0fc4e258e7edea SHA256 94c82c7f1b213af232bd1a401ddcaef1578dc7cc70ce3258e73887e438532133
-AUX gnome-settings-daemon-3.3.92-optional-color-wacom.patch 4463 RMD160 479d3dc32f5bb648d3b4486be01b2dacefb1e372 SHA1 79d9c9abd181c7386d487a40a8caba1ee382951c SHA256 9a6dbe2a2abbd2fae6e399cd842e6cc5bbf52351ddc665d74c1a6cfcef8dfda2
-DIST gnome-settings-daemon-3.3.92.tar.xz 1464080 RMD160 20228968fdf50c2adbde13448a929801aa6e1fa1 SHA1 4b315e934ff7439b92bb9ee9e28ac0ae0d1721cd SHA256 419d177a2c381b51fee775987973f7434a21a4f0fd9a0b1253c2d80e318e9a3f
-EBUILD gnome-settings-daemon-3.3.92.ebuild 3581 RMD160 97b21879e5ed3720e8fb3b83c07256ddf6e9a9a9 SHA1 0d876478250c4a20131d06aa59c43658be994f83 SHA256 215c4918c67d81d173067de70c72fc4ed07ad6cd438635552b5a1e068369407e
-EBUILD gnome-settings-daemon-9999.ebuild 3581 RMD160 97b21879e5ed3720e8fb3b83c07256ddf6e9a9a9 SHA1 0d876478250c4a20131d06aa59c43658be994f83 SHA256 215c4918c67d81d173067de70c72fc4ed07ad6cd438635552b5a1e068369407e
+AUX gnome-settings-daemon-3.4.0-optional-color-wacom.patch 4459 RMD160 2ff464bd02efffa4932d851dd8c73b5932667506 SHA1 d42be52c90d56d751b1991f8c2e7c565c2f0d750 SHA256 90ca17376761f81f81faf714d89642599dc779050ac1de71927063d2447396fd
+DIST gnome-settings-daemon-3.4.0.tar.xz 1470012 RMD160 e4f3aefbe557b062d0173858396261bed9ac7667 SHA1 55e5f229f6a90a11a05711fc72c0b998232d204c SHA256 5639cbba28caa7b3e33990f49aeed11ed9325e78e76af2175d9ccd5ff298401d
+EBUILD gnome-settings-daemon-3.4.0.ebuild 3640 RMD160 a37d7cc2b8879a8be89e3982400ad2efdb6db756 SHA1 2482becdfa80f41e93d73181ddf469e7bba8b7d8 SHA256 dc7ac4cf99bd41db6d43710188364d49014e22ec90e2dcbc4bd791a898654a81
+EBUILD gnome-settings-daemon-9999.ebuild 3640 RMD160 a37d7cc2b8879a8be89e3982400ad2efdb6db756 SHA1 2482becdfa80f41e93d73181ddf469e7bba8b7d8 SHA256 dc7ac4cf99bd41db6d43710188364d49014e22ec90e2dcbc4bd791a898654a81
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.3.92-optional-color-wacom.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.0-optional-color-wacom.patch
index 6af221d..045b4d6 100644
--- a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.3.92-optional-color-wacom.patch
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.0-optional-color-wacom.patch
@@ -12,14 +12,14 @@ diff -Naur gnome-settings-daemon-3.3.92//configure.ac gnome-settings-daemon-3.3.
+ [with_color=$enableval],
+ [with_color=yes]) dnl Default value
+
-+if test x$WANT_COLOR = xyes; then
++if test x$with_color = xyes; then
+ PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
-+ AC_DEFINE(HAVE_WACOM, 1, [Define if wacom plugin is enabled])
++ AC_DEFINE(HAVE_COLOR, 1, [Define if wacom plugin is enabled])
+fi
-+AM_CONDITIONAL(WITH_COLOR, test "x$with_color" = "xtrue")
++AM_CONDITIONAL(WITH_COLOR, test "x$with_color" = "xyes")
+
-+AC_SUBST(COLORD_CFLAGS)
-+AC_SUBST(COLORD_LIBS)
++AC_SUBST(COLOR_CFLAGS)
++AC_SUBST(COLOR_LIBS)
dnl ---------------------------------------------------------------------------
dnl - wacom
@@ -36,7 +36,7 @@ diff -Naur gnome-settings-daemon-3.3.92//configure.ac gnome-settings-daemon-3.3.
+ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst $GUDEV_PKG gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
+ AC_DEFINE(HAVE_WACOM, 1, [Define if wacom plugin is enabled])
+fi
-+AM_CONDITIONAL(WITH_WACOM, test "x$with_wacom" = "xtrue")
++AM_CONDITIONAL(WITH_WACOM, test "x$with_wacom" = "xyes")
+
+AC_SUBST(WACOM_CFLAGS)
+AC_SUBST(WACOM_LIBS)
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.3.92.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.0.ebuild
index f7bbc6a..1a3a652 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.3.92.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.0.ebuild
@@ -21,8 +21,7 @@ if [[ ${PV} = 9999 ]]; then
else
KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
fi
-IUSE="+colord +cups debug packagekit policykit +short-touchpad-timeout smartcard
-+udev" #wacom
+IUSE="+colord +cups debug packagekit policykit +short-touchpad-timeout smartcard systemd +udev wacom"
# colord-0.1.13 needed to avoid polkit errors in CreateProfile and CreateDevice
COMMON_DEPEND="
@@ -57,9 +56,10 @@ COMMON_DEPEND="
smartcard? (
sys-fs/udev[gudev]
>=dev-libs/nss-3.11.2 )
- udev? ( sys-fs/udev[gudev] )"
-# Needs libwacom
-# wacom? ( x11-drivers/xf86-input-wacom )"
+ systemd? ( >=sys-apps/systemd-31 )
+ udev? ( sys-fs/udev[gudev] )
+ wacom? ( >=dev-libs/libwacom-0.3
+ x11-drivers/xf86-input-wacom )"
# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
@@ -70,7 +70,9 @@ RDEPEND="${COMMON_DEPEND}
>=x11-themes/gnome-icon-theme-symbolic-2.91
!<gnome-base/gnome-control-center-2.22
!<gnome-extra/gnome-color-manager-3.1.1
- !<gnome-extra/gnome-power-manager-3.1.3"
+ !<gnome-extra/gnome-power-manager-3.1.3
+
+ !systemd? ( sys-auth/consolekit )"
# xproto-7.0.15 needed for power plugin
DEPEND="${COMMON_DEPEND}
cups? ( sys-apps/sed )
@@ -89,16 +91,15 @@ pkg_setup() {
G2CONF="${G2CONF}
--disable-static
--disable-schemas-compile
- --disable-systemd
$(use_enable colord color)
$(use_enable cups)
$(use_enable debug)
$(use_enable debug more-warnings)
$(use_enable packagekit)
$(use_enable smartcard smartcard-support)
- $(use_enable udev gudev)"
- # TODO: libwacom is needem
- #$(use_enable wacom)
+ $(use_enable systemd)
+ $(use_enable udev gudev)
+ $(use_enable wacom)"
}
src_prepare() {
@@ -110,7 +111,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-3.0.2-short-touchpad-timeout.patch"
# Make colord and wacom optional; requires eautoreconf
- epatch "${FILESDIR}/${PN}-3.3.92-optional-color-wacom.patch"
+ epatch "${FILESDIR}/${PN}-3.4.0-optional-color-wacom.patch"
eautoreconf
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild
index f7bbc6a..1a3a652 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild
@@ -21,8 +21,7 @@ if [[ ${PV} = 9999 ]]; then
else
KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
fi
-IUSE="+colord +cups debug packagekit policykit +short-touchpad-timeout smartcard
-+udev" #wacom
+IUSE="+colord +cups debug packagekit policykit +short-touchpad-timeout smartcard systemd +udev wacom"
# colord-0.1.13 needed to avoid polkit errors in CreateProfile and CreateDevice
COMMON_DEPEND="
@@ -57,9 +56,10 @@ COMMON_DEPEND="
smartcard? (
sys-fs/udev[gudev]
>=dev-libs/nss-3.11.2 )
- udev? ( sys-fs/udev[gudev] )"
-# Needs libwacom
-# wacom? ( x11-drivers/xf86-input-wacom )"
+ systemd? ( >=sys-apps/systemd-31 )
+ udev? ( sys-fs/udev[gudev] )
+ wacom? ( >=dev-libs/libwacom-0.3
+ x11-drivers/xf86-input-wacom )"
# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
@@ -70,7 +70,9 @@ RDEPEND="${COMMON_DEPEND}
>=x11-themes/gnome-icon-theme-symbolic-2.91
!<gnome-base/gnome-control-center-2.22
!<gnome-extra/gnome-color-manager-3.1.1
- !<gnome-extra/gnome-power-manager-3.1.3"
+ !<gnome-extra/gnome-power-manager-3.1.3
+
+ !systemd? ( sys-auth/consolekit )"
# xproto-7.0.15 needed for power plugin
DEPEND="${COMMON_DEPEND}
cups? ( sys-apps/sed )
@@ -89,16 +91,15 @@ pkg_setup() {
G2CONF="${G2CONF}
--disable-static
--disable-schemas-compile
- --disable-systemd
$(use_enable colord color)
$(use_enable cups)
$(use_enable debug)
$(use_enable debug more-warnings)
$(use_enable packagekit)
$(use_enable smartcard smartcard-support)
- $(use_enable udev gudev)"
- # TODO: libwacom is needem
- #$(use_enable wacom)
+ $(use_enable systemd)
+ $(use_enable udev gudev)
+ $(use_enable wacom)"
}
src_prepare() {
@@ -110,7 +111,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-3.0.2-short-touchpad-timeout.patch"
# Make colord and wacom optional; requires eautoreconf
- epatch "${FILESDIR}/${PN}-3.3.92-optional-color-wacom.patch"
+ epatch "${FILESDIR}/${PN}-3.4.0-optional-color-wacom.patch"
eautoreconf