summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-12-22 23:54:57 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2013-12-22 23:54:57 +0100
commit4f50b292fbc672d29655051f62358ff66e2b6eca (patch)
tree2a4315ea299c3426d4fe6fe806c7cc15bc5c19d9
parentsys-libs/libosinfo: fix repoman warnings (diff)
downloadgnome-4f50b292fbc672d29655051f62358ff66e2b6eca.tar.gz
gnome-4f50b292fbc672d29655051f62358ff66e2b6eca.tar.bz2
gnome-4f50b292fbc672d29655051f62358ff66e2b6eca.zip
x11-libs/colord-gtk: sync with gentoo-x86
-rw-r--r--x11-libs/colord-gtk/colord-gtk-9999.ebuild43
-rw-r--r--x11-libs/colord-gtk/files/colord-gtk-0.1.22-automagic-vala.patch38
-rw-r--r--x11-libs/colord-gtk/metadata.xml8
3 files changed, 31 insertions, 58 deletions
diff --git a/x11-libs/colord-gtk/colord-gtk-9999.ebuild b/x11-libs/colord-gtk/colord-gtk-9999.ebuild
index 519a3fd1..ff62a06f 100644
--- a/x11-libs/colord-gtk/colord-gtk-9999.ebuild
+++ b/x11-libs/colord-gtk/colord-gtk-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/colord-gtk/colord-gtk-0.1.22.ebuild,v 1.1 2012/08/10 19:03:00 tetromino Exp $
+# $Header: $
-EAPI="4"
+EAPI="5"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
-inherit autotools eutils
+inherit eutils vala
if [[ ${PV} = 9999 ]]; then
GCONF_DEBUG="no"
inherit gnome2-live # need all the hacks from gnome2-live_src_prepare
@@ -18,26 +20,29 @@ else
SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
fi
-LICENSE="LGPL-3"
-SLOT="0"
+LICENSE="LGPL-3+"
+SLOT="0/1" # subslot = libcolord-gtk soname version
+IUSE="doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
fi
-IUSE="doc +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-COMMON_DEPEND=">=dev-libs/glib-2.28:2
- >=media-libs/lcms-2.2:2
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28:2
+ >=media-libs/lcms-2.2:2=
x11-libs/gdk-pixbuf:2[introspection?]
x11-libs/gtk+:3[X(+),introspection?]
- x11-misc/colord[introspection?,vala?]
+ x11-misc/colord:=[introspection?,vala?]
introspection? ( >=dev-libs/gobject-introspection-0.9.8 )"
# ${PN} was part of x11-misc/colord until 0.1.22
RDEPEND="${COMMON_DEPEND}
- !<x11-misc/colord-0.1.22"
+ !<x11-misc/colord-0.1.27
+"
DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
dev-libs/libxslt
>=dev-util/intltool-0.35
>=sys-devel/gettext-0.17
@@ -46,14 +51,13 @@ DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.1.2
>=dev-util/gtk-doc-1.9
)
- vala? ( dev-lang/vala:0.14[vapigen] )"
+ vala? ( $(vala_depend) )
+"
src_prepare() {
- epatch "${FILESDIR}/${PN}-0.1.22-automagic-vala.patch"
+ use vala && vala_src_prepare
if [[ ${PV} = 9999 ]]; then
gnome2_src_prepare
- else
- eautoreconf
fi
}
@@ -62,11 +66,10 @@ src_configure() {
--disable-static \
$(use_enable doc gtk-doc) \
$(use_enable introspection) \
- $(use_enable vala) \
- VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable vala)
}
src_install() {
default
- prune_libtool_files
+ prune_libtool_files --modules
}
diff --git a/x11-libs/colord-gtk/files/colord-gtk-0.1.22-automagic-vala.patch b/x11-libs/colord-gtk/files/colord-gtk-0.1.22-automagic-vala.patch
deleted file mode 100644
index 5e7519fc..00000000
--- a/x11-libs/colord-gtk/files/colord-gtk-0.1.22-automagic-vala.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 09cfb7f14f3766c80137a00586579dd2280ffe65 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Fri, 10 Aug 2012 14:34:03 -0400
-Subject: [PATCH] Make vala bindings non-automagic
-
----
- configure.ac | 8 ++++++--
- 1 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index b51b7d2..e174c4b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -134,7 +134,9 @@ PKG_CHECK_MODULES(LCMS, lcms2 >= 2.2)
- dnl ---------------------------------------------------------------------------
- dnl - Build VALA support
- dnl ---------------------------------------------------------------------------
--if test x$found_introspection != xno; then
-+AC_ARG_ENABLE(vala, AS_HELP_STRING([--enable-vala],[build vala bindings]),
-+ enable_vala=$enableval,enable_vala=no)
-+if test x$found_introspection != xno -a x$enable_vala != xno; then
- AC_PATH_PROG([VAPIGEN], [vapigen], [])
- if test "x$VAPIGEN" = "x"; then
- has_vapigen="no"
-@@ -144,7 +146,9 @@ if test x$found_introspection != xno; then
- fi
- else
- has_vapigen="no"
-- AC_MSG_WARN([Not introspection found, will not build Vala binding])
-+ if test x$found_introspection = xno; then
-+ AC_MSG_WARN([introspection not found, will not build Vala binding])
-+ fi
- fi
- AM_CONDITIONAL(HAVE_VAPIGEN, [test "x$has_vapigen" = "xyes"])
-
---
-1.7.8.6
-
diff --git a/x11-libs/colord-gtk/metadata.xml b/x11-libs/colord-gtk/metadata.xml
new file mode 100644
index 00000000..67201d3a
--- /dev/null
+++ b/x11-libs/colord-gtk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="vala">Generate bindings for <pkg>dev-lang/vala</pkg></flag>
+ </use>
+</pkgmetadata>