summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-01-17 20:06:47 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-01-17 20:06:47 +0530
commit159e5326e85425d9c2533d98bf53e9b8054fbefc (patch)
treece7c2fc7256faaf873e9d9f58597c821ece9433f /app-arch
parentgnome-base/gnome-keyring: prefix ssl cert directory with ROOT (diff)
downloadgnome-159e5326e85425d9c2533d98bf53e9b8054fbefc.tar.gz
gnome-159e5326e85425d9c2533d98bf53e9b8054fbefc.tar.bz2
gnome-159e5326e85425d9c2533d98bf53e9b8054fbefc.zip
Add app-arch/file-roller-2.91.5, and a live version
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/Manifest4
-rw-r--r--app-arch/file-roller/file-roller-2.91.5.ebuild86
-rw-r--r--app-arch/file-roller/file-roller-9999.ebuild86
-rw-r--r--app-arch/file-roller/files/file-roller-2.10.3-use_bin_tar.patch12
4 files changed, 188 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
new file mode 100644
index 00000000..4195dc7e
--- /dev/null
+++ b/app-arch/file-roller/Manifest
@@ -0,0 +1,4 @@
+AUX file-roller-2.10.3-use_bin_tar.patch 504 RMD160 0af7af1c83953554e58c3a2f82ae3edb2e6b7e55 SHA1 a40077b5ace4be970dae46b44aa5b8ce19a75780 SHA256 c22e742893800c4302df40af66b1eabeab700fea7326eada849f919bdd76c052
+DIST file-roller-2.91.5.tar.bz2 1931078 RMD160 fb89e20db32c8cefe234aff8d10fa788c5b64120 SHA1 0ab64af1345ea3f981ab59a2fc8c82606155135d SHA256 0b2c0f8bc5e09f28b41bff15c6015bd21a24bc3610890f622185645538cb6b28
+EBUILD file-roller-2.91.5.ebuild 2328 RMD160 89f7f04630d67642a6652260e94f136bfecf437f SHA1 7ef031841f50d073276a2c6697774c4955482356 SHA256 6a931df0e231edde46815c377fef3107158680c52687d7c25b5828779c420f1e
+EBUILD file-roller-9999.ebuild 2328 RMD160 89f7f04630d67642a6652260e94f136bfecf437f SHA1 7ef031841f50d073276a2c6697774c4955482356 SHA256 6a931df0e231edde46815c377fef3107158680c52687d7c25b5828779c420f1e
diff --git a/app-arch/file-roller/file-roller-2.91.5.ebuild b/app-arch/file-roller/file-roller-2.91.5.ebuild
new file mode 100644
index 00000000..90365b9d
--- /dev/null
+++ b/app-arch/file-roller/file-roller-2.91.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.32.1.ebuild,v 1.2 2010/12/07 19:37:09 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nautilus"
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND=">=dev-libs/glib-2.25.5
+ >=x11-libs/gtk+-2.91.1:3
+ nautilus? ( >=gnome-base/nautilus-2.22.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ dev-util/pkgconfig
+ app-text/gnome-doc-utils"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+pkg_setup() {
+ # TODO: PackageKit support
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --disable-scrollkeeper
+ --disable-run-in-place
+ --disable-static
+ --disable-packagekit
+ --disable-deprecations
+ --disable-schemas-compile
+ $(use_enable nautilus nautilus-actions)"
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+}
+
+src_install() {
+ gnome2_src_install
+ if use nautilus; then
+ find "${ED}"usr/$(get_libdir)/nautilus -name "*.la" -delete \
+ || die "la file removal failed"
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "${PN} is a frontend for several archiving utilities. If you want a"
+ elog "particular achive format support, see ${HOMEPAGE}"
+ elog "and install the relevant package."
+ elog
+ elog "for example:"
+ elog " 7-zip - app-arch/p7zip"
+ elog " ace - app-arch/unace"
+ elog " arj - app-arch/arj"
+ elog " cpio - app-arch/cpio"
+ elog " deb - app-arch/dpkg"
+ elog " iso - app-cdr/cdrtools"
+ elog " jar,zip - app-arch/zip and app-arch/unzip"
+ elog " lha - app-arch/lha"
+ elog " lzma - app-arch/xz-utils"
+ elog " lzop - app-arch/lzop"
+ elog " rar - app-arch/unrar"
+ elog " rpm - app-arch/rpm"
+ elog " unstuff - app-arch/stuffit"
+ elog " zoo - app-arch/zoo"
+}
diff --git a/app-arch/file-roller/file-roller-9999.ebuild b/app-arch/file-roller/file-roller-9999.ebuild
new file mode 100644
index 00000000..90365b9d
--- /dev/null
+++ b/app-arch/file-roller/file-roller-9999.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.32.1.ebuild,v 1.2 2010/12/07 19:37:09 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nautilus"
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND=">=dev-libs/glib-2.25.5
+ >=x11-libs/gtk+-2.91.1:3
+ nautilus? ( >=gnome-base/nautilus-2.22.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ dev-util/pkgconfig
+ app-text/gnome-doc-utils"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+pkg_setup() {
+ # TODO: PackageKit support
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --disable-scrollkeeper
+ --disable-run-in-place
+ --disable-static
+ --disable-packagekit
+ --disable-deprecations
+ --disable-schemas-compile
+ $(use_enable nautilus nautilus-actions)"
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+}
+
+src_install() {
+ gnome2_src_install
+ if use nautilus; then
+ find "${ED}"usr/$(get_libdir)/nautilus -name "*.la" -delete \
+ || die "la file removal failed"
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "${PN} is a frontend for several archiving utilities. If you want a"
+ elog "particular achive format support, see ${HOMEPAGE}"
+ elog "and install the relevant package."
+ elog
+ elog "for example:"
+ elog " 7-zip - app-arch/p7zip"
+ elog " ace - app-arch/unace"
+ elog " arj - app-arch/arj"
+ elog " cpio - app-arch/cpio"
+ elog " deb - app-arch/dpkg"
+ elog " iso - app-cdr/cdrtools"
+ elog " jar,zip - app-arch/zip and app-arch/unzip"
+ elog " lha - app-arch/lha"
+ elog " lzma - app-arch/xz-utils"
+ elog " lzop - app-arch/lzop"
+ elog " rar - app-arch/unrar"
+ elog " rpm - app-arch/rpm"
+ elog " unstuff - app-arch/stuffit"
+ elog " zoo - app-arch/zoo"
+}
diff --git a/app-arch/file-roller/files/file-roller-2.10.3-use_bin_tar.patch b/app-arch/file-roller/files/file-roller-2.10.3-use_bin_tar.patch
new file mode 100644
index 00000000..edaa16c1
--- /dev/null
+++ b/app-arch/file-roller/files/file-roller-2.10.3-use_bin_tar.patch
@@ -0,0 +1,12 @@
+diff -uNr file-roller-2.10.3/src/fr-command-tar.c file-roller-2.10.3.patched/src/fr-command-tar.c
+--- file-roller-2.10.3/src/fr-command-tar.c 2005-04-22 18:39:22.000000000 +0200
++++ file-roller-2.10.3.patched/src/fr-command-tar.c 2005-06-06 14:29:45.000000000 +0200
+@@ -225,7 +225,7 @@
+ if (command != NULL)
+ fr_process_begin_command (comm->process, command);
+ else
+- fr_process_begin_command (comm->process, "tar");
++ fr_process_begin_command (comm->process, "/bin/tar");
+ g_free (command);
+ }
+