summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Piechotka <uzytkownik2@gmail.com>2010-03-07 22:49:09 +0000
committerMaciej Piechotka <uzytkownik2@gmail.com>2010-03-29 10:46:13 +0100
commit1f615373f434f9e9df7b2d74555ae7c6c3803971 (patch)
treef9949ecb3947eeb0c7480567f8e5ab838ff5894b /app-crypt/seahorse
parentx11-themes/gtk-engines: version 2.19.0 bump (diff)
downloadgnome-1f615373f434f9e9df7b2d74555ae7c6c3803971.tar.gz
gnome-1f615373f434f9e9df7b2d74555ae7c6c3803971.tar.bz2
gnome-1f615373f434f9e9df7b2d74555ae7c6c3803971.zip
app-crypt/seahorse: version 2.29.91 bump
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/Manifest3
-rw-r--r--app-crypt/seahorse/files/seahorse-2.28.0-as-needed.patch16
-rw-r--r--app-crypt/seahorse/seahorse-2.29.91.ebuild82
3 files changed, 101 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
new file mode 100644
index 00000000..75f99299
--- /dev/null
+++ b/app-crypt/seahorse/Manifest
@@ -0,0 +1,3 @@
+AUX seahorse-2.28.0-as-needed.patch 381 RMD160 2756cc4440f36b2a206b07710f5bc9b60037a564 SHA1 390204f347f89b3c0dcebbe8cb1f154090b22aa4 SHA256 243d49dd613a19d569e8fa5560d4f4d1618c9c067b00588cd61ccf6dc7516d3c
+DIST seahorse-2.29.91.tar.bz2 2405285 RMD160 d7b902f89f5b8013039c4275fce87c887da1fd42 SHA1 de918d10c0af5a091cfe4e96c7ac5454e3a58355 SHA256 057cfb128f7676078546b596178c8e814621910f7acb9266e103c63a81ff8252
+EBUILD seahorse-2.29.91.ebuild 2068 RMD160 3b836ede04eb457d2982f34ad5c0f2e5d205ac72 SHA1 e37d02997187c9620687f81d4601169d1f66ed4b SHA256 422d7227b3f088eb4d0a932db0c4b8ace69065f78f8f485769a4f5aeb1c1e33d
diff --git a/app-crypt/seahorse/files/seahorse-2.28.0-as-needed.patch b/app-crypt/seahorse/files/seahorse-2.28.0-as-needed.patch
new file mode 100644
index 00000000..1ffef527
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-2.28.0-as-needed.patch
@@ -0,0 +1,16 @@
+Fix linking libgcryptui.so with -Wl,--as-needed in LDFLAGS. Missing DBUS_CFLAGS
+in INCLUDES.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=596691
+
+---
+--- libcryptui/Makefile.am
++++ libcryptui/Makefile.am
+@@ -70,6 +70,7 @@
+
+ INCLUDES = -I$(top_builddir) \
+ -I$(top_srcdir) \
++ $(DBUS_CFLAGS) \
+ $(LIBCRYPTUI_CFLAGS) \
+ -DLIBCRYPTUI_BUILD=1 \
+ -DLIBCRYPTUI_API_SUBJECT_TO_CHANGE
diff --git a/app-crypt/seahorse/seahorse-2.29.91.ebuild b/app-crypt/seahorse/seahorse-2.29.91.ebuild
new file mode 100644
index 00000000..b8c31a97
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-2.29.91.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.28.1.ebuild,v 1.2 2009/10/29 21:15:39 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi debug doc ldap libnotify test"
+
+RDEPEND="
+ >=gnome-base/gconf-2.0
+ >=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.18
+ >=dev-libs/dbus-glib-0.72
+ >=gnome-base/gnome-keyring-2.25.5
+ net-libs/libsoup:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1.0.0
+ || (
+ =app-crypt/gnupg-1.4*
+ =app-crypt/gnupg-2.0* )
+
+ avahi? ( >=net-dns/avahi-0.6 )
+ ldap? ( net-nds/openldap )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-pgp
+ --enable-ssh
+ --enable-pkcs11
+ --disable-static
+ --disable-scrollkeeper
+ --disable-update-mime-database
+ --enable-hkp
+ $(use_enable avahi sharing)
+ $(use_enable debug)
+ $(use_enable ldap)
+ $(use_enable libnotify)
+ $(use_enable test tests)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=596691
+ epatch "${FILESDIR}/${PN}-2.28.0-as-needed.patch"
+
+ # Make it libtool-1 compatible
+ rm -v m4/lt* m4/libtool.m4 || die "removing libtool macros failed"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+}
+
+pkg_postinst() {
+ einfo "The seahorse-agent tool has been moved to app-crypt/seahorse-plugins"
+ einfo "Use that if you want seahorse to manage your terminal SSH keys"
+}