summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-23 23:12:49 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-23 23:13:16 +0100
commit5aeb293b8561ce9cdb9db10d28584b32d02ef23f (patch)
treef03d2613973c2b82876b4c598eda0499db052cf0 /app-editors
parentdev-util/devhelp: fix linking failure with gold, drop unused patch (diff)
downloadgnome-5aeb293b8561ce9cdb9db10d28584b32d02ef23f.tar.gz
gnome-5aeb293b8561ce9cdb9db10d28584b32d02ef23f.tar.bz2
gnome-5aeb293b8561ce9cdb9db10d28584b32d02ef23f.zip
app-editors/gedit-plugins: 3.4.0 → 3.6.1
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit-plugins/Manifest11
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.6.1.ebuild90
-rw-r--r--app-editors/gedit-plugins/metadata.xml11
3 files changed, 112 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
new file mode 100644
index 00000000..93e57c17
--- /dev/null
+++ b/app-editors/gedit-plugins/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gedit-plugins-3.6.1.tar.xz 1402568 SHA256 c5e92830e6029110bf1117bd9f31b23a9ad907210b8cb37039772f5bfcf6d174 SHA512 71bdcbe427125be1a3b73086c5d1e2c9f51e9fab6e66c6142578cbf2e30f4b2de3264e1301f6232dbc2fee84202ab1d449b1fff6e13c1a7477e23a9418f10b49 WHIRLPOOL 11e860e567f13ace41a09de0585b0e5248589f09ae22d7cd0d8b84d1381617d45c40b865050e9f4d89a243b59624c45bbd493062d6c7fea539a7ee086d72491a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iEYEAREKAAYFAlCv9OIACgkQ1fmVwcYIWAa6RACeOEP2IzfjVRoNBLM4B92mDoyI
+sO0AoM259bmS3iuJdQ7HSFfB/tVh42Fm
+=EKVC
+-----END PGP SIGNATURE-----
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.6.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.6.1.ebuild
new file mode 100644
index 00000000..edb76b6c
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.6.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-3.4.0.ebuild,v 1.3 2012/05/03 18:33:02 jdhore Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="xml"
+PYTHON_USE_WITH_OPT="python"
+
+inherit eutils gnome2 multilib python
+
+DESCRIPTION="Offical plugins for gedit"
+HOMEPAGE="http://live.gnome.org/GeditPlugins"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE_plugins="charmap terminal"
+IUSE="+python ${IUSE_plugins}"
+REQUIRED_USE="charmap? ( python ) terminal? ( python )"
+
+RDEPEND=">=app-editors/gedit-3.2.1[python?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-0.7.3[gtk,python?]
+ >=x11-libs/gtk+-3.4:3
+ >=x11-libs/gtksourceview-3:3.0
+ python? (
+ >=app-editors/gedit-3[introspection]
+ dev-python/dbus-python
+ dev-python/pycairo
+ || (
+ dev-python/pygobject:2[cairo,introspection]
+ dev-python/pygobject:3[cairo] )
+ >=x11-libs/gtk+-3.4:3[introspection]
+ >=x11-libs/gtksourceview-3:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ terminal? ( x11-libs/vte:2.90[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ # DEFAULT_PLUGINS from configure.ac
+ local myplugins="bookmarks,drawspaces,wordcompletion,taglist"
+
+ # python plugins with no extra dependencies beyond what USE=python brings
+ use python && myplugins="${myplugins},bracketcompletion,codecomment,colorpicker,commander,dashboard,joinlines,multiedit,textsize,sessionsaver,smartspaces,synctex"
+
+ # python plugins with extra dependencies
+ for plugin in ${IUSE_plugins/+}; do
+ use ${plugin} && myplugins="${myplugins},${plugin}"
+ done
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+ G2CONF="${G2CONF}
+ --with-plugins=${myplugins}
+ $(use_enable python)"
+
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ use python && python_clean_py-compile_files
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize /usr/{$(get_libdir),share}/gedit/plugins
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use python && python_mod_cleanup /usr/{$(get_libdir),share}/gedit/plugins
+}
diff --git a/app-editors/gedit-plugins/metadata.xml b/app-editors/gedit-plugins/metadata.xml
new file mode 100644
index 00000000..387fb8ac
--- /dev/null
+++ b/app-editors/gedit-plugins/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <longdescription>Official plugins for gedit</longdescription>
+ <use>
+ <flag name="charmap">Insert special characters just by clicking on
+ them</flag>
+ <flag name="terminal">Embed a terminal in the bottom pane</flag>
+ </use>
+</pkgmetadata>