summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-10-13 12:09:30 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2013-11-15 01:39:11 +0100
commit92251f7b929cb92f7e367fc6366a59b16e6deb42 (patch)
treefa0435a5f5e179e619c7130db87722645389d096 /app-editors
parentapp-misc/bijiben: 3.8.4 → 3.10.0 (diff)
downloadgnome-92251f7b929cb92f7e367fc6366a59b16e6deb42.tar.gz
gnome-92251f7b929cb92f7e367fc6366a59b16e6deb42.tar.bz2
gnome-92251f7b929cb92f7e367fc6366a59b16e6deb42.zip
app-editors/gedit: 3.8.3 → 3.10.0
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/Manifest11
-rw-r--r--app-editors/gedit/gedit-3.10.0.ebuild84
-rw-r--r--app-editors/gedit/gedit-9999.ebuild61
3 files changed, 124 insertions, 32 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
new file mode 100644
index 00000000..7e263563
--- /dev/null
+++ b/app-editors/gedit/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gedit-3.10.0.tar.xz 3102112 SHA256 4c20049ccee2198468edaf20fba9dbd44e3baf50bd304700b4f24257571cdca5 SHA512 312b2ffe62e345cf4a15cdd9aa51cdd642d07106bb2a8e834ce656cb88923e6e95b2590ab026c9abf692a48570114878ce6851c2d7725ac02678812e3db32dfc WHIRLPOOL c843e5b4470af0478a23656b180059b7f0f01cdaebe5ed5640fdc0942f6b77d359d308b5838a87b73d45ca8ae4f6b58da3f4e6986d2912e335a536a648b3faf2
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlJacVsACgkQ1fmVwcYIWAa/hgCgjtyZ8xbBgfJjotghTy7unJqv
+MHgAn2eSIV2S0fboBgtg50RV65W1xTcV
+=Y35U
+-----END PGP SIGNATURE-----
diff --git a/app-editors/gedit/gedit-3.10.0.ebuild b/app-editors/gedit/gedit-3.10.0.ebuild
new file mode 100644
index 00000000..62054217
--- /dev/null
+++ b/app-editors/gedit/gedit-3.10.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{2,3} )
+
+inherit eutils gnome2 multilib python-r1 virtualx
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://live.gnome.org/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+introspection +python spell zeitgeist"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+
+# X libs are not needed for OSX (aqua)
+COMMON_DEPEND="
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/glib-2.37.5:2
+ >=x11-libs/gtk+-3.9.9:3[introspection?]
+ >=x11-libs/gtksourceview-3.9.91:3.0[introspection?]
+ >=dev-libs/libpeas-1.7.0[gtk]
+
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+
+ x11-libs/libX11
+
+ net-libs/libsoup:2.4
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-0.9.3
+ >=x11-libs/gtk+-3:3[introspection]
+ >=x11-libs/gtksourceview-3.6:3.0[introspection]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}] )
+ spell? (
+ >=app-text/enchant-1.2:=
+ >=app-text/iso-codes-0.35 )
+ zeitgeist? ( >=gnome-extra/zeitgeist-0.9.12 )
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/scrollkeeper-0.3.11
+ dev-libs/libxml2:2
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+# yelp-tools, gnome-common needed to eautoreconf
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-updater \
+ --enable-gvfs-metadata \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable spell) \
+ $(use_enable zeitgeist) \
+ ITSTOOL=$(type -P true)
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
diff --git a/app-editors/gedit/gedit-9999.ebuild b/app-editors/gedit/gedit-9999.ebuild
index 7580adc3..84d8f06e 100644
--- a/app-editors/gedit/gedit-9999.ebuild
+++ b/app-editors/gedit/gedit-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python3_{2,3} )
-inherit eutils gnome2 multilib python-single-r1 virtualx
+inherit eutils gnome2 multilib python-r1 virtualx
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -15,31 +15,30 @@ fi
DESCRIPTION="A text editor for the GNOME desktop"
HOMEPAGE="http://live.gnome.org/Gedit"
-LICENSE="GPL-2+ CCPL-Attribution-ShareAlike-3.0"
+LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
+
IUSE="+introspection +python spell zeitgeist"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
if [[ ${PV} = 9999 ]]; then
IUSE="${IUSE} doc"
KEYWORDS=""
else
- KEYWORDS="~amd64 ~mips ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
fi
# X libs are not needed for OSX (aqua)
COMMON_DEPEND="
- >=x11-libs/libSM-1.0
>=dev-libs/libxml2-2.5.0:2
- >=dev-libs/glib-2.28:2
- >=x11-libs/gtk+-3.3.15:3[introspection?]
- >=x11-libs/gtksourceview-3.0.0:3.0[introspection?]
- >=dev-libs/libpeas-1.1.0[gtk]
+ >=dev-libs/glib-2.37.5:2
+ >=x11-libs/gtk+-3.9.9:3[introspection?]
+ >=x11-libs/gtksourceview-3.9.91:3.0[introspection?]
+ >=dev-libs/libpeas-1.7.0[gtk]
gnome-base/gsettings-desktop-schemas
gnome-base/gvfs
x11-libs/libX11
- x11-libs/libICE
- x11-libs/libSM
net-libs/libsoup:2.4
@@ -49,14 +48,16 @@ COMMON_DEPEND="
>=dev-libs/gobject-introspection-0.9.3
>=x11-libs/gtk+-3:3[introspection]
>=x11-libs/gtksourceview-3.6:3.0[introspection]
- dev-python/pycairo
+ dev-python/pycairo[${PYTHON_USEDEP}]
>=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}] )
spell? (
>=app-text/enchant-1.2:=
>=app-text/iso-codes-0.35 )
- zeitgeist? ( dev-libs/libzeitgeist )"
+ zeitgeist? ( >=gnome-extra/zeitgeist-0.9.12 )
+"
RDEPEND="${COMMON_DEPEND}
- x11-themes/gnome-icon-theme-symbolic"
+ x11-themes/gnome-icon-theme-symbolic
+"
DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.1.2
>=app-text/scrollkeeper-0.3.11
@@ -74,24 +75,20 @@ if [[ ${PV} = 9999 ]]; then
app-text/yelp-tools"
fi
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
+src_configure() {
+ local myconf=""
+ [[ ${PV} != 9999 ]] && myconf="ITSTOOL=$(type -P true)"
DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
- G2CONF="${G2CONF}
- --disable-deprecations
- --enable-updater
- --enable-gvfs-metadata
- $(use_enable introspection)
- $(use_enable python)
- $(use_enable spell)
- $(use_enable zeitgeist)"
- [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
-
- gnome2_src_prepare
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-updater \
+ --enable-gvfs-metadata \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable spell) \
+ $(use_enable zeitgeist) \
+ ITSTOOL=$(type -P true) \
+ ${myconf}
}
src_test() {