summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-10-13 00:25:25 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-10-13 01:19:07 +0200
commitbd595ad300bd52366175fba9f2f21a245d82c614 (patch)
tree7bd73e1e98fac458af7ebfbdf13a83cbf997ce3d /app-editors
parentx11-wm/mutter: Fix QA (diff)
downloadgnome-bd595ad300bd52366175fba9f2f21a245d82c614.tar.gz
gnome-bd595ad300bd52366175fba9f2f21a245d82c614.tar.bz2
gnome-bd595ad300bd52366175fba9f2f21a245d82c614.zip
app-editors/gedit: switch to copy sources
Some perl script is driving me crazy not working with out-of-source builds.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/files/gedit-3.14.0-fix-install.patch23
-rw-r--r--app-editors/gedit/gedit-3.14.0.ebuild61
-rw-r--r--app-editors/gedit/gedit-9999.ebuild52
3 files changed, 47 insertions, 89 deletions
diff --git a/app-editors/gedit/files/gedit-3.14.0-fix-install.patch b/app-editors/gedit/files/gedit-3.14.0-fix-install.patch
deleted file mode 100644
index e2627ba9..00000000
--- a/app-editors/gedit/files/gedit-3.14.0-fix-install.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 634726ba5be7caa947a676fbe7b8091311b41b62 Mon Sep 17 00:00:00 2001
-From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Sun, 12 Oct 2014 23:20:35 +0200
-Subject: [PATCH] Force creation of directory with out-of-source build
-
----
- plugins/externaltools/data/Makefile.am | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/plugins/externaltools/data/Makefile.am b/plugins/externaltools/data/Makefile.am
-index e3a4707..3a8de2e 100644
---- a/plugins/externaltools/data/Makefile.am
-+++ b/plugins/externaltools/data/Makefile.am
-@@ -59,5 +59,6 @@ CLEANFILES += \
- # generating the .desktop files.
- # If the following bug is fixed, this hack can normally be removed:
- # https://bugs.launchpad.net/intltool/+bug/605826
-+BUILT_SOURCES = $(externaltools_all_desktop_files) $(externaltools_tools_SCRIPTS)
- $(externaltools_all_desktop_files):
- $(AM_V_GEN) $(MKDIR_P) $(top_builddir)/plugins/externaltools/data/
---
-2.1.2
-
diff --git a/app-editors/gedit/gedit-3.14.0.ebuild b/app-editors/gedit/gedit-3.14.0.ebuild
index a8a2570b..339c6ce1 100644
--- a/app-editors/gedit/gedit-3.14.0.ebuild
+++ b/app-editors/gedit/gedit-3.14.0.ebuild
@@ -9,7 +9,7 @@ PYTHON_COMPAT=( python3_{2,3} )
VALA_MIN_API_VERSION="0.26"
VALA_USE_DEPEND="vapigen"
-inherit autotools eutils gnome2 multilib python-r1 vala virtualx
+inherit eutils gnome2 multilib python-r1 vala virtualx
DESCRIPTION="A text editor for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
@@ -70,39 +70,32 @@ src_prepare() {
#sed -e '/g_test_add_func/d' \
# -i tests/document-loader.c || die
- # Fix out-of-source build
- epatch "${FILESDIR}"/${PN}-3.14.0-fix-install.patch
-
- eautoreconf
-
vala_src_prepare
gnome2_src_prepare
+
+ python_copy_sources
}
src_configure() {
DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
- gedit_configure() {
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- --disable-deprecations \
- --enable-updater \
- --enable-gvfs-metadata \
- $(use_enable introspection) \
- $(use_enable spell) \
- $(use_enable vala) \
- ITSTOOL=$(type -P true) \
- "$@"
- }
-
- gedit_py_configure() {
- mkdir -p "${BUILD_DIR}" || die
- run_in_build_dir gedit_configure --enable-python
- }
-
- # run gedit_py_configure first to avoid out-of-source build for C code
- use python && python_parallel_foreach_impl gedit_py_configure
- gedit_configure --disable-python
+ local myconf
+ myconf="
+ --disable-deprecations
+ --enable-updater
+ --enable-gvfs-metadata
+ $(use_enable introspection)
+ $(use_enable spell)
+ $(use_enable vala)
+ $(use_enable python)
+ ITSTOOL=$(type -P true)
+ "
+
+ if use python ; then
+ python_parallel_foreach_impl gnome2_src_configure ${myconf}
+ else
+ gnome2_src_configure ${myconf}
+ fi
}
src_test() {
@@ -114,13 +107,9 @@ src_test() {
}
src_install() {
- gedit_py_install() {
- pushd "${BUILD_DIR}" > /dev/null || die
- # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
- emake DESTDIR="${D}" top_builddir="${S}" pyoverridesdir="$(python_get_sitedir)/gi/overrides" install
- popd > /dev/null
- }
-
- gnome2_src_install
- use python && python_foreach_impl gedit_py_install
+ if use python ; then
+ python_foreach_impl gnome2_src_install
+ else
+ gnome2_src_install
+ fi
}
diff --git a/app-editors/gedit/gedit-9999.ebuild b/app-editors/gedit/gedit-9999.ebuild
index 3d76df01..7d06b78a 100644
--- a/app-editors/gedit/gedit-9999.ebuild
+++ b/app-editors/gedit/gedit-9999.ebuild
@@ -88,27 +88,23 @@ src_configure() {
[[ ${PV} != 9999 ]] && myconf="ITSTOOL=$(type -P true)"
DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
- gedit_configure() {
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- --disable-deprecations \
- --enable-updater \
- --enable-gvfs-metadata \
- $(use_enable introspection) \
- $(use_enable spell) \
- $(use_enable vala) \
- ${myconf} \
- "$@"
- }
-
- gedit_py_configure() {
- mkdir -p "${BUILD_DIR}" || die
- run_in_build_dir gedit_configure --enable-python
- }
-
- # run gedit_py_configure first to avoid out-of-source build for C code
- use python && python_parallel_foreach_impl gedit_py_configure
- gedit_configure --disable-python
+ local myconf
+ myconf="
+ --disable-deprecations
+ --enable-updater
+ --enable-gvfs-metadata
+ $(use_enable introspection)
+ $(use_enable spell)
+ $(use_enable vala)
+ $(use_enable python)
+ ITSTOOL=$(type -P true)
+ "
+
+ if use python ; then
+ python_parallel_foreach_impl gnome2_src_configure ${myconf}
+ else
+ gnome2_src_configure ${myconf}
+ fi
}
src_test() {
@@ -120,13 +116,9 @@ src_test() {
}
src_install() {
- gedit_py_install() {
- pushd "${BUILD_DIR}" > /dev/null || die
- # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
- emake DESTDIR="${D}" top_builddir="${S}" pyoverridesdir="$(python_get_sitedir)/gi/overrides" install
- popd > /dev/null
- }
-
- gnome2_src_install
- use python && python_foreach_impl gedit_py_install
+ if use python ; then
+ python_foreach_impl gnome2_src_install
+ else
+ gnome2_src_install
+ fi
}